View Issue Details

IDProjectCategoryView StatusLast Update
0002862Kali Linux[All Projects] Tool Upgrade Requestpublic2015-11-24 14:02
Reporterg0tmi1k Assigned Tosbrun  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2.0 
Summary0002862: Aircrack-ng 1.2 Release Candidate 3
DescriptionName: Aircrack-ng
Version: 1.2 Release Candidate 3
Homepage: http://aircrack-ng.org/
Download: http://download.aircrack-ng.org/aircrack-ng-1.2-rc3.tar.gz
LICENSE: https://svn.aircrack-ng.org/trunk/LICENSE

Changelog:

Airodump-ng: Prevent sending signal to init which caused the system to reboot/shutdown.
Airbase-ng: Allow to use a user-specified ANonce instead of a randomized one when doing the 4-way handshake
Aircrack-ng: Fixed compilation warnings.
Aircrack-ng: Removed redundant NULL check and fixed typo in another one.
Aircrack-ng: Workaround for segfault when compiling aircrack-ng with clang and gcrypt and running a check.
Airmon-ng: Created version for FreeBSD.
Airmon-ng: Prevent passing invalid values as channel.
Airmon-ng: Handle udev renaming interfaces.
Airmon-ng: Better handling of rfkill.
Airmon-ng: Updated OUI URL.
Airmon-ng: Fix VM detection.
Airmon-ng: Make lsusb optional if there doesn't seem to be a usb bus. Improve pci detection slightly.
Airmon-ng: Various cleanup and fixes (including wording and typos).
Airmon-ng: Display iw errors.
Airmon-ng: Improved handling of non-monitor interfaces.
Airmon-ng: Fixed error when running 'check kill'.
Airdrop-ng: Display error instead of stack trace.
Airmon-ng: Fixed bashism.
Airdecap-ng: Allow specifying output file names.
Airtun-ng: Added missing parameter to help screen.
Besside-ng-crawler: Removed reference to darkircop.org (non-existent subdomain).
Airgraph-ng: Display error when no graph type is specified.
Airgraph-ng: Fixed make install.
Manpages: Fixed, updated and improved airodump-ng, airmon-ng, aircrack-ng, airbase-ng and aireplay-ng manpages.
Aircrack-ng GUI: Fixes issues with wordlists selection.
OSdep: Add missing RADIOTAP_SUPPORT_OVERRIDES check.
OSdep: Fix possible infinite loop.
OSdep: Use a default MTU of 1500 (Linux only).
OSdep: Fixed compilation on OSX.
AppArmor: Improved and added profiles.
General: Fixed warnings reported by clang.
General: Updated TravisCI configuration file
General: Fixed typos in various tools.
General: Fixed clang warning about 'gcry_thread_cbs()' being deprecated with gcrypt > 1.6.0.
General: Fixed compilation on cygwin due to undefined reference to GUID_DEVCLASS_NET
General: Fixed compilation with musl libc.
General: Improved testing and added test cases (make check).
General: Improved mutexes handling in various tools.
General: Fixed memory leaks, use afer free, null termination and return values in various tools and OSdep.
General: Fixed compilation on FreeBSD.
General: Various fixes and improvements to README (wording, compilation, etc).
General: Updated copyrights in help screen.

Relationships

has duplicate 0002863 resolvedsbrun Please update aircrack-ng to version 1.2-rc3 in sana/kali-dev/safi 

Activities

sbrun

2015-11-24 14:02

manager   ~0004273

new version 1:1.2-0~rc3-0kali1 is in sana, safi and kali-rolling

Issue History

Date Modified Username Field Change
2015-11-22 10:05 g0tmi1k New Issue
2015-11-23 07:03 rhertzog Assigned To => sbrun
2015-11-23 07:03 rhertzog Status new => assigned
2015-11-23 07:04 rhertzog Relationship added has duplicate 0002863
2015-11-24 14:02 sbrun Note Added: 0004273
2015-11-24 14:02 sbrun Status assigned => resolved
2015-11-24 14:02 sbrun Resolution open => fixed
2015-11-24 14:02 sbrun Fixed in Version => 2.0
2015-12-04 22:29 alexhj451 Issue cloned: 0002898
2021-05-31 13:37 rhertzog Category Tool Upgrade => Tool Upgrade Request