View Issue Details

IDProjectCategoryView StatusLast Update
0002958Kali Linux[All Projects] General Bugpublic2020-12-01 10:48
Reporterayhaga111 Assigned Torhertzog  
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2.0 
Target VersionFixed in Version 
Summary0002958: E: Failed to fetch http://http.kali.org/kali/pool/main/m/metasploit-framework/metasploit-framework_4.11.5-2015120901-0kali1~r1u1
DescriptionErr http://http.kali.org/kali/ sana/main metasploit-framework amd64 4.11.5-2015120901-0kali1~r1u1
  404 Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/m/metasploit-framework/metasploit-framework_4.11.5-2015120901-0kali1~r1u1_amd64.deb 404 Not Found

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?
Steps To Reproduceapt-get update
apt-get upgrade

Activities

muts

2015-12-22 10:19

reporter   ~0004425

You need to apt-get update...or you have an AV solution blocking the file from being downloaded.

ayhaga111

2015-12-22 13:41

reporter   ~0004426

i did apt-get update and i don't even have an AV
and it failed cause the package was not found, not because anything else

ayhaga111

2015-12-22 13:50

reporter   ~0004427

Last edited: 2015-12-22 14:00

View 2 revisions

actually i can see in http://http.kali.org/kali/pool/main/m/metasploit-framework

metasploit-framework_4.11.5-2015120901-0kali1_amd64.deb
metasploit-framework_4.11.5-2015121501-0kali1_amd64.deb
metasploit-framework_4.11.5-2015121501-0kali1~r1u1_amd64.deb
 and my metasploit is 2015113001-0kali1~r1u1_amd64.deb

i could download and dpkg manually but i fear i will break something

ayhaga111

2015-12-22 13:53

reporter   ~0004428

metasploit-framework 4.11.5-2015120901-0kali1~r1u1.deb doesn't exist

muts

2015-12-22 14:08

reporter   ~0004429

Last edited: 2015-12-22 14:09

View 2 revisions

It is an old and outdated version - check http://http.kali.org/kali/pool/main/m/metasploit-framework/
Make sure you apt-get update first. If this is still an issue, perhaps we are dealing with a stale repository, although that doesn't make much sense.

ayhaga111

2015-12-22 14:18

reporter   ~0004430

Last edited: 2015-12-22 14:20

View 3 revisions

i did apt-get update then apt-get upgrade many times

metasploit is the only broken package ,other packages/programs are upgraded normally

should i download"" metasploit-framework_4.11.5-2015121501-0kali1~r1u1_amd64.deb"" and dpkg it manually for now
"dpkg -i" ??? Thanks

muts

2015-12-22 14:23

reporter   ~0004431

No, better we get to the bottom of this, as updating metasploit works perfectly for me. Can you show me the output of :

curl -sI http://http.kali.org/README

ayhaga111

2015-12-22 14:28

reporter   ~0004432

HTTP/1.1 302 Found
Date: Tue, 22 Dec 2015 14:31:06 GMT
Server: Apache/2.4.10 (Debian)
X-MirrorBrain-Mirror: kali.mirror.garr.it
X-MirrorBrain-Realm: other
Link: <http://http.kali.org/README.meta4>; rel=describedby; type="application/metalink4+xml"
Link: <http://kali.mirror.garr.it/mirrors/kali/README>; rel=duplicate; pri=1; geo=it
Link: <http://archive-3.kali.org/kali/README>; rel=duplicate; pri=2; geo=de
Link: <http://ftp.halifax.rwth-aachen.de/kali/README>; rel=duplicate; pri=3; geo=de
Link: <http://ftp.belnet.be/kali/kali/README>; rel=duplicate; pri=4; geo=be
Link: <http://ftp.free.fr/pub/kali/README>; rel=duplicate; pri=5; geo=fr
Location: http://kali.mirror.garr.it/mirrors/kali/README
Content-Type: text/html; charset=iso-8859-1

ayhaga111

2015-12-22 14:36

reporter   ~0004433

Last edited: 2015-12-22 14:38

View 2 revisions

I just remembered
I tried doing msfupdate and i could see that i am downloading but nothing was shown on the terminal as downloading or even any action so i aborted, rebooted and then apt-get update
but i did that before and nothing broke

machaith

2015-12-23 04:51

reporter   ~0004435

I'm Having the same issue on multiple machines, the A\V was blocking part of the update, but even disabling the A\V, reboot kali and trying to update gave the same issue.

Trying to update using msfupdate gave the following output:

[*]
[*] Attempting to update the Metasploit Framework...
[*]

[*] Checking for updates via the APT repository
[*] Note: expect weekly(ish) updates using this method
[*] Updating to version 4.11.5-2015120901-0kali1~r1u1
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  metasploit-framework
1 upgraded, 0 newly installed, 0 to remove and 29 not upgraded.
Need to get 58.3 MB of archives.
After this operation, 36.9 kB of additional disk space will be used.
Err http://http.kali.org/kali/ sana/main metasploit-framework i386 4.11.5-2015120901-0kali1~r1u1
  404 Not Found
E: Failed to fetch http://http.kali.org/kali/pool/main/m/metasploit-framework/metasploit-framework_4.11.5-2015120901-0kali1~r1u1_i386.deb 404 Not Found

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

machaith

2015-12-23 05:10

reporter   ~0004436

I tried a new machine that was not interrupted by the A\V before, and I got the same error

Fetched 55.1 MB in 1min 32s (596 kB/s)
E: Failed to fetch http://http.kali.org/kali/pool/main/m/metasploit-framework/metasploit-framework_4.11.5-2015120901-0kali1~r1u1_i386.deb 404 Not Found

E: Unable to fetch some archives, maybe run apt-get update or try with --fix-missing?

ayhaga111

2015-12-23 06:11

reporter   ~0004437

I never had an AV

rhertzog

2015-12-23 09:00

administrator   ~0004438

I disabled kali.mirror.garr.it until I can check the status of this mirror. They made some changes recently, nothing was supposed to break but it looks like it did not work well.

rhertzog

2015-12-23 20:48

administrator   ~0004440

kali.mirror.garr.it has been fixed.

Issue History

Date Modified Username Field Change
2015-12-22 08:39 ayhaga111 New Issue
2015-12-22 10:19 muts Note Added: 0004425
2015-12-22 10:19 muts Status new => closed
2015-12-22 10:19 muts Assigned To => muts
2015-12-22 10:19 muts Resolution open => no change required
2015-12-22 13:41 ayhaga111 Note Added: 0004426
2015-12-22 13:41 ayhaga111 Status closed => feedback
2015-12-22 13:41 ayhaga111 Resolution no change required => reopened
2015-12-22 13:50 ayhaga111 Note Added: 0004427
2015-12-22 13:50 ayhaga111 Status feedback => assigned
2015-12-22 13:53 ayhaga111 Note Added: 0004428
2015-12-22 14:00 ayhaga111 Note Edited: 0004427 View Revisions
2015-12-22 14:08 muts Note Added: 0004429
2015-12-22 14:08 muts Status assigned => closed
2015-12-22 14:08 muts Resolution reopened => no change required
2015-12-22 14:09 muts Note Edited: 0004429 View Revisions
2015-12-22 14:18 ayhaga111 Note Added: 0004430
2015-12-22 14:18 ayhaga111 Status closed => feedback
2015-12-22 14:18 ayhaga111 Resolution no change required => reopened
2015-12-22 14:18 ayhaga111 Note Edited: 0004430 View Revisions
2015-12-22 14:20 ayhaga111 Note Edited: 0004430 View Revisions
2015-12-22 14:23 muts Note Added: 0004431
2015-12-22 14:28 ayhaga111 Note Added: 0004432
2015-12-22 14:28 ayhaga111 Status feedback => assigned
2015-12-22 14:36 ayhaga111 Note Added: 0004433
2015-12-22 14:38 ayhaga111 Note Edited: 0004433 View Revisions
2015-12-23 04:51 machaith Note Added: 0004435
2015-12-23 05:10 machaith Note Added: 0004436
2015-12-23 06:11 ayhaga111 Note Added: 0004437
2015-12-23 08:59 rhertzog Assigned To muts => rhertzog
2015-12-23 09:00 rhertzog Note Added: 0004438
2015-12-23 20:48 rhertzog Note Added: 0004440
2015-12-23 20:48 rhertzog Status assigned => resolved
2015-12-23 20:48 rhertzog Resolution reopened => fixed
2020-12-01 10:48 g0tmi1k Priority high => normal