View Issue Details

IDProjectCategoryView StatusLast Update
0003127Kali Linux[All Projects] Kali Package Improvementpublic2016-03-09 10:47
Reporteresaumell Assigned Torhertzog  
PrioritynormalSeveritycrashReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version 
Summary0003127: "Could not find rake-10.4.2 in any of the sources" after dist-upgrade
DescriptionAfter shooting an apt-get update&&apt-get dist-upgrade on a recently downloaded Kali 2016.1 VM I got this error:

Could not find rake-10.4.2 in any of the sources

Trying to execute mfsconsole gave the same error.

To fix it:

cd /usr/share/metasploit-framework/
bundle install

In my case, 'bundle install' throw errors while installing:

Installing pg 0.18.4 with native extensions
Installing pcaprub 0.12.1 with native extensions
Installing sqlite3 1.3.11 with native extensions

pg and sqlite3 errors are self explanatory,
pg needs: apt install postgresql-server-dev-9.5
sqlite3 needs: apt install libsqlite3-dev
pcaprub needs: Since others needed dev libraries, I guess that pcap also wants them so: apt install libpcap0.8-dev

Now msfconsole is working again :D
Additional InformationSource: http://netneo.co.uk/2015/02/kali-raspberry-pi-msfconsole-run-error-could-not-find-rake-10-4-2-in-any-of-the-sources/

Activities

rhertzog

2016-03-09 10:47

administrator   ~0004830

Those instructions will fix your setup in the short term but will break it on the long term...

We have released metasploit-framework 4.11.14-0kali1+b1 to fix this.

Issue History

Date Modified Username Field Change
2016-03-08 18:50 esaumell New Issue
2016-03-09 10:47 rhertzog Note Added: 0004830
2016-03-09 10:47 rhertzog Status new => resolved
2016-03-09 10:47 rhertzog Resolution open => fixed
2016-03-09 10:47 rhertzog Assigned To => rhertzog