View Issue Details

IDProjectCategoryView StatusLast Update
0003195Kali Linux[All Projects] Queued Tool Additionpublic2021-05-18 11:03
Reportersteev Assigned Torhertzog  
PrioritylowSeverityfeatureReproducibilityalways
Status resolvedResolutionfixed 
Product Versionkali-dev 
Target Version2016.2Fixed in Version2016.2 
Summary0003195: make dh-make-golang available on arm64
DescriptionIt would be nice to have dh-make-golang available on arm64

More and more people are starting to get into golang, and it would be nice to give them the opportunity to use a tool to create proper debs.

I'd also like it for a personal project that I'm working on, and I've tested importing it following the wiki instructions and it seems to work.

Activities

rhertzog

2016-03-29 06:06

administrator   ~0005039

dh-make-golang is already available:
http://pkg.kali.org/pkg/dh-make-golang

Did I miss anything?

steev

2016-03-29 06:12

developer   ~0005040

Last edited: 2016-03-29 06:12

View 2 revisions

Weird, the pkg site claims it's arch any, but

steev@eren:~ $ sudo apt update
Hit:1 http://repo.kali.org/kali kali-rolling InRelease
Hit:2 http://repo.kali.org/kali kali-bleeding-edge InRelease
Hit:3 http://repo.kali.org/kali kali-dev InRelease
Reading package lists... Done
Building dependency tree
Reading state information... Done
All packages are up to date.
steev@eren:~ $ apt search dh-make-golang
Sorting... Done
Full Text Search... Done
steev@eren:~ $

I guess I should mention this is arm64

rhertzog

2016-03-29 06:49

administrator   ~0005042

Ah yes, it's not yet available on arm64 for some reason... according to https://buildd.debian.org/status/package.php?p=dh-make-golang it got built but it was never accepted in the archive. I have asked the build daemon maintainer to do something about this (re-upload or re-trigger a build).

rhertzog

2016-03-29 09:03

administrator   ~0005045

I filed a bug on the Debian side: https://bugs.debian.org/819472

(and also https://bugs.debian.org/819473 which is really the root cause)

The fix is trivial. I will wait to check if the maintainer reacts. Otherwise I will fix it myself.

rhertzog

2016-03-29 09:05

administrator   ~0005046

In the mean time I scheduled a build on Kali, as we don't have any check that rejects invalid Built-Using field here.

rhertzog

2016-04-07 09:36

administrator   ~0005099

So this kali-only arm64 build is now available in kali-rolling and I uploaded a fix on the debian side as well so that everything goes back to normal soon.

Issue History

Date Modified Username Field Change
2016-03-29 05:42 steev New Issue
2016-03-29 05:42 steev Status new => assigned
2016-03-29 05:42 steev Assigned To => rhertzog
2016-03-29 06:06 rhertzog Note Added: 0005039
2016-03-29 06:07 rhertzog Status assigned => feedback
2016-03-29 06:12 steev Note Added: 0005040
2016-03-29 06:12 steev Status feedback => assigned
2016-03-29 06:12 steev Note Edited: 0005040 View Revisions
2016-03-29 06:49 rhertzog Note Added: 0005042
2016-03-29 09:03 rhertzog Note Added: 0005045
2016-03-29 09:03 rhertzog Summary dh-make-golang import request => make dh-make-golang available on arm64
2016-03-29 09:03 rhertzog Description Updated View Revisions
2016-03-29 09:05 rhertzog Note Added: 0005046
2016-04-07 09:36 rhertzog Note Added: 0005099
2016-04-07 09:36 rhertzog Status assigned => resolved
2016-04-07 09:36 rhertzog Fixed in Version => 2016.2
2016-04-07 09:36 rhertzog Resolution open => fixed
2021-05-18 11:03 g0tmi1k Category New Tool Requests => Queued Tool Addition