View Issue Details

IDProjectCategoryView StatusLast Update
0003260Kali Linux[All Projects] Feature Requestspublic2018-06-29 20:57
ReporterkcdtvAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2016.1 
Target Version2017.1Fixed in Version 
Summary0003260: Support for RTL8812AU (realtek "ac" wifi chip )
DescriptionThe RTL8812AU is an ac chipset that can be found in the alfa network AWUS036ACH.
No drivers are included in kali eventhought realtek provides some. I was not able to install the ones provided in the DvD (little fail at compiling) but i was able to get it works using the drivers provided in this github branch : https://github.com/diederikdehaas/rtl8812AU
device works fine in managed mode, i couldn't try the ac mode as my access point does not support it, will try soon.
mode monitor couldn't be enabled with airmon-ng but it could be enabled with iwconfig on the wlanX interface. snifing packets works very well, injection... i am not so sure, the aireplay-ng test was giving back 0/30 on all access point tested.Some details to fix but i have the feeling that this chipset could work and give great results with kali linux. i am ready to test whatever and have the device. cheers

Activities

skan

skan

2016-09-22 15:34

reporter   ~0005977

I'm also very interested in having support for the RTL8812AU chipset.
That chipset is also included in many other devices made by TP-Link, Comfast, Alfa, D-Link, Belkin, and an increasing number of manufacturers.
kcdtv

kcdtv

2017-02-12 21:28

reporter   ~0006367

Good news! astsam created a Git Hub branch with drivers that support packet injection! You can find them here: https://github.com/astsam/rtl8812au .
He made them compatible with kali Linux (see: https://github.com/astsam/rtl8812au/issues/7 )
 I strongly suggest to introduce them in Kali linux repositories :)
kimocoder

kimocoder

2017-02-12 21:35

reporter   ~0006368

Just a sticky note for these drivers, many of the RTL drivers are to be found here:

https://github.com/lwfinger/rtlwifi_new

really nice repo. Will try to collaborate these to repos and sync them into the rtlwifi_new :) Thanks!
kimocoder

kimocoder

2017-02-12 21:38

reporter   ~0006369

Looking into it, the "https://github.com/astsam/rtl8812au/" is finished and ready to GO for Kali :) Nice catch kcdtv -- again thanks!
skan

skan

2017-02-12 21:52

reporter   ~0006370

Great news!!.

So, Will those drivers be included in the next Kali release?
Or will we need to install them manually from that repository instead?
kimocoder

kimocoder

2017-02-12 22:15

reporter   ~0006371

To be clear, I got no jurisdiction to make those call since I'm NOT an official Kali developer, but run them manually for now, and we'll see if devs include it.. I'm pretty sure it will be done :) It's ready2go so why not
kcdtv

kcdtv

2017-02-12 22:50

reporter   ~0006373

Thank you very much to you!
Notice that there is a second branch in satsam with power managment and it works find ( git clone -b v4.3.21 https://github.com/astsam/rtl8812au.git.) The driver is very stable, there is still some very little improvements to do to have it "perfect". I don't know if the branch 4.3.1 will become main and when. I am sure that with your expertise, general collaboration and his very good work we gonna reach perfection. :D
It is also to e noticed that alfa network just released a MIMO4T4R USB high power device with the rtl8814au. Looking at the drivers i have the feeling that it will be possible to implement injection following the same steps... 2017 will be the year for wifi ac injection :)
sbrun

sbrun

2017-04-07 11:57

manager   ~0006567

we created a package realtek-rtl88xxau-dkms for these drivers.
The package is in kali-dev and will be soon in kali-rolling.
Please test it and let us know if it works.
kcdtv

kcdtv

2017-04-08 12:56

reporter   ~0006573

Very good job!
  Installing the dkms package is trivial
You did use the good branch (tx power control is enabled, I checked) and used the latest version: I can see that straightforward in an airodump-ng shell because it doesn't have the message "chanel -1"
  I'll receive next week a device with RTL8814AU and i will let you know how it went. Compiling has to be done specifying rtl8114au, I don't know if you considered that doing the dkms package.
  Anyway... For me this dkms package is fully satisfactory and could go right now in kali linux main repository.
sbrun

sbrun

2017-04-11 08:21

manager   ~0006577

"Compiling has to be done specifying rtl8814au": yes I noticed that. The package builds and installs the two drivers 8812au and 8814au

Please feel free to reopen the bug or open a new one if you have a problem with one of the drivers.

Issue History

Date Modified Username Field Change
2016-04-30 10:40 kcdtv New Issue
2016-09-22 15:34 skan Note Added: 0005977
2017-02-12 21:28 kcdtv Note Added: 0006367
2017-02-12 21:35 kimocoder Note Added: 0006368
2017-02-12 21:38 kimocoder Note Added: 0006369
2017-02-12 21:52 skan Note Added: 0006370
2017-02-12 22:15 kimocoder Note Added: 0006371
2017-02-12 22:50 kcdtv Note Added: 0006373
2017-03-30 13:33 rhertzog Assigned To => sbrun
2017-03-30 13:33 rhertzog Status new => assigned
2017-03-30 18:49 rhertzog Target Version => 2017.1
2017-04-07 11:57 sbrun Note Added: 0006567
2017-04-08 12:56 kcdtv Note Added: 0006573
2017-04-11 08:21 sbrun Status assigned => resolved
2017-04-11 08:21 sbrun Resolution open => fixed
2017-04-11 08:21 sbrun Note Added: 0006577