View Issue Details

IDProjectCategoryView StatusLast Update
0003274Kali Linux[All Projects] Kali Package Bugpublic2016-05-11 13:56
Reportervanguard Assigned Torhertzog  
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version2016.2 
Summary0003274: kernel panic with latest live images
DescriptionHi team,
I regularly build 32-bit version of kali using live-build. The build is working fine, but I discovered, that the finished kali-livefile is crashing at boot. I get kernel-panic.

This also happens, when booting in safe-option.
 
Steps To ReproduceI tried several kind of builds:

1. Within a running livesystem - build ok, boot crash.
2. Build within an actual and installed kali-linux - build ok, boot crash.
3. Build command: ./build.sh --options.... build ok, boot crash
4. Build command: lb clean --purge , lb config --options...., lb build - build ok, boot crash

All builds were don within a 32-bit as well as in a 64-bit ennvironment.
Additional InformationFormer builds were running fine and worked fine.
The crashes also appeear in virtual environment (like Virtualbox)

Thank you for any help!

Activities

vanguard

2016-05-07 16:28

reporter  

VBox.log (101,201 bytes)

vanguard

2016-05-07 16:29

reporter   ~0005196

Added VirtualBox Logfile (as it crashes there, too). Hope it helps!

Best

Hans

vanguard

2016-05-09 07:31

reporter   ~0005198

Crashes not only on EEEPC. Crashes on all systens!

rhertzog

2016-05-09 08:14

administrator   ~0005199

I'm sorry but you don't provide enough information. Can you provide screenshot of the crash? The output of dmesg?

What CPU do you use? Is there are version of Kali that was working for you?

Etc. Without any concrete element, I'll just close the ticket and ask you to get support on forums and on IRC.

vanguard

2016-05-09 09:07

reporter   ~0005203

Yes, no problem. I attached a video of the boot process. As you can see, I cannot start dmesg, as the boot crashes (how can this be called, when I cannot boot??)

The boot crashes on EVERY cpu, not only on EEEPC.

I made the video in virtualbox, as there is no difference by booting native or in virtualbox.

The last versions, which build fine and worked fine were about 4 weeks ago (I am building unregularly, mostly within 1 or 2 weeks, so I cannot tell exactly the day).

I believe, it has soemthing to do with the build process, as I have kali-linux installed on several systems and those are booting fine.

The builds I am doing (and which worked before) could done in two ways. First one is the original way:

lb clean
lb config -a i386 --distribution kali-rolling --bootappend-live "boot=live noconfig=sudo username=root hostname=kali ignore_uuid locales=de_DE.UTF-8 keyboard-layouts=de keyboard-variants=nodeadkeys"
lb build

This worked well and I could also use apt-cacher-ng.

The second way is the one, you are prefer on your website:
./build.sh --arch i386 --distribution kali-rolling --variant lxde --verbose -- --bootappend-live "boot=live noconfig=sudo username=root hostname=kali ignore_uuid locales=de_DE.UTF-8 keyboard-layouts=de keyboard-variants=nodeadkeys"
.
This way also worked fine, but apt-cacher-ng can not bed used, as build.sh purges everything in the first step.

As I already told: both ways are building fine, both ways crash at boot.

More informagtion: I made a fresh git-download and build within a kali livesystem as well as on a native installed kali-linux (both native were kali-rolling) = all crash.

What else is to say? I wondered, why kali-linux has changed to use the "./build.sh" command, as this is not that, what the live-build-manual requires.

At the moment I am trying a new build, but that will last several hours. When finished, I can send the build.log, if needed.

Hope this helps a little bit.

Best regards

Hans

rhertzog

2016-05-09 10:04

administrator   ~0005207

Yes, please provide the log file of the build.

I guess you don't have the same problem with our official images, right?

And what about daily images here? http://archive.kali.org/kali-daily-images/kali-linux-light-rolling-i386.iso

Somehow I have the feeling that your CPU are not compatible with the 686-class of CPU required by the i386 architecture nowadays. See debian.org/debian-devel-announce/2016/05/msg00001.html

vanguard

2016-05-09 10:24

reporter   ~0005211

This is nonsense! 4 weks ago everything is working. And now it crashes on ALL my computers? I repeat: The crash is showing on ALL cpus and ONLY on a build livefilesystem.
And every build was done on DIFFERENT computers, and ENVIRONMENTS to make sure, the environment and the cpu's are NOT the problem.

The problem IMO exists in the kind of making the build or in the git itself.

However, I will test a daily-build iso, of course. If that boots, I will then build a new livefile within this environment. This will last several hours, so maybe I can report tomorrow the results.

Best

Hans

vanguard

2016-05-09 10:59

reporter   ~0005216

> I guess you don't have the same problem with our official images, right?
My prior builds (5 weeks old from now) are all running fine.

> And what about daily images here? http://archive.kali.org/kali-daily-images/kali-
> linux-light-rolling-i386.iso

I downloaded and checked: This one is crashing, too.

Meanwhile I contacted Ben Hutchinson and he confirmed, all my cpu's are still supported.

Hans

rhertzog

2016-05-09 12:06

administrator   ~0005218

Can you attach the video that you promised?

What kernel version are you using?

vanguard

2016-05-09 12:14

reporter   ~0005219

Of course. I uploaded it again. Maybe I uploaded it at the wrong bugreport. However, here it is again.

vanguard

2016-05-09 12:26

reporter   ~0005221

Sorry again. Seems the video is too big for this site (2MB). Please download it here:

http://www.ccpeine.de/wp-content/kali2.webm

Thank you!

Hans

rhertzog

2016-05-09 15:20

administrator   ~0005222

So I confirmed the problem and it is not i386 specific. It seems to be a recent regression. It's also reported on the Debian side:
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=823069

I'm looking if https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=823323 is also not related to this. At least it would make sense.

vanguard

2016-05-09 15:41

reporter   ~0005224

Yes, I think so, too. This would also explain, why an installed kali-linux is booting fine, and only the livefile is crashing.

When the related fixed packages are in the repo of kali-rolling, I will soon build a new iso and test it out. Report follows then after build.

Each build lasts about 6-8 hours on my system, so please be patient. I will then try both ways: lb config > lb build, and the recommended way with ./build.sh.

I prefer the first one, because I can use apt-cacher-ng with it, with the second way this does not work and every build needs to download all packagaes again and again.

Thumbs up!

Hans

rhertzog

2016-05-09 18:42

administrator   ~0005225

The bug has been tracked down to a regression in util-linux's mount implementation: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=823856

rhertzog

2016-05-11 13:56

administrator   ~0005236

This bug has been fixed with live-boot 20160511~kali1 that I just uploaded to Kali (copy of the version I sent to Debian at the same time).

Issue History

Date Modified Username Field Change
2016-05-04 17:03 vanguard New Issue
2016-05-07 16:28 vanguard File Added: VBox.log
2016-05-07 16:29 vanguard Note Added: 0005196
2016-05-09 07:31 vanguard Note Added: 0005198
2016-05-09 08:14 rhertzog Note Added: 0005199
2016-05-09 09:07 vanguard Note Added: 0005203
2016-05-09 10:04 rhertzog Note Added: 0005207
2016-05-09 10:24 vanguard Note Added: 0005211
2016-05-09 10:59 vanguard Note Added: 0005216
2016-05-09 12:06 rhertzog Note Added: 0005218
2016-05-09 12:14 vanguard Note Added: 0005219
2016-05-09 12:26 vanguard Note Added: 0005221
2016-05-09 15:20 rhertzog Note Added: 0005222
2016-05-09 15:20 rhertzog Assigned To => rhertzog
2016-05-09 15:20 rhertzog Status new => assigned
2016-05-09 15:20 rhertzog Summary Kali-livefile crashes at boot on EEEPC => kernel panic with latest live images
2016-05-09 15:41 vanguard Note Added: 0005224
2016-05-09 18:42 rhertzog Note Added: 0005225
2016-05-11 13:56 rhertzog Note Added: 0005236
2016-05-11 13:56 rhertzog Status assigned => resolved
2016-05-11 13:56 rhertzog Fixed in Version => 2016.2
2016-05-11 13:56 rhertzog Resolution open => fixed