View Issue Details

IDProjectCategoryView StatusLast Update
0003417Kali Linux[All Projects] General Bugpublic2016-07-18 19:35
ReporterfyzbytAssigned Torhertzog 
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version 
Summary0003417: netboot fails when retrieving libc6-udev
DescriptionWhen trying to boot off the most recent netboot install, the install fails giving a "Loading libc6-udeb failed for unknown reasons. Aborting" message. The debug console shows retrieving libc6-udev 2.23-1 and then segfaults.

After this point, all available menu steps fail on themselves, and the debug menu reports a segmentation fault. Using a seperate ptty to get a dump fails as it won't open a new terminal (just repeats "Please Press Enter to activate this console" and reports a segfault in debug.
Steps To ReproduceStart install from netboot image.

Wait.

*error*

Activities

fyzbyt

2016-07-15 19:31

reporter   ~0005542

It does take additional steps between starting netboot and failure. Original error was reported with a preseed.cfg that would automatically set settings. Failure is at Partition Disks, and has been tried across several different systems with similar results.

rhertzog

2016-07-15 22:40

administrator   ~0005543

I just scheduled a rebuild of the debian-installer images to fix this. It's due to to the new libc6 switch (2.22 -> 2.23).

Please try again with the new ISO once http://http.kali.org/dists/kali-dev/main/installer-amd64/ contains version 20160516+kali1+b1.

fyzbyt

2016-07-18 16:46

reporter   ~0005546

This appears to be fixed, after downloading the new netboot install, the process is successfully passing that step.

Thank you!

Fyz

Issue History

Date Modified Username Field Change
2016-07-15 19:20 fyzbyt New Issue
2016-07-15 19:31 fyzbyt Note Added: 0005542
2016-07-15 22:36 rhertzog Assigned To => rhertzog
2016-07-15 22:36 rhertzog Status new => assigned
2016-07-15 22:40 rhertzog Note Added: 0005543
2016-07-18 16:46 fyzbyt Note Added: 0005546
2016-07-18 19:35 rhertzog Status assigned => resolved
2016-07-18 19:35 rhertzog Resolution open => fixed