2017-11-22 12:46 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003426Kali Linux[All Projects] Kali Package Bugpublic2017-02-03 14:04
Reportereapolsniper 
Assigned Torhertzog 
PrioritynormalSeveritymajorReproducibilityhave not tried
StatusclosedResolutionfixed 
Product Version2016.1 
Target VersionFixed in Version2017.1 
Summary0003426: open-vm-tools missing from repo
DescriptionThe Kali open-vm-tools and open-vm-tools-desktop packages are missing from the Kali repo as of sometime in July. Another user has metioned the same in the forums under the sticky Vmware Tools thread.

apt/sources is set to: deb http://http.kali.org/kali kali-rolling main non-free coontrib

I'm pulling from http://kali.localmsp.org/kali kali-rolling InRelease

Steps To ReproduceFresh install of Kali Rolling
apt-get update
apt-get dist-upgrade
reboot
apt-get update
apt search open-vm (no results)
Attached Files

-Relationships
+Relationships

-Notes

~0005552

g0tmi1k (administrator)

Upstream: https://tracker.debian.org/pkg/open-vm-tools

~0005553

rhertzog (administrator)

I copied the package from Debian unstable and rebuilt the binary packages so that they are installable. This is now fixed.

~0006111

g0tmi1k (administrator)

Looks like its gone again:

[2016-11-11] open-vm-tools REMOVED from testing (Debian testing watch)

~0006112

teward001 (reporter)

You will need to import them and likely hold them in the repository for some time. The core problem is the OPenSSL migration, and an FTBFS. See https://packages.qa.debian.org/o/open-vm-tools/news/20161111T163922Z.html for the removal reasons (the ongoing OpenSSL 1.1.0 migration is causing hell for everyone)

~0006305

rhertzog (administrator)

The packages came back a long time ago.
+Notes

-Issue History
Date Modified Username Field Change
2016-07-18 22:40 eapolsniper New Issue
2016-07-19 07:35 g0tmi1k Note Added: 0005552
2016-07-19 13:55 rhertzog Note Added: 0005553
2016-07-19 13:55 rhertzog Status new => resolved
2016-07-19 13:55 rhertzog Resolution open => fixed
2016-07-19 13:55 rhertzog Assigned To => rhertzog
2016-11-12 20:51 g0tmi1k Status resolved => feedback
2016-11-12 20:51 g0tmi1k Resolution fixed => reopened
2016-11-12 20:51 g0tmi1k Note Added: 0006111
2016-11-12 22:07 teward001 Note Added: 0006112
2017-02-03 14:04 rhertzog Status feedback => closed
2017-02-03 14:04 rhertzog Resolution reopened => fixed
2017-02-03 14:04 rhertzog Fixed in Version => 2017.1
2017-02-03 14:04 rhertzog Note Added: 0006305
+Issue History