2017-09-25 18:44 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0003473Kali Linux[All Projects] Kali Package Bugpublic2016-09-02 13:16
Reporterlostincynicism 
Assigned Torhertzog 
PriorityhighSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version2016.2 
Target VersionFixed in Version2017.1 
Summary0003473: unable to move aside './usr/share/bug/gedit' to install new version: Invalid cross-device link
DescriptionOn a persistent live filesystem, it is impossible to upgrade packages that replace a directory with a file. This is a limitation of the "overlay" filesystem. See https://bugs.debian.org/836211


Original description:

gedit in the gedit_3.20.2-2_amd64.deb appears to be corrupt. As a result, x crashes on reboot. Since kali-desktop-gnome requires gedit to be installed, one can't uninstall it without also uninstalling gnome.

Steps To ReproduceI have tried this on multiple new USB drives from different manufacturers to eradicate possible usb thumb drive failures/bad manufacturing run.

Hardware used:

Viking 32gb USB 3.0 thumb drive
SanDisk Ultra 32gb USB 3.0 Thumb Drive (repro's on both)

Lenovo T420, i5 8gb RAM, 160gb Intel SSD

--------------------------------------------------------------------------------

Grab the fresh ISO from the Kali download page. Create a Kali Live USB stick with Encrypted Persistence.

Boot into Kali, and update:

apt-get update
apt-get upgrade

Gedit will fail to install with the error:

Errors were encountered while processing:
 /var/cache/apt/archives/gedit_3.20.2-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1

2.

Unpacking gedit (3.20.2-2) over (3.18.2-1) ...
dpkg: error processing archive /var/cache/apt/archives/gedit_3.20.2-2_amd64.deb (--unpack):
 unable to move aside './usr/share/bug/gedit' to install new version: Invalid cross-device link

Bug 0003361 also references this issue, but with less info or repro steps.

rhertzog recommends removing '/usr/share/bug/gedit'. I tried this, but after running 'apt-get -f install', it complains about not being able to 'securely remove' the dpkg temp file for gedit. I also removed this file as well, which only further aggravates the situation. Trying 'apt-get -f install' then complains:

 Package is in a very bad inconsistent state - you should
 reinstall it before attempting a removal.

Reinstallation also fails in the same manner as the summarized issue. Something is not right.

MD5 of the package: 70759d412f8db08028ee60e1300e6707
Additional InformationRelated bug:

https://bugs.kali.org/view.php?id=3361
Attached Files

-Relationships
+Relationships

-Notes

~0005627

lostincynicism (reporter)

I've reinstalled Kali in this manner 3 different times, and get the same end result.

~0005628

lostincynicism (reporter)

I noticed the package is from the debian sid repository and has the same checksum

~0005630

rhertzog (administrator)

I doubt that gedit is the root cause of your problems. gedit alone can't affect the X server, it's rather some other underlying problem which results in breaking gedit and X!

The error message still leads me to believe that we have some sort of file system problem... maybe related to encrypted persistence since that's what you're using and since the problem is not otherwise reproducible.

Have you done some hardware checks to ensure you don't have a bad RAM module?

Do you also have the problem if you only upgrade "gedit" on first boot?

apt-get update
apt-get install gedit

~0005631

rhertzog (administrator)

Also output of "ls -al /usr/share/bug/" before and after the failing upgrade would be interesting.

~0005632

rhertzog (administrator)

More interestingly, can you also reproduce the problem with a daily image that you can download here: http://archive.kali.org/kali-daily-images/ ?

~0005633

harveyUK47 (reporter)

I have also reported the issue in 0003473.

root@kali:~# apt-get update
Hit:1 http://ftp.hands.com/kali kali-rolling InRelease
Reading package lists... Done
root@kali:~# apt-get install gedit
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  caribou-antler castxml creepy dff gccxml gir1.2-clutter-gst-2.0 gir1.2-gkbd-3.0 gir1.2-packagekitglib-1.0 gir1.2-xkl-1.0 gnome-icon-theme-symbolic gtk2-engines gucharmap inguma libapache2-mod-php5
  libasn1-8-heimdal libavcodec-ffmpeg56 libavdevice-ffmpeg56 libavfilter-ffmpeg5 libavformat-ffmpeg56 libavresample-ffmpeg2 libavutil-ffmpeg54 libbasicusageenvironment0 libbind9-90 libboost-filesystem1.58.0
  libboost-python1.58.0 libboost-python1.61.0 libboost-system1.58.0 libboost-thread1.58.0 libcamel-1.2-54 libclutter-gst-2.0-0 libcrypto++9v5 libdbus-1-dev libdns100 libexporter-tiny-perl libgdict-1.0-9
  libgif4 libgrilo-0.2-1 libgroupsock1 libgssapi3-heimdal libgtkglext1 libgucharmap-2-90-7 libhcrypto4-heimdal libhdb9-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhunspell-1.3-0 libhx509-5-heimdal
  libical1a libilmbase6v5 libisc95 libisccc90 libisccfg90 libjansson4 libjasper1 libkdc2-heimdal libkrb5-26-heimdal liblist-moreutils-perl liblivemedia23 libllvm3.7 liblouis9 liblwres90 libntdb1 libonig2
  libopenexr6v5 libopenjpeg5 libpff1 libpgm-5.1-0 libphonon4 libpng12-0 libpoppler57 libpostproc-ffmpeg53 libpth20 libpython3.4-minimal libpython3.4-stdlib libqdbm14 libqmi-glib1 libquvi-scripts libquvi7
  libregfi0 libroken18-heimdal libsodium13 libswresample-ffmpeg1 libswscale-ffmpeg3 libtask-weaken-perl libtre5 libtrio2 libusageenvironment1 libusbmuxd2 libwebp5 libwebpdemux1 libwebpmux1
  libwebrtc-audio-processing-0 libwind0-heimdal libx265-68 libyara3 libzip2 libzmq3 multiforcer phonon phonon-backend-vlc php5 php5-cli php5-common php5-json php5-mysql php5-readline python-apsw python-bluez
  python-characteristic python-ctypeslib python-dbus-dev python-distlib python-dominate python-ecdsa python-flickrapi python-googleapi python-instagram python-jwt python-lzma python-lzo python-magic
  python-ntdb python-oauth2client python-oauthlib python-opengl python-pyatspi python-pyexiv2 python-pyexiv2-doc python-pyqtgraph python-qt4-gl python-qt4-phonon python-requests-oauthlib
  python-requests-toolbelt python-rsa python-tidylib python-tweepy python-uritemplate python-yapsy python3.4 python3.4-minimal ratproxy ruby-rainbow ruby-rexec ruby2.2-dev system-config-printer
Use 'apt autoremove' to remove them.
Suggested packages:
  gedit-plugins
The following packages will be upgraded:
  gedit
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
1673 not fully installed or removed.
Need to get 0 B/414 kB of archives.
After this operation, 106 kB of additional disk space will be used.
Reading changelogs... Done
(Reading database ... 318516 files and directories currently installed.)
Preparing to unpack .../gedit_3.20.2-2_amd64.deb ...
Unpacking gedit (3.20.2-2) over (3.18.2-1) ...
dpkg: error processing archive /var/cache/apt/archives/gedit_3.20.2-2_amd64.deb (--unpack):
 unable to move aside './usr/share/bug/gedit' to install new version: Invalid cross-device link
Errors were encountered while processing:
 /var/cache/apt/archives/gedit_3.20.2-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
root@kali:~#

~0005634

harveyUK47 (reporter)

Downloaded nightly build 17th Aug, issue not present, but maybe as apt-get dist-upgrade doesn't have anything to upgrade.

~0005635

rhertzog (administrator)

harveyUK47, with the nightly build, you can try "apt install --reinstall gedit" for example.

With the problematic 2016.1 setup, can you show me the output of "ls -al /usr/share/bug/" and possibly also of the same directory in the persistence filesystem?

~0005636

harveyUK47 (reporter)

Sorry had to rebuild my usb key with nightly build. On nightly build, running apt install --reinstall gedit presents no errors.

~0005637

lostincynicism (reporter)

Just got into the office. For the time being, I was able to avoid the issue by issuing 'apt-mark hold gedit' I have a spare usb stick here, ill try the steps you recommended and also run memtest to make sure it's not a bad dimm.

~0005642

lostincynicism (reporter)

So first set of results, the dimms are fine. After 10 iterations of testing with all 13 tests in memtest86 v7.1, there were 0 errors.

Before upgrade ls -al /usr/share/bug/:

root@kali:~# ls -al /usr/share/bug/
total 15
drwxr-xr-x 110 root root 2633 Jan 20 2016 .
drwxr-xr-x 1 root root 4096 Jan 20 2016 ..
drwxr-xr-x 2 root root 44 Jan 20 2016 apache2
drwxr-xr-x 2 root root 44 Jan 20 2016 apache2-bin
drwxr-xr-x 2 root root 29 Jan 20 2016 apt
drwxr-xr-x 2 root root 30 Jan 20 2016 bash-completion
drwxr-xr-x 2 root root 30 Jan 20 2016 binutils
drwxr-xr-x 2 root root 30 Jan 20 2016 console-setup
drwxr-xr-x 2 root root 30 Jan 20 2016 console-setup-linux
drwxr-xr-x 2 root root 44 Jan 20 2016 cron
-rwxr-xr-x 1 root root 297 Apr 28 2015 cryptsetup
drwxr-xr-x 2 root root 30 Jan 20 2016 dbus
drwxr-xr-x 2 root root 30 Jan 20 2016 empathy
drwxr-xr-x 2 root root 30 Jan 20 2016 evince
drwxr-xr-x 2 root root 30 Jan 20 2016 evolution-data-server
drwxr-xr-x 2 root root 29 Jan 20 2016 exim4-base
drwxr-xr-x 2 root root 29 Jan 20 2016 exim4-config
drwxr-xr-x 2 root root 29 Jan 20 2016 exim4-daemon-light
drwxr-xr-x 2 root root 45 Jan 20 2016 file
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-amd-graphics
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-atheros
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-bnx2
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-bnx2x
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-brcm80211
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-cavium
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-intel-sound
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-intelwimax
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-ipw2x00
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-ivtv
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-iwlwifi
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-libertas
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-linux
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-misc-nonfree
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-myricom
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-netxen
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-qlogic
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-realtek
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-samsung
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-siano
drwxr-xr-x 2 root root 30 Jan 20 2016 firmware-ti-connectivity
drwxr-xr-x 2 root root 44 Jan 20 2016 fonts-cantarell
drwxr-xr-x 2 root root 44 Jan 20 2016 fonts-droid
drwxr-xr-x 2 root root 44 Jan 20 2016 fonts-liberation
drwxr-xr-x 2 root root 30 Jan 20 2016 fonts-wine
-rwxr-xr-x 1 root root 118 Jun 30 2015 fping
drwxr-xr-x 2 root root 29 Jan 20 2016 gedit
drwxr-xr-x 2 root root 30 Jan 20 2016 gnome-core
drwxr-xr-x 2 root root 30 Jan 20 2016 gnupg
drwxr-xr-x 2 root root 59 Jan 20 2016 iceweasel
drwxr-xr-x 2 root root 44 Jan 20 2016 imagemagick
drwxr-xr-x 2 root root 29 Jan 20 2016 initramfs-tools
drwxr-xr-x 2 root root 30 Jan 20 2016 keyboard-configuration
drwxr-xr-x 2 root root 44 Jan 20 2016 libapache2-mod-php5
-rwxr-xr-x 1 root root 53 Aug 30 2015 libdvdnav4
-rwxr-xr-x 1 root root 57 Aug 29 2014 libdvdread4
drwxr-xr-x 2 root root 44 Jan 20 2016 libegl1-mesa
drwxr-xr-x 2 root root 44 Jan 20 2016 libgbm1
drwxr-xr-x 2 root root 44 Jan 20 2016 libgl1-mesa-dri
drwxr-xr-x 2 root root 44 Jan 20 2016 libgl1-mesa-glx
drwxr-xr-x 2 root root 44 Jan 20 2016 libglapi-mesa
drwxr-xr-x 2 root root 44 Jan 20 2016 libgles1-mesa
drwxr-xr-x 2 root root 44 Jan 20 2016 libgles2-mesa
drwxr-xr-x 2 root root 45 Jan 20 2016 libmagic1
-rwxr-xr-x 1 root root 553 Oct 28 2015 libvdpau1
lrwxrwxrwx 1 root root 11 Nov 2 2015 libvlc5 -> libvlccore8
drwxr-xr-x 2 root root 45 Jan 20 2016 libvlccore8
drwxr-xr-x 2 root root 44 Jan 20 2016 libwayland-egl1-mesa
drwxr-xr-x 2 root root 30 Jan 20 2016 libwine
drwxr-xr-x 2 root root 44 Jan 20 2016 libxatracker2
drwxr-xr-x 2 root root 291 Jan 20 2016 linux-image-4.3.0-kali1-amd64
drwxr-xr-x 2 root root 30 Jan 20 2016 linux-image-amd64
drwxr-xr-x 2 root root 44 Jan 20 2016 live-boot
drwxr-xr-x 2 root root 30 Jan 20 2016 live-config
drwxr-xr-x 2 root root 30 Jan 20 2016 live-tools
drwxr-xr-x 2 root root 30 Jan 20 2016 locales
drwxr-xr-x 2 root root 29 Jan 20 2016 logrotate
-rwxr-xr-x 1 root root 604 May 27 2014 lsb-release
drwxr-xr-x 2 root root 30 Jan 20 2016 man-db
drwxr-xr-x 2 root root 30 Jan 20 2016 menu
drwxr-xr-x 2 root root 44 Jan 20 2016 mesa-vdpau-drivers
drwxr-xr-x 2 root root 30 Jan 20 2016 mime-support
drwxr-xr-x 2 root root 44 Jan 20 2016 nfs-common
drwxr-xr-x 2 root root 45 Jan 20 2016 nfs-utils
drwxr-xr-x 2 root root 44 Jan 20 2016 php5
drwxr-xr-x 2 root root 44 Jan 20 2016 php5-cli
drwxr-xr-x 2 root root 44 Jan 20 2016 php5-common
drwxr-xr-x 2 root root 44 Jan 20 2016 php5-mysql
drwxr-xr-x 2 root root 44 Jan 20 2016 php5-readline
drwxr-xr-x 2 root root 30 Jan 20 2016 procps
-rwxr-xr-x 1 root root 1249 Nov 6 2015 pulseaudio
drwxr-xr-x 2 root root 59 Jan 20 2016 reportbug
drwxr-xr-x 2 root root 44 Jan 20 2016 systemd
drwxr-xr-x 2 root root 30 Jan 20 2016 tex-common
drwxr-xr-x 2 root root 44 Jan 20 2016 texlive-base
drwxr-xr-x 2 root root 44 Jan 20 2016 texlive-latex-base
drwxr-xr-x 2 root root 44 Jan 20 2016 texlive-latex-base-doc
drwxr-xr-x 2 root root 44 Jan 20 2016 udev
drwxr-xr-x 2 root root 30 Jan 20 2016 usb-modeswitch-data
-rwxr-xr-x 1 root root 553 Oct 28 2015 vdpau-driver-all
drwxr-xr-x 2 root root 44 Jan 20 2016 vim
drwxr-xr-x 2 root root 44 Jan 20 2016 vim-gtk
drwxr-xr-x 2 root root 44 Jan 20 2016 vim-tiny
lrwxrwxrwx 1 root root 7 Nov 2 2015 vlc -> vlc-nox
lrwxrwxrwx 1 root root 11 Nov 2 2015 vlc-nox -> libvlccore8
lrwxrwxrwx 1 root root 7 Nov 2 2015 vlc-plugin-notify -> vlc-nox
lrwxrwxrwx 1 root root 7 Nov 2 2015 vlc-plugin-samba -> vlc-nox
drwxr-xr-x 2 root root 30 Jan 20 2016 wine
drwxr-xr-x 2 root root 30 Jan 20 2016 wine64
drwxr-xr-x 2 root root 30 Jan 20 2016 xorg
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-core
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-input-evdev
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-input-mouse
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-input-synaptics
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-input-vmmouse
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-video-ati
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-video-fbdev
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-video-intel
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-video-nouveau
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-video-qxl
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-video-radeon
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-video-vesa
drwxr-xr-x 2 root root 29 Jan 20 2016 xserver-xorg-video-vmware
-rwxr-xr-x 1 root root 1783 Dec 2 2015 zsh
-rwxr-xr-x 1 root root 1783 Dec 2 2015 zsh-common


I'll add the output post upgrade once it finishes or fails.

~0005643

lostincynicism (reporter)

Failed again:

Errors were encountered while processing:
 /var/cache/apt/archives/gedit_3.20.2-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

root@kali:~/Downloads# apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
 gedit : Depends: gedit-common (< 3.19) but 3.20.2-2 is installed
E: Unmet dependencies. Try using -f.
root@kali:~/Downloads#

~0005644

lostincynicism (reporter)

root@kali:~/Downloads# apt-get -f dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Correcting dependencies... Done
Calculating upgrade... Done
The following packages were automatically installed and are no longer required:
  caribou-antler castxml creepy dff gccxml gir1.2-clutter-gst-2.0
  gir1.2-gkbd-3.0 gir1.2-packagekitglib-1.0 gir1.2-xkl-1.0
  gnome-icon-theme-symbolic gtk2-engines gucharmap inguma libapache2-mod-php5
  libasn1-8-heimdal libavcodec-ffmpeg56 libavdevice-ffmpeg56
  libavfilter-ffmpeg5 libavformat-ffmpeg56 libavresample-ffmpeg2
  libavutil-ffmpeg54 libbasicusageenvironment0 libbind9-90
  libboost-filesystem1.58.0 libboost-python1.58.0 libboost-python1.61.0
  libboost-system1.58.0 libboost-thread1.58.0 libcamel-1.2-54
  libclutter-gst-2.0-0 libcrypto++9v5 libdbus-1-dev libdns100
  libexporter-tiny-perl libgdict-1.0-9 libgif4 libgrilo-0.2-1 libgroupsock1
  libgssapi3-heimdal libgtkglext1 libgucharmap-2-90-7 libhcrypto4-heimdal
  libhdb9-heimdal libheimbase1-heimdal libheimntlm0-heimdal libhunspell-1.3-0
  libhx509-5-heimdal libical1a libilmbase6v5 libisc95 libisccc90 libisccfg90
  libjansson4 libjasper1 libkdc2-heimdal libkrb5-26-heimdal
  liblist-moreutils-perl liblivemedia23 libllvm3.7 liblouis9 liblwres90
  libntdb1 libonig2 libopenexr6v5 libopenjpeg5 libpff1 libpgm-5.1-0 libphonon4
  libpng12-0 libpoppler57 libpostproc-ffmpeg53 libpth20 libpython3.4-minimal
  libpython3.4-stdlib libqdbm14 libqmi-glib1 libquvi-scripts libquvi7
  libregfi0 libroken18-heimdal libsodium13 libswresample-ffmpeg1
  libswscale-ffmpeg3 libtask-weaken-perl libtre5 libtrio2 libusageenvironment1
  libusbmuxd2 libwebp5 libwebpdemux1 libwebpmux1 libwebrtc-audio-processing-0
  libwind0-heimdal libx265-68 libyara3 libzip2 libzmq3 multiforcer phonon
  phonon-backend-vlc php5 php5-cli php5-common php5-json php5-mysql
  php5-readline python-apsw python-bluez python-characteristic
  python-ctypeslib python-dbus-dev python-distlib python-dominate python-ecdsa
  python-flickrapi python-googleapi python-instagram python-jwt python-lzma
  python-lzo python-magic python-ntdb python-oauth2client python-oauthlib
  python-opengl python-pyatspi python-pyexiv2 python-pyexiv2-doc
  python-pyqtgraph python-qt4-gl python-qt4-phonon python-requests-oauthlib
  python-requests-toolbelt python-rsa python-tidylib python-tweepy
  python-uritemplate python-yapsy python3.4 python3.4-minimal ratproxy
  ruby-rainbow ruby-rexec ruby2.2-dev system-config-printer
Use 'apt autoremove' to remove them.
The following packages will be upgraded:
  gedit
1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
657 not fully installed or removed.
Need to get 0 B/414 kB of archives.
After this operation, 106 kB of additional disk space will be used.
Do you want to continue? [Y/n]
Reading changelogs... Done
(Reading database ... 318520 files and directories currently installed.)
Preparing to unpack .../gedit_3.20.2-2_amd64.deb ...
Unpacking gedit (3.20.2-2) over (3.18.2-1) ...
dpkg: error processing archive /var/cache/apt/archives/gedit_3.20.2-2_amd64.deb (--unpack):
 unable to move aside './usr/share/bug/gedit' to install new version: Invalid cross-device link
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Errors were encountered while processing:
 /var/cache/apt/archives/gedit_3.20.2-2_amd64.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
W: Operation was interrupted before it could finish
root@kali:~/Downloads#

~0005645

lostincynicism (reporter)

ls -al after upgrade:

root@kali:~/Downloads# ls -al /usr/share/bug/
total 492
drwxr-xr-x 1 root root 4096 Aug 18 03:36 .
drwxr-xr-x 1 root root 12288 Aug 18 03:32 ..
drwxr-xr-x 1 root root 4096 Aug 17 20:21 apache2
drwxr-xr-x 1 root root 4096 Aug 17 20:21 apache2-bin
drwxr-xr-x 1 root root 4096 Aug 17 20:20 apt
drwxr-xr-x 1 root root 4096 Aug 17 20:19 bash-completion
drwxr-xr-x 1 root root 4096 Aug 17 20:12 binutils
drwxr-xr-x 1 root root 4096 Aug 17 20:19 console-setup
drwxr-xr-x 1 root root 4096 Aug 17 20:19 console-setup-linux
drwxr-xr-x 2 root root 44 Jan 20 2016 cron
-rwxr-xr-x 1 root root 763 Feb 9 2016 cryptsetup
drwxr-xr-x 1 root root 4096 Aug 17 20:19 dbus
drwxr-xr-x 1 root root 4096 Aug 18 02:41 empathy
drwxr-xr-x 1 root root 4096 Aug 18 02:47 evince
drwxr-xr-x 1 root root 4096 Aug 18 02:18 evolution-data-server
drwxr-xr-x 1 root root 4096 Aug 18 02:52 exim4-base
drwxr-xr-x 1 root root 4096 Aug 18 02:52 exim4-config
drwxr-xr-x 1 root root 4096 Aug 18 02:52 exim4-daemon-light
drwxr-xr-x 1 root root 4096 Aug 18 02:36 file
drwxr-xr-x 2 root root 4096 Aug 18 02:53 firefox-esr
drwxr-xr-x 1 root root 4096 Aug 17 20:23 firmware-amd-graphics
drwxr-xr-x 1 root root 4096 Aug 17 20:37 firmware-atheros
drwxr-xr-x 1 root root 4096 Aug 17 20:37 firmware-bnx2
drwxr-xr-x 1 root root 4096 Aug 17 20:37 firmware-bnx2x
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-brcm80211
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-cavium
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-intel-sound
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-intelwimax
drwxr-xr-x 1 root root 4096 Aug 17 20:23 firmware-ipw2x00
drwxr-xr-x 1 root root 4096 Aug 17 20:23 firmware-ivtv
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-iwlwifi
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-libertas
drwxr-xr-x 1 root root 4096 Aug 17 20:23 firmware-linux
drwxr-xr-x 1 root root 4096 Aug 17 20:23 firmware-misc-nonfree
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-myricom
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-netxen
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-qlogic
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-realtek
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-samsung
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-siano
drwxr-xr-x 1 root root 4096 Aug 17 20:38 firmware-ti-connectivity
drwxr-xr-x 1 root root 4096 Aug 17 20:39 fonts-cantarell
drwxr-xr-x 2 root root 4096 Aug 18 02:28 fonts-droid-fallback
drwxr-xr-x 2 root root 44 Jan 20 2016 fonts-liberation
drwxr-xr-x 2 root root 4096 Aug 18 02:53 fonts-noto-mono
drwxr-xr-x 1 root root 4096 Aug 17 20:40 fonts-wine
-rwxr-xr-x 1 root root 118 Jun 30 2015 fping
drwxr-xr-x 2 root root 29 Jan 20 2016 gedit
drwxr-xr-x 1 root root 4096 Aug 18 03:00 gnome-core
drwxr-xr-x 1 root root 4096 Aug 17 20:27 gnupg
drwxr-xr-x 1 root root 4096 Aug 17 21:04 imagemagick
drwxr-xr-x 1 root root 4096 Aug 18 03:03 initramfs-tools
drwxr-xr-x 2 root root 4096 Aug 17 20:09 init-system-helpers
drwxr-xr-x 1 root root 4096 Aug 17 20:19 keyboard-configuration
drwxr-xr-x 2 root root 44 Jan 20 2016 libapache2-mod-php5
drwxr-xr-x 2 root root 4096 Aug 18 03:05 libapache2-mod-php7.0
-rwxr-xr-x 1 root root 53 Aug 30 2015 libdvdnav4
-rwxr-xr-x 1 root root 57 Aug 29 2014 libdvdread4
drwxr-xr-x 1 root root 4096 Aug 17 20:32 libegl1-mesa
drwxr-xr-x 1 root root 4096 Aug 17 20:32 libgbm1
drwxr-xr-x 1 root root 4096 Aug 18 02:28 libgl1-mesa-dri
drwxr-xr-x 1 root root 4096 Aug 17 21:11 libgl1-mesa-glx
drwxr-xr-x 1 root root 4096 Aug 17 21:11 libglapi-mesa
drwxr-xr-x 1 root root 4096 Aug 17 21:11 libgles1-mesa
drwxr-xr-x 1 root root 4096 Aug 17 21:11 libgles2-mesa
drwxr-xr-x 1 root root 4096 Aug 18 02:36 libmagic1
drwxr-xr-x 2 root root 4096 Aug 18 03:16 libosmesa6
-rwxr-xr-x 1 root root 553 Oct 28 2015 libvdpau1
drwxr-xr-x 2 root root 4096 Aug 17 20:23 libvlc5
drwxr-xr-x 1 root root 4096 Aug 17 20:23 libvlccore8
drwxr-xr-x 1 root root 4096 Aug 17 20:32 libwayland-egl1-mesa
drwxr-xr-x 1 root root 4096 Aug 18 03:22 libwine
drwxr-xr-x 1 root root 4096 Aug 18 02:28 libxatracker2
drwxr-xr-x 2 root root 291 Jan 20 2016 linux-image-4.3.0-kali1-amd64
drwxr-xr-x 2 root root 4096 Aug 18 03:24 linux-image-4.6.0-kali1-amd64
drwxr-xr-x 1 root root 4096 Aug 18 03:24 linux-image-amd64
drwxr-xr-x 1 root root 4096 Aug 17 21:21 live-boot
drwxr-xr-x 1 root root 4096 Aug 17 21:21 live-config
drwxr-xr-x 1 root root 4096 Aug 17 21:22 live-tools
drwxr-xr-x 1 root root 4096 Aug 17 20:09 locales
drwxr-xr-x 2 root root 29 Jan 20 2016 logrotate
-rwxr-xr-x 1 root root 604 May 27 2014 lsb-release
drwxr-xr-x 2 root root 30 Jan 20 2016 man-db
drwxr-xr-x 2 root root 30 Jan 20 2016 menu
drwxr-xr-x 2 root root 4096 Aug 18 03:03 mesa-opencl-icd
drwxr-xr-x 1 root root 4096 Aug 18 03:25 mesa-vdpau-drivers
drwxr-xr-x 1 root root 4096 Aug 17 20:17 mime-support
drwxr-xr-x 1 root root 4096 Aug 17 21:24 nfs-common
drwxr-xr-x 1 root root 4096 Aug 17 21:24 nfs-utils
drwxr-xr-x 2 root root 44 Jan 20 2016 php5
drwxr-xr-x 2 root root 44 Jan 20 2016 php5-cli
drwxr-xr-x 2 root root 44 Jan 20 2016 php5-common
drwxr-xr-x 2 root root 44 Jan 20 2016 php5-mysql
drwxr-xr-x 2 root root 44 Jan 20 2016 php5-readline
drwxr-xr-x 2 root root 4096 Aug 18 03:05 php7.0
drwxr-xr-x 2 root root 4096 Aug 18 03:04 php7.0-cli
drwxr-xr-x 2 root root 4096 Aug 18 03:04 php7.0-common
drwxr-xr-x 2 root root 4096 Aug 18 03:04 php7.0-json
drwxr-xr-x 2 root root 4096 Aug 18 03:05 php7.0-mysql
drwxr-xr-x 2 root root 4096 Aug 18 03:04 php7.0-opcache
drwxr-xr-x 2 root root 4096 Aug 18 03:04 php7.0-readline
drwxr-xr-x 1 root root 4096 Aug 18 02:07 procps
-rwxr-xr-x 1 root root 1249 Jul 3 16:00 pulseaudio
drwxr-xr-x 2 root root 59 Jan 20 2016 reportbug
drwxr-xr-x 1 root root 4096 Aug 17 20:15 systemd
drwxr-xr-x 1 root root 4096 Aug 17 20:39 tex-common
drwxr-xr-x 1 root root 4096 Aug 18 02:51 texlive-base
drwxr-xr-x 2 root root 4096 Aug 18 02:51 texlive-latex-base
drwxr-xr-x 1 root root 4096 Aug 18 02:50 texlive-latex-base-doc
drwxr-xr-x 1 root root 4096 Aug 17 20:14 udev
drwxr-xr-x 1 root root 4096 Aug 17 21:58 usb-modeswitch-data
-rwxr-xr-x 1 root root 553 Oct 28 2015 vdpau-driver-all
drwxr-xr-x 1 root root 4096 Aug 18 02:34 vim
drwxr-xr-x 1 root root 4096 Aug 18 02:33 vim-gtk
drwxr-xr-x 1 root root 4096 Aug 18 02:34 vim-tiny
drwxr-xr-x 2 root root 4096 Aug 18 02:30 vlc
drwxr-xr-x 2 root root 4096 Aug 17 20:24 vlc-data
lrwxrwxrwx 1 root root 7 Nov 2 2015 vlc.dpkg-backup -> vlc-nox
drwxr-xr-x 2 root root 4096 Aug 18 02:30 vlc-nox
lrwxrwxrwx 1 root root 11 Nov 2 2015 vlc-nox.dpkg-backup -> libvlccore8
drwxr-xr-x 2 root root 4096 Aug 17 20:26 vlc-plugin-notify
drwxr-xr-x 2 root root 4096 Aug 17 20:26 vlc-plugin-samba
drwxr-xr-x 1 root root 4096 Aug 18 03:19 wine
drwxr-xr-x 1 root root 4096 Aug 18 03:19 wine64
drwxr-xr-x 1 root root 4096 Aug 17 21:37 xorg
drwxr-xr-x 1 root root 4096 Aug 17 21:37 xserver-xorg
drwxr-xr-x 1 root root 4096 Aug 18 02:27 xserver-xorg-core
drwxr-xr-x 1 root root 4096 Aug 18 02:27 xserver-xorg-input-evdev
drwxr-xr-x 2 root root 4096 Aug 18 02:28 xserver-xorg-input-libinput
drwxr-xr-x 1 root root 4096 Aug 18 02:27 xserver-xorg-input-mouse
drwxr-xr-x 2 root root 4096 Aug 18 03:32 xserver-xorg-video-amdgpu
drwxr-xr-x 1 root root 4096 Aug 18 02:26 xserver-xorg-video-ati
drwxr-xr-x 1 root root 4096 Aug 18 02:26 xserver-xorg-video-fbdev
drwxr-xr-x 1 root root 4096 Aug 18 02:27 xserver-xorg-video-intel
drwxr-xr-x 1 root root 4096 Aug 18 02:26 xserver-xorg-video-nouveau
drwxr-xr-x 1 root root 4096 Aug 18 02:26 xserver-xorg-video-qxl
drwxr-xr-x 1 root root 4096 Aug 18 02:26 xserver-xorg-video-radeon
drwxr-xr-x 1 root root 4096 Aug 18 02:26 xserver-xorg-video-vesa
drwxr-xr-x 1 root root 4096 Aug 18 02:26 xserver-xorg-video-vmware
-rwxr-xr-x 1 root root 1815 May 6 17:40 zsh
-rwxr-xr-x 1 root root 1815 May 6 17:40 zsh-common
root@kali:~/Downloads#

~0005646

lostincynicism (reporter)

I looked at the live partition versus the persistence partition, but the directory hierarchy isn't the same. While the persistence partition has directories such as /usr or /var or /etc, the live partition has the BOOT, EFI, and LIVE directory which containts things like initrd, some c files, and some other images. But they don't have that same directory structure. I could open up those images to look, if you like.

~0005733

rhertzog (administrator)

Ok, I finally figured out the root problem... it's this bug: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=836211

So it's an annoying limitation of "overlay" (the layering filesystem we use for persistence).

There's no clear solution though... the problem will happen every time that a newer package replaces a directory with a file.

~0005737

rhertzog (administrator)

I have uploade dpkg 1.18.10kali1 with a work-around for this problem. We will keep that dpkg patch until the underlying overlayfs bug is fixed...
+Notes

-Issue History
Date Modified Username Field Change
2016-08-16 20:17 lostincynicism New Issue
2016-08-16 20:18 lostincynicism Note Added: 0005627
2016-08-16 20:50 lostincynicism Note Added: 0005628
2016-08-17 07:33 rhertzog Note Added: 0005630
2016-08-17 07:33 rhertzog Assigned To => rhertzog
2016-08-17 07:33 rhertzog Status new => feedback
2016-08-17 07:35 rhertzog Note Added: 0005631
2016-08-17 10:22 rhertzog Note Added: 0005632
2016-08-17 10:30 harveyUK47 Note Added: 0005633
2016-08-17 12:01 harveyUK47 Note Added: 0005634
2016-08-17 13:04 rhertzog Note Added: 0005635
2016-08-17 15:25 harveyUK47 Note Added: 0005636
2016-08-17 15:34 lostincynicism Note Added: 0005637
2016-08-17 15:34 lostincynicism Status feedback => assigned
2016-08-17 22:26 lostincynicism Note Added: 0005642
2016-08-18 03:36 lostincynicism Note Added: 0005643
2016-08-18 03:37 lostincynicism Note Added: 0005644
2016-08-18 03:39 lostincynicism Note Added: 0005645
2016-08-18 03:42 lostincynicism Note Added: 0005646
2016-09-02 09:59 rhertzog Note Added: 0005733
2016-09-02 10:00 rhertzog Status assigned => confirmed
2016-09-02 10:03 rhertzog Priority normal => high
2016-09-02 10:03 rhertzog Product Version 2016.1 => 2016.2
2016-09-02 10:03 rhertzog Summary Gedit binary in gedit package 3.20.2-2_amd64 is corrupt, which causes x to crash => unable to move aside './usr/share/bug/gedit' to install new version: Invalid cross-device link
2016-09-02 10:03 rhertzog Description Updated View Revisions
2016-09-02 13:16 rhertzog Note Added: 0005737
2016-09-02 13:16 rhertzog Status confirmed => resolved
2016-09-02 13:16 rhertzog Fixed in Version => 2017.1
2016-09-02 13:16 rhertzog Resolution open => fixed
+Issue History