View Issue Details

IDProjectCategoryView StatusLast Update
0003503Kali Linux[All Projects] General Bugpublic2016-09-20 21:31
Reporterdarmasoc Assigned Torhertzog  
PriorityhighSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0003503: Fresh boot Raspi 3; unable to locate package; apt-get update no Hit all Ign with Err: armhf packages 404 not found
DescriptionErr:3 http://ftp.ne.jp/Linux/packages/kali/kali kali-rolling/main Sources
  404 Not Found
Err:4 http://ftp.ne.jp/Linux/packages/kali/kali kali-rolling/contrib Sources
  404 Not Found
Err:5 http://ftp.ne.jp/Linux/packages/kali/kali kali-rolling/non-free Sources
  404 Not Found
Err:6 http://ftp.ne.jp/Linux/packages/kali/kali kali-rolling/main armhf Packages
  404 Not Found
Ign:7 http://http.kali.org/kali kali-rolling/main all Packages
Ign:8 http://http.kali.org/kali kali-rolling/main Translation-en
Err:9 http://ftp.ne.jp/Linux/packages/kali/kali kali-rolling/contrib armhf Packages
  404 Not Found
Ign:10 http://http.kali.org/kali kali-rolling/contrib all Packages
Ign:11 http://http.kali.org/kali kali-rolling/contrib Translation-en
Err:12 http://ftp.ne.jp/Linux/packages/kali/kali kali-rolling/non-free armhf Packages
  404 Not Found
Ign:13 http://http.kali.org/kali kali-rolling/non-free all Packages
Reading package lists... Done
W: The repository 'http://http.kali.org/kali kali-rolling Release' does not have a Release file.
N: Data from such a repository can't be authenticated and is therefore potentially dangerous to use.
N: See apt-secure(8) manpage for repository creation and user configuration details.
W: Failed to fetch http://http.kali.org/kali/dists/kali-rolling/main/source/Sources 404 Not Found
W: Failed to fetch http://http.kali.org/kali/dists/kali-rolling/contrib/source/Sources 404 Not Found
W: Failed to fetch http://http.kali.org/kali/dists/kali-rolling/non-free/source/Sources 404 Not Found
W: Failed to fetch http://ftp.ne.jp/Linux/packages/kali/kali/dists/kali-rolling/main/binary-armhf/Packages 404 Not Found
W: Failed to fetch http://ftp.ne.jp/Linux/packages/kali/kali/dists/kali-rolling/contrib/binary-armhf/Packages 404 Not Found
W: Failed to fetch http://ftp.ne.jp/Linux/packages/kali/kali/dists/kali-rolling/non-free/binary-armhf/Packages 404 Not Found
E: Some index files failed to download. They have been ignored, or old ones used instead.

Activities

muts

2016-08-27 16:48

administrator   ~0005687

Last edited: 2016-08-27 16:48

View 2 revisions

This could be a temporary issue with the ftp.ne.jp mirror. Can you try hardcoding your sources.list at and try again? http://offs.ec/hardcode

darmasoc

2016-08-28 03:08

reporter   ~0005688

Works like charm.. Thanks.

rhertzog

2016-08-29 14:15

administrator   ~0005693

Please attach the output of "apt-config dump". I wonder if it's not an issue with the APT configuration of the image that you used to start with.

Can you let us know how you installed Kali on your Raspberry Pi 3? What image did you use?

rhertzog

2016-08-29 14:37

administrator   ~0005694

Subsidiary question: do you have IPv6 connectivity or not? since ftp.ne.jp is IPv6-enabled, it might be relevant.

rhertzog

2016-08-29 16:01

administrator   ~0005695

We just tried on a raspberry pi with a kali image and it seems to work if we put the japanese mirror in /etc/apt/sources.list:
cat >/etc/apt/sources.list <<EOF
deb http://ftp.ne.jp/Linux/packages/kali/kali/ kali-rolling main non-free contrib
EOF

So I'm really wondering if it's not just some temporary glitch that you encountered....

darmasoc

2016-08-29 21:05

reporter   ~0005701

1. I will send the apt-config dump output later
2. I did not bother configuring or checking IPv6. I always stick with IPv4.
3. Two weeks ago before I encounter the problem I had a successful fresh install and upgraded of kali-linux-full on my RasPi3. I had to do the same with my other RasPi3 but it fails.
4. It came accross me that maybe since I am in Singapore things like such are being monitored and suppressed. I am not really sure.

rhertzog

2016-09-20 21:30

administrator   ~0005965

This has been fixed on the DNS level.

Issue History

Date Modified Username Field Change
2016-08-27 15:42 darmasoc New Issue
2016-08-27 16:48 muts Note Added: 0005687
2016-08-27 16:48 muts Note Edited: 0005687 View Revisions
2016-08-28 03:08 darmasoc Note Added: 0005688
2016-08-29 14:15 rhertzog Note Added: 0005693
2016-08-29 14:15 rhertzog Assigned To => rhertzog
2016-08-29 14:15 rhertzog Status new => feedback
2016-08-29 14:37 rhertzog Note Added: 0005694
2016-08-29 16:01 rhertzog Note Added: 0005695
2016-08-29 21:05 darmasoc Note Added: 0005701
2016-08-29 21:05 darmasoc Status feedback => assigned
2016-09-20 21:30 rhertzog Note Added: 0005965
2016-09-20 21:30 rhertzog Status assigned => resolved
2016-09-20 21:30 rhertzog Resolution open => fixed