View Issue Details

IDProjectCategoryView StatusLast Update
0003535Kali Linux[All Projects] Kali Package Bugpublic2016-12-22 14:42
Reporterkimocoder Assigned To 
PrioritylowSeveritytweakReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2016.2 
Target VersionFixed in Version 
Summary0003535: Beef-XSS controlpanel says v0.4.6.1, but apt says It's v0.4.7.0 ..trivial
DescriptionAs explained. Look at the image i added to the case.

Activities

kimocoder

2016-09-03 07:00

reporter  

kimocoder

2016-09-03 07:05

reporter   ~0005751

Jupp, updated to 0.4.7.0 from github and now it shows up correct and they've fixed several things since 0.4.6.1 that i like. version mismatch

bennelson

2016-11-29 08:40

reporter   ~0006141

Issue:
Looks like the Kali package 'beef-xss_0.4.7.0-0kali3' is still using version 0.4.6.1-alpha of the beef-xss Project.
At writing this note, latest release of beef-xss is 0.4.7.0-alpha.

Fix:
The beef-xss Kali package needs to be updated to use the latest upstream beef-xss version of 0.4.7.0-alpha.

sbrun

2016-12-22 14:42

manager   ~0006192

The latest upstream version is 0.4.7.0 (release on 29 Dec 2015). Upstream made a tagged release:
https://github.com/beefproject/beef/archive/beef-0.4.7.0.tar.gz

In Kali we used this source code to package the latest version of beef.
But upstream didn't change the version in the code (they change it just after the tagged release).

To avoid any confusion I just uploaded a new version of kali package (version 0.4.7.0-0kali4) with a patch to update the version in the code.

Issue History

Date Modified Username Field Change
2016-09-03 07:00 kimocoder New Issue
2016-09-03 07:00 kimocoder File Added: Screenshot from 2016-09-03 08-58-39.png
2016-09-03 07:05 kimocoder Note Added: 0005751
2016-11-29 08:40 bennelson Note Added: 0006141
2016-12-22 14:42 sbrun Status new => resolved
2016-12-22 14:42 sbrun Resolution open => fixed
2016-12-22 14:42 sbrun Note Added: 0006192