View Issue Details

IDProjectCategoryView StatusLast Update
0003884Kali Linux[All Projects] General Bugpublic2020-12-01 10:48
Reporterrimvydukas Assigned Torhertzog  
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0003884: Hibernate does not work after dist upgrade to latest kernel version

I have Hibernate problem after dist upgrade. So my story.

I had dual boot system - Windows 7 and freshly installed Kali Linux 2016.2 with 4.6.4 kernel (Light version with xfce). Checked if hibernate works. No problems - all windows are retained after laptop comes out of hibernate.

So I've did apt-get upgrade after that. Reboot. Checked hibernate - everything works.

So next step - I did apt-get dist upgrade. Kali was upgraded to 4.9.0 kernel. Did reboot. Checked if hibernate is working. And it seems that hibernate does not work after this upgrade. When laptop comes up from hibernate - my windows and sessions are not retained at all:( How can I fix this? Thanks.
Steps To Reproducedist upgrade to latest version.



2017-02-16 18:54

reporter   ~0006417

Found interesting thing in dmesg, maybe this will help:

    1.837790] PM: Starting manual resume from disk
[ 1.837793] PM: Hibernation image partition 8:9 present
[ 1.837794] PM: Looking for hibernation image.
[ 1.838055] PM: Image not found (code -22)
[ 1.838055] PM: Hibernation image not present or could not be loaded.


2017-02-16 19:35

administrator   ~0006418

It would also help if you said how you actually hibernate your computer.


2017-02-16 19:36

administrator   ~0006419

Is hibernate a standard option in the XFCE menu? At least in GNOME it does not appear. And suspend is an implicit operation (when closing lid).


2017-02-17 09:39

reporter   ~0006420

I think that hibernate is standard thing in xfce as I simply enabled this menu via actions buttons menu and I simply press on this menu entry when I want to hibernate my laptop. And as I said - this feature worked without any problems right after fresh install and prior dist-upgrade. Problems show up right after dist-upgrade. When I bring up laptop to hibernate and when it is brought back from this mode it seems that everything is working from hibernate part as I see the following in dmesg:

[ 135.958626] PM: Hibernation mode set to 'platform'
[ 135.960551] PM: Syncing filesystems ...
[ 135.975644] PM: Marking nosave pages: [mem 0x00000000-0x00000fff]
[ 135.975645] PM: Marking nosave pages: [mem 0x0009d000-0x000fffff]
[ 135.975647] PM: Marking nosave pages: [mem 0xb9bc1000-0xffffffff]
[ 135.976392] PM: Basic memory bitmaps created
[ 135.976435] PM: Preallocating image memory... done (allocated 222812 pages)
[ 136.090628] PM: Allocated 891248 kbytes in 0.11 seconds (8102.25 MB/s)
[ 137.416035] PM: freeze of devices complete after 1324.179 msecs
[ 137.440197] PM: late freeze of devices complete after 24.150 msecs
[ 137.467787] PM: noirq freeze of devices complete after 27.578 msecs
[ 137.477423] PM: Saving platform NVS memory
[ 137.489367] PM: Creating hibernation image:
[ 137.644258] PM: Need to copy 219139 pages
[ 137.644259] PM: Normal pages needed: 219139 + 1024, available pages: 1727164
[ 137.490464] PM: Restoring platform NVS memory
[ 137.534952] PM: noirq restore of devices complete after 20.196 msecs
[ 137.541733] PM: early restore of devices complete after 6.759 msecs
[ 139.049374] PM: restore of devices complete after 1475.952 msecs
[ 139.049672] PM: Image restored successfully.
[ 139.049691] PM: Basic memory bitmaps freed

But there is another thing in dmesg I suspect can cause the problems:

[ 150.852492] [drm] GPU HANG: ecode 9:0:0x00dfbd8f, in Xorg [619], reason: Hang on render ring, action: reset
[ 150.852495] [drm] GPU hangs can indicate a bug anywhere in the entire gfx stack, including userspace.
[ 150.852497] [drm] Please file a _new_ bug report on against DRI -> DRM/Intel
[ 150.852499] [drm] drm/i915 developers can then reassign to the right component if it's not a kernel issue.
[ 150.852500] [drm] The gpu crash dump is required to analyze gpu hangs, so please always attach it.
[ 150.852502] [drm] GPU crash dump saved to /sys/class/drm/card0/error
[ 150.852578] drm/i915: Resetting chip after gpu hang
[ 150.852655] [drm] RC6 on
[ 150.868327] [drm] GuC firmware load skipped
[ 161.828840] drm/i915: Resetting chip after gpu hang

What do you think?


2017-02-17 09:51

reporter   ~0006421

And maybe this will help:


2017-02-17 10:19

administrator   ~0006422

It's unlikely to help, the IOMMU config is already disabled by default in our kernel:
$ grep INTEL_IOMMU /boot/config-4.9.0-1-amd64

But you should definitely follow the instructions found in dmesg and open a ticket on and attach the content of /sys/class/drm/card0/error (after having seen the message).


2017-02-17 10:33

reporter   ~0006423

So what is your opinion - can this bug cause my hibernate problems or not? When I was on 4.6.x kernel and when laptop was brought back from hibernate there was no such error:( But I dont know if this bug is related to hibernate problem. I only see that I must wait for login screen longer than I had to wait when hibernate was working.


2017-02-17 10:34

reporter   ~0006424

Oh, and this error shows up only when laptop is brought from hibernate and not after laptop is restar ted.


2017-02-17 13:09

administrator   ~0006425

So this seems to be related to your hibernate problem. The video driver is no longer properly working after wakeup from hibernation and this ought to be fixed at the kernel level. Please file the bug.


2017-02-17 17:48

reporter   ~0006428

Must I fill this bug at or somewhere else?

I've tried the same configuration on my virtual machine and there are no problems at all with hibernate option...


2017-02-22 09:29

reporter   ~0006444


It seems that new kernel is out I Hibernate started to work again.


2017-02-22 16:26

administrator   ~0006447

Thanks for the notice, closing the ticket.

Issue History

Date Modified Username Field Change
2017-02-16 18:45 rimvydukas New Issue
2017-02-16 18:54 rimvydukas Note Added: 0006417
2017-02-16 19:35 rhertzog Note Added: 0006418
2017-02-16 19:36 rhertzog Note Added: 0006419
2017-02-17 09:39 rimvydukas Note Added: 0006420
2017-02-17 09:51 rimvydukas Note Added: 0006421
2017-02-17 10:19 rhertzog Note Added: 0006422
2017-02-17 10:33 rimvydukas Note Added: 0006423
2017-02-17 10:34 rimvydukas Note Added: 0006424
2017-02-17 13:09 rhertzog Note Added: 0006425
2017-02-17 17:48 rimvydukas Note Added: 0006428
2017-02-22 09:29 rimvydukas Note Added: 0006444
2017-02-22 16:26 rhertzog Assigned To => rhertzog
2017-02-22 16:26 rhertzog Status new => resolved
2017-02-22 16:26 rhertzog Resolution open => fixed
2017-02-22 16:26 rhertzog Note Added: 0006447
2020-12-01 10:48 g0tmi1k Priority high => normal