View Issue Details

IDProjectCategoryView StatusLast Update
0003970Kali LinuxNew Tool Requestspublic2018-01-29 10:53
Reporterndy82 Assigned Tog0tmi1k  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version2016.2 
Summary0003970: Universal Radio Hacker (urh)
Description

There is a tool for simple pentesting and analyzing of proprietary wireless protocols with SDRs. See https://github.com/jopohl/urh
It would be great, if you add this tool :)

Additional Information

https://github.com/jopohl/urh

Required

Python 3.4+
numpy / psutil / zmq
PyQt5
C++ Compiler

Optional

librtlsdr (for native RTL-SDR device backend)
libhackrf (for native HackRF device backend)
libairspy (for native AirSPy device backend)
liblimesdr (for native LimeSDR device backend)
rfcat (for RfCat plugin to send e.g. with YardStick One)
gnuradio / gnuradio-osmosdr (for GNU Radio device backends)

Relationships

duplicate of 0004211 acknowledged urh (Universal Radio Hacker) - investigating unknown wireless protocols 

Activities

jopohl

jopohl

2017-05-12 13:47

reporter   ~0006672

Any updates on this? It would be awesome to see URH on this great distribution. Let me know if I can assist you in any way e.g. packaging or code adaptions.

g0tmi1k

g0tmi1k

2018-01-29 10:53

administrator   ~0007939

Duplicate (0004211)
Closing

Issue History

Date Modified Username Field Change
2017-04-26 13:50 ndy82 New Issue
2017-05-12 13:47 jopohl Note Added: 0006672
2018-01-26 11:26 g0tmi1k Relationship added duplicate of 0004211
2018-01-29 10:53 g0tmi1k Assigned To => g0tmi1k
2018-01-29 10:53 g0tmi1k Status new => closed
2018-01-29 10:53 g0tmi1k Resolution open => duplicate
2018-01-29 10:53 g0tmi1k Note Added: 0007939