2017-09-25 18:50 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004039Kali Linux[All Projects] Kali Package Improvementpublic2017-05-30 13:56
ReporterFireFart 
Assigned Tosbrun 
PrioritynormalSeverityminorReproducibilityN/A
StatusresolvedResolutionfixed 
Product Version2017.1 
Target VersionFixed in Version2017.2 
Summary0004039: metasploit-framework - Remove msfupdate
DescriptionHi,
when installing metasploit-framework there is the file "msfupdate". This file is intended for updating the git version of metasploit and should not be run on kali. As this confuses some users, we think it would be better to remove the file at all in the kali package.
Could you please add the removal of the file to the package rules?

Discussion about the removal can be found on the official bug tracker:
https://github.com/rapid7/metasploit-framework/issues/8448
Attached Files

-Relationships
+Relationships

-Notes

~0006775

sbrun (manager)

msfupdate was using apt. Since version 4.14.21 in Kali, it doesn't work anymore.

In new version 4.14.22-0kali1, msfupdate is not installed anymore.
+Notes

-Issue History
Date Modified Username Field Change
2017-05-24 23:06 FireFart New Issue
2017-05-27 20:53 rhertzog Assigned To => sbrun
2017-05-27 20:53 rhertzog Status new => assigned
2017-05-30 13:56 sbrun Status assigned => resolved
2017-05-30 13:56 sbrun Resolution open => fixed
2017-05-30 13:56 sbrun Fixed in Version => 2017.2
2017-05-30 13:56 sbrun Note Added: 0006775
+Issue History