View Issue Details

IDProjectCategoryView StatusLast Update
0004210Kali Linux[All Projects] General Bugpublic2018-07-27 10:36
ReporterkypropexAssigned Torhertzog 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionno change required 
Product Version2017.1 
Target VersionFixed in Version 
Summary0004210: Application's menu buttons/icons in GTK2 apps are broken under Wayland
DescriptionAfter latest update some applications like gimp, eclipse SDK (gtk2) and VMware workstation have broken button icons.
Additional InformationI tried running eclipse with gtk3 and the the icons are ok, so I assume it has something to do with the gnome update.
Similar issues have been reported on the kali linux forum by another user:

https://forums.kali.org/showthread.php?37405-upgrade-reports-After-update-upgrade-got-some-issues

Activities

kypropex

2017-08-30 14:27

reporter  

broken_app.png (42,238 bytes)
broken_app.png (42,238 bytes)

rhertzog

2017-08-30 14:44

administrator   ~0007204

When you complain about an upgrade, you should include information about the upgrade... what packages have been updated and so on.

What version of kali-root-login do you have now?
dpkg -s kali-root-login|grep Version

I suspect the problem is related to the switch to Wayland which I reversed with kali-root-login 2017.2.0.

What's the output of "ps aux|grep Xorg" and "ps aux|grep wayland" ?

kypropex

2017-08-30 14:56

reporter   ~0007205

dpkg -s kali-root-login|grep Version :
Version: 2016.1.0

ps aux|grep Xorg
root 4647 0.0 0.0 12728 984 pts/0 S+ 17:46 0:00 grep Xorg

yes I know that an update history would be helpful unfortunately I updated a lot of packages at once (including distribution) and I don't know which one broke it. If you want I can attach the log.

kypropex

2017-08-30 14:58

reporter   ~0007206

ps aux|grep wayland

Debian-+ 700 0.0 0.0 188892 5208 tty1 Ssl+ 14:56 0:00 /usr/lib/gdm3/gdm-wayland-session gnome-session --autostart /usr/share/gdm/greeter/autostart
Debian-+ 747 0.0 0.1 326936 43572 tty1 Sl+ 14:57 0:00 /usr/bin/Xwayland :1024 -rootless -noreset -listen 4 -listen 5 -displayfd 6
root 1437 0.0 0.0 188892 5104 tty2 Ssl+ 14:57 0:00 /usr/lib/gdm3/gdm-wayland-session gnome-session
root 1489 0.7 0.3 409160 109360 tty2 Sl+ 14:57 1:19 /usr/bin/Xwayland :0 -rootless -noreset -listen 4 -listen 5 -displayfd 6
root 4910 0.0 0.0 12728 976 pts/0 S+ 17:58 0:00 grep wayland

kypropex

2017-08-30 15:11

reporter   ~0007207

update: The issue is not present in Gnome classic

rhertzog

2017-08-31 06:30

administrator   ~0007212

So your system is still not up-to-date... please update it and after a reboot you should be good.

rhertzog

2017-08-31 06:33

administrator   ~0007213

I'm changing the summary since the problem seems to be limited to GTK2 apps and only under Wayland.

kypropex

2017-08-31 13:26

reporter   ~0007219

I tried "apt dist-upgrade" and "apt upgrade" after "apt update" and it seams that there is nothing to update, except putty which I do not want to update.
I'm using:

deb http://http.kali.org/kali kali-rolling main non-free contrib

in the apt source.list

# apt list --upgradable
Listing... Done
putty/kali-rolling 0.70-1 amd64 [upgradable from: 0.67-3]
N: There is 1 additional version. Please use the '-a' switch to see it

The software center also only lists putty as the only upgradeable packet. Should I be using a different repo or a different command to update kali?

rhertzog

2017-08-31 13:41

administrator   ~0007222

I can assure you that kali-root-login in kali-rolling is newer than what you reported:
http://pkg.kali.org/kali-root-login

To which mirror are you redirected with http://http.kali.org/README ?

curl -sI http://http.kali.org/README

kypropex

2017-08-31 13:53

reporter   ~0007223

# curl -sI http://http.kali.org/README
HTTP/1.1 302 Found
Date: Thu, 31 Aug 2017 14:13:44 GMT
Server: Apache/2.4.10 (Debian)
X-MirrorBrain-Mirror: kali.mirror.garr.it
X-MirrorBrain-Realm: region
Link: <http://http.kali.org/README.meta4>; rel=describedby; type="application/metalink4+xml"
Link: <http://kali.mirror.garr.it/mirrors/kali/README>; rel=duplicate; pri=1; geo=it
Link: <http://archive-3.kali.org/kali/README>; rel=duplicate; pri=2; geo=de
Link: <http://mirrors.dotsrc.org/kali/README>; rel=duplicate; pri=3; geo=dk
Link: <http://ftp.halifax.rwth-aachen.de/kali/README>; rel=duplicate; pri=4; geo=de
Link: <http://ftp.belnet.be/kali/kali/README>; rel=duplicate; pri=5; geo=be
Location: http://kali.mirror.garr.it/mirrors/kali/README
Content-Type: text/html; charset=iso-8859-1

kypropex

2017-08-31 13:54

reporter   ~0007224

Do you know which mirrors are up to date?

rhertzog

2017-08-31 15:54

administrator   ~0007229

All mirrors behind http.kali.org are supposed to be up-to-date. We are monitoring them.

But kali.mirror.garr.it is a bit special (it's a round robin on two IP and thus we are not correctly monitoring both servers). I'll disable that mirror until they change this. In any case, if "apt update" succeeds, then you should see kali-root-login 2017.2.0 (apt show kali-root-login).

kypropex

2017-09-01 08:19

reporter   ~0007233

I checked today and it seems that I was redirected to a new mirror, after the update everything is resolved.
kali-root-login is 2017.2.0 and interface problems are also gone, I also had an issue with putty 0.70-1 which was showing segmentation fault error that also got resolved.

Thanks for your help.

rhertzog

2018-07-27 10:36

administrator   ~0009397

This issue is no longer relevant since we are back to using Xorg and not wayland.

Issue History

Date Modified Username Field Change
2017-08-30 14:27 kypropex New Issue
2017-08-30 14:27 kypropex File Added: broken_app.png
2017-08-30 14:44 rhertzog Note Added: 0007204
2017-08-30 14:44 rhertzog Assigned To => rhertzog
2017-08-30 14:44 rhertzog Status new => feedback
2017-08-30 14:56 kypropex Note Added: 0007205
2017-08-30 14:56 kypropex Status feedback => assigned
2017-08-30 14:58 kypropex Note Added: 0007206
2017-08-30 15:11 kypropex Note Added: 0007207
2017-08-31 06:30 rhertzog Note Added: 0007212
2017-08-31 06:33 rhertzog Summary Application's menu buttons/icons are broken after update => Application's menu buttons/icons in GTK2 apps are broken under Wayland
2017-08-31 06:33 rhertzog Note Added: 0007213
2017-08-31 13:26 kypropex Note Added: 0007219
2017-08-31 13:41 rhertzog Note Added: 0007222
2017-08-31 13:53 kypropex Note Added: 0007223
2017-08-31 13:54 kypropex Note Added: 0007224
2017-08-31 15:54 rhertzog Note Added: 0007229
2017-09-01 08:19 kypropex Note Added: 0007233
2018-06-22 06:19 g0tmi1k Severity major => minor
2018-07-27 10:36 rhertzog Status assigned => resolved
2018-07-27 10:36 rhertzog Resolution open => no change required
2018-07-27 10:36 rhertzog Note Added: 0009397