2018-05-21 22:13 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004218Kali Linux[All Projects] General Bugpublic2018-02-21 09:40
Assigned To 
PriorityurgentSeveritymajorReproducibilityunable to reproduce
Product Version2017.1 
Target VersionFixed in Version 
Summary0004218: iwlwifi-3160 cannot change txpower when switched to on (0 dBm forever!)
DescriptionThis is my third worst bug i see on my newest version of kali
i'm thinking to download (1.0+,-2.0) instead cause all said its good for all i want
but i have an hope to fix it and i will post the the 2nd soon but by the way we here now!

I'm trying to change the txpower of my Intel Corporation Wireless 3160 (rev 83)
to 30 dBm
but whatever the number of dBm it won't work!!

root@kira:~# ifconfig wlan0 down
root@kira:~# iw reg set 00 # i'm trying 00 cause i can't get something else when i type iw reg set --debug
root@kira:~# iwconfig wlan0 txpower 30 # also tried iw dev wlan0 set txpower fixed 30mBm
root@kira:~# ifconfig wlan0 up
root@kira:~# iwconfig wlan0
wlan0 IEEE 802.11 ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=0 dBm
          Retry short limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:on

and i'm always in need to this command after startup in kali
iwconfig wlan0 txpower on

I have followed multiple posts in AskUbuntu, Null-byte and maybe Superuser too

but with no benefit and i started to think that current kali version is a really trash cause nothing interesting like cracking with my radeon gpu works in this system also...but yes we are in this bug now!

or even penetration testing on an iphone that i noticed they using kind of keep-alive packets that normal deauth attacks won't work for that i was in need to get more power plus other reasons like using airbase-ng on my AP but does that matters?

I feel like a restricted and thinking to code tools myself and that may be illegal, thinking again about how even i will change the txpower if i'm not even knowing what's the root problem or config file of that thing.
Steps To ReproduceWhat do you think?
may i tried everything..
Additional InformationThis txpower doesn't change whatever i change it to
BO , US , EG , ANYCOUNTRY..that won't work....
it will stuck to 0 i even tried from range (1-20)
-does this worked?

I followed this tutorial

but that doesn't work too and i have the latest firmware of my wireless card

believe me i tried all before posting this EXCEPT editing iwconfig CONFIG FILE
that i don't know where to find it to edit the txpower directly and forever

also tried to change the txpower of wlan0mon
haha..but i got "Killed" and then i need to reboot my system to fix the wireless card cause KALI almost CRASHING ALL COMMANDS I TYPE IN TERMINAL IN INFINITE LOOP AFTER THAT
root@kira:~# iwconfig wlan0mon txpower 30
by the way i'm still thinking the problem from this kali

What makes me think that older version would fix the problem?
- Maybe cause all interesting old tutorials use backtrack or 2015 kali versions? that's deserve to try and i will when i found the good old version

so if that case can be resolved i will be really glad to not to download older one which will make me out of updates.
Attached Files




g0tmi1k (administrator)

Due to the age of the OS (Kali Moto [v1], Kali Safi [v2], Kali Rolling 2016.x/2017.1), these legacy versions are no longer supported.
We will be closing this ticket due to inactivity.

Please could you see if you are able to replicate this issue with the latest version of Kali Linux - https://www.kali.org/downloads/)?

If you are still facing the same problem, feel free to re-open the ticket. If you choose to do this, could you provide more information to the issue you are facing,and also give information about your setup?
For more information, please read: https://kali.training/topic/filing-a-good-bug-report/

-Issue History
Date Modified Username Field Change
2017-09-03 02:29 Kira New Issue
2017-09-03 02:29 Kira File Added: Screenshot from 2017-09-03 05-18-30.png
2018-02-21 09:40 g0tmi1k Note Added: 0008704
2018-02-21 09:40 g0tmi1k Status new => closed
+Issue History