2017-09-23 00:14 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004244Kali Linux[All Projects] General Bugpublic2017-09-20 07:38
Reporteryallaen 
Assigned Torhertzog 
PrioritylowSeverityminorReproducibilityalways
StatusassignedResolutionopen 
Product Version2017.1 
Target VersionFixed in Version 
Summary0004244: With VMWare, the initial Xorg screen is not resized before restart of open-vm-tools or click on "fit guest now"
DescriptionWhen you start a Kali VM in VMWare, the initial screen resolution in Xorg is set to 800x600 and it's not resized to the size of the VMWare window even if "Autoresize" is enabled in VMWare. A manual click on "Fit guest now" does work however.

Original report: Up until about 2 weeks ago, my Kali worked fine with VM Workstation 12.x I have been running the latest version of VMWorkstation with no issues. When I log into Kali, I could go "full screen" and it would fit normally.

After updates of about 2 weeks ago, that does not work anymore. Either the screen would stay small in the default setting, or I would have to manually change the resolution to the 16:10 aspect ratio, which is annoying. This does not occur with any other of my OS's I run virtually, including Kali 1, Mint, Ubuntu, and a Windows VM instance. I have co-workers that are experiencing the same issue.
Steps To ReproduceGo to Display, and pull down the menu for the various resolutions. Most are either 16:10 aspect ratio, or 4:3. There is ONE 16:9 ratio, but it's smaller. Kali does not fit the monitor size correctly as it should.
Attached Files

-Relationships
+Relationships

-Notes

~0007323

rhertzog (administrator)

Is your system fully up-to-date? apt update && apt full-upgrade

What version of open-vm-tools and open-vm-tools-desktop are you using ?
dpkg -s open-vm-tools|grep Version
dpkg -s open-vm-tools-desktop|grep Version

What is your current kernel ?
uname -a

~0007324

dookie (administrator)

I've come across this issue of failing to autofit intermittently under VMware Fusion but running "systemctl restart open-vm-tools" fixes it immediately.

~0007328

yallaen (reporter)

Ok, I usually always do a apt-get update, apt-get upgrade, and apt-get dist-upgrade weekly or every couple of weeks. I did these recently, and I also ensured that my VMTools installed was recent. But, here are the results:

Current Kernel:
Linux kali 4.9.0-kali4-amd64 0000001 SMP Debian 4.9.30-2kali1 (2017-06-22) x86_64 GNU/Linux

Now this is weird:
open-vm-tools:
dpkg -s open-vm-tools|grep Version
dpkg-query: package 'open-vm-tools' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.

Same thing for the other:
dpkg -s open-vm-tools-desktop | grep Version
dpkg-query: package 'open-vm-tools-desktop' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.

But I loaded VM tools...and it's working on other VM machines. I guess I will re-install VM Tools and see what's up. But I've noticed this error starting now, which was after I issued the apt full-upgrade:

Preconfiguring packages ...
dpkg: warning: 'ldconfig' not found in PATH or not executable
dpkg: warning: 'start-stop-daemon' not found in PATH or not executable
dpkg: error: 2 expected programs not found in PATH or not executable
Note: root's PATH should usually contain /usr/local/sbin, /usr/sbin and /sbin
E: Sub-process /usr/bin/dpkg returned an error code (2)

I'm going to try the suggested command and see what happens first:
systemctl restart open-vm-tools

And that got me
Failed to restart open-vm-tools.service: Unit open-vm-tools.service not found.

Ok, I don't know what's going on. Let me do some real world work on my house, then I'll blow away this VM and recreate a new one and see what happens. Unless you have other suggestions. I dont want to try and do multiple fixes under one ticket. The focus is the resolution issue, which seems to be because it's reporting that vm tools isn't loaded, which it is...but I'll redo.

~0007329

rhertzog (administrator)

Well, did you install VMWare tools manually or with the Debian package?

In any case, your system looks badly screwed up currently.

~0007331

yallaen (reporter)

Please bare with me, my linux-fu is not that great. However, let me show you something interesting that may shed light. I will attach screenshots I took as I went about this, so you may need to look at several notes.

I blew away the Kali Linux 2 VM, and started from scratch. This was based on your comment "In any case, your system looks badly screwed up currently". I concurred, and started new.

Pic 1 called "Kali before tools" is the latest VM I just created last night. I did no updates:
Linux kali 4.9.0-kali3-amd64 0000001 SMP Debian 4.9.18-1kali1 (2017-04-04) x86_64 GNU/Linux

~0007332

muts (administrator)

Your system is not fully up to date (as can be seen by your kernel version). Until this is not rectified on your side, your bug report is not actionable.

~0007333

yallaen (reporter)

If you look at the progressive pics I've attached, you can see I d/l'ed the current VMTools, extracted, and ran it. You can also see that the resolutions were minimal initially with the first screenshot, and then with the last screenshot the resolutions showed up correctly. The VM is defaulted with Autosize>Autofit Guest, and the resolution is now correct at 16:9.

Now, perhaps I misunderstand your commands from earlier, but I want to confirm this for both my knowledge and yours. You told me up above to run

dpkg -s open-vm-tools|grep Version and
dpkg -s open-vm-tools-desktop|grep Version

But is that looking for specifically those open vm tools? Because I have the paid version of VMWorkstation 12.x. After loading Kali, I clicked on the VM>Install VM Tools, which downloaded the "cd" of those tools (see the screenshot which shows the folder I extracted, it is VMwareTools-10.1.6-5214329

Now, running your commands above after I re-loaded Kali, and successfully installed VMTools (you can see the screenshots for the msgs that it successfully installed), I get the following:

root@kali:~# dpkg -s open-vm-tools|grep Version
dpkg-query: package 'open-vm-tools' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.

root@kali:~# dpkg -s open-vm-tools-desktop|grep Version
dpkg-query: package 'open-vm-tools-desktop' is not installed and no information is available
Use dpkg --info (= dpkg-deb --info) to examine archive files,
and dpkg --contents (= dpkg-deb --contents) to list their contents.

I'm thinking that your command is looking for an open source version of VMTools, vs. what I installed, which is the actual paid version included from VMWare.

As of right now, Kali Linux 2017.1 is running fine. I just did an apt update and an apt upgrade, and everything is current. Everything appears to be running correctly at this time, including the auto-sizing.

Sorry so long-winded, but I want to ensure we are troubleshooting correctly.

~0007334

muts (administrator)

We are not. You will need to start again as you have polluted your installation with the wrong version of vmware tools. Please read this, and follow the instructions there to the letter : https://docs.kali.org/general-use/install-vmware-tools-kali-guest

~0007335

yallaen (reporter)

Ok, d/l'ed the Kali 64bit VM. Ran it. Updated it. This is what I'm reporting:

uname -a
Linux kali 4.9.0-kali3-amd64 0000001 SMP Debian 4.9.18-1kali1 (2017-04-04) x86_64 GNU/Linux

dpkg -s open-vm-tools|grep Version
Version: 2:10.1.10-2

Same for desktop...

Cut/paste between monitors stopped working. I have my Firefox open on main laptop monitor, and my VM open in an HDMI connected monitor. I used to be able to cut/paste between the two. Now I cant. However, the core issue appears to still be resolved: I can full screen and it works fine.

I did an apt update and apt upgrade, even an apt dist-upgrade, and all still appears to be working EXCEPT the cut/paste between the instances. So the core issues appear resolved. I am going to try and do this with my work laptop as well, and see if it resolves that too. Not as powerful a laptop as my home laptop, but still both are ASUS, both running VMWorkstation 12.x (updated), and both have NVidia graphics cards. The work laptop is having the same issue as my home one. I will try these fixes on that and see if it resolves.

Thank you for the help! Also, it's good to know that VMTools should not be loaded.

~0007336

yallaen (reporter)

Ok, before you close...still have an issue

~0007337

yallaen (reporter)

So, my work laptop is ALMOST the same setup as my home laptop. But it's not resolved on it. I have blown away and reloaded. I did not load VMTools; it was a VM image, and the open-vm-tools were already loaded. So, there are a couple slight differences:

uname-a
Linux alpine-kali 4.9.0-kali4-amd64 0000001 SMP Debian 4.9.30-2kali1 (2017-06-22) x86_64 GNU/Linux

When I do dpkg -s open-vm-tools|grep Version, I get:

Version: 2:10.1.10-2
Config-Version: 2:10.1.5-5055683

Same with the "Desktop"

That config-version didnt pop up before.

Full screen did not go full screen, nor allow 16:9 as resolution in 1920x1080.

Also, running systemctl restart open-vm-tools, allowed me to go full screen, and appeared to be 16:9. However, when I rebooted, it fails to go full screen again.
I have to run that command systemctl restart open-vm-tools to get it back full screen. Thoughts?

~0007343

muts (administrator)

Once again, kernel 4.9 is outdated. Your system is not fully updated. Please follow the instructions given in my last note before posting here again.

~0007345

yallaen (reporter)

Trying this again:

Followed the instructions per your direction (again). Started with brand new VM machine. Did the apt update && apt -y full-upgrade, results:

Linux alpine-kali 4.12.0-kali1-amd64 0000001 SMP Debian 4.12.6-1kali6 (2017-08-30) x86_64 GNU/Linux

root@kali:~# dpkg -s open-vm-tools |grep Version
Version: 2:10.1.10-2
root@kali:~# dpkg -s open-vm-tools-Desktop |grep Version
Version: 2:10.1.10-2

Still having issues. When the VM starts and Kali boots, it's in 800x600 mode. Autofit Guest is selected, and the check mark is next to Autofit Window. When I try to go to full screen, nothing happens. When I run the systemctl restart open-vm-tools command, it will go to full screen mode.

All of my other VM's work correctly.

~0007356

rhertzog (administrator)

I'm changing the bug description accordingly. And yes this is a known (minor) issue (that you don't have if you use Wayland, it's Xorg specific).

~0007369

yallaen (reporter)

Curious, how do you know the difference between Wayland vs Xorg? And can it be changed?

~0007371

rhertzog (administrator)

It can be changed in /etc/gdm3/daemon.conf (WaylandEnable=true) and you can check the process list... if you see Xwayland then use wayland, if you see Xorg then you use Xorg.

There are different environment variables too.
+Notes

-Issue History
Date Modified Username Field Change
2017-09-14 13:35 yallaen New Issue
2017-09-14 16:08 rhertzog Note Added: 0007323
2017-09-14 16:08 rhertzog Assigned To => rhertzog
2017-09-14 16:08 rhertzog Status new => feedback
2017-09-14 17:14 dookie Note Added: 0007324
2017-09-14 21:39 yallaen Note Added: 0007328
2017-09-14 21:39 yallaen Status feedback => assigned
2017-09-15 06:22 rhertzog Note Added: 0007329
2017-09-15 12:41 yallaen File Added: Kali before tools.JPG
2017-09-15 12:41 yallaen Note Added: 0007331
2017-09-15 12:42 yallaen File Added: Kali with latest VM tools.JPG
2017-09-15 12:42 yallaen File Added: Kali running vm install.JPG
2017-09-15 12:42 yallaen File Added: Full install run of vmtools with defaults selected.JPG
2017-09-15 12:43 yallaen File Added: Initial success msgs.JPG
2017-09-15 12:50 muts Note Added: 0007332
2017-09-15 12:56 yallaen Note Added: 0007333
2017-09-15 14:15 muts Note Added: 0007334
2017-09-15 16:53 yallaen Note Added: 0007335
2017-09-15 17:10 yallaen Note Added: 0007336
2017-09-15 17:18 yallaen Note Added: 0007337
2017-09-16 06:46 muts Note Added: 0007343
2017-09-18 00:58 yallaen Note Added: 0007345
2017-09-18 10:05 rhertzog Priority normal => low
2017-09-18 10:05 rhertzog Summary The 16:9 resolutions for 1920x1080 and others are gone; autofit guest does not work in VM => With VMWare, the initial Xorg screen is not resized before restart of open-vm-tools or click on "fit guest now"
2017-09-18 10:05 rhertzog Description Updated View Revisions
2017-09-18 10:05 rhertzog Note Added: 0007356
2017-09-19 20:32 yallaen Note Added: 0007369
2017-09-20 07:38 rhertzog Note Added: 0007371
+Issue History