View Issue Details

IDProjectCategoryView StatusLast Update
0004261Kali Linux[All Projects] Tool Upgradepublic2017-09-25 10:50
Reportermrfrank25Assigned Tosbrun 
PriorityhighSeveritycrashReproducibilityalways
Status resolvedResolutionfixed 
Product Version2017.2 
Target VersionFixed in Version 
Summary0004261: mitmf stopped working after system update
Descriptioni have had mitmf working on my computers for a long time with no problems ever then i upgraded my kali and now when i try running mitmf it no longer works and gives me this error -

root@kali1:~# mitmf --arp --spoof --gateway 10.0.1.1 --targets 10.0.1.10 -i eth0
Traceback (most recent call last):
  File "./mitmf.py", line 33, in <module>
    from twisted.internet import reactor
  File "/usr/lib/python2.7/dist-packages/twisted/internet/reactor.py", line 38, in <module>
    from twisted.internet import default
  File "/usr/lib/python2.7/dist-packages/twisted/internet/default.py", line 56, in <module>
    install = _getInstallFunction(platform)
  File "/usr/lib/python2.7/dist-packages/twisted/internet/default.py", line 44, in _getInstallFunction
    from twisted.internet.epollreactor import install
  File "/usr/lib/python2.7/dist-packages/twisted/internet/epollreactor.py", line 24, in <module>
    from twisted.internet import posixbase
  File "/usr/lib/python2.7/dist-packages/twisted/internet/posixbase.py", line 18, in <module>
    from twisted.internet import error, udp, tcp
  File "/usr/lib/python2.7/dist-packages/twisted/internet/tcp.py", line 28, in <module>
    from twisted.internet._newtls import (
  File "/usr/lib/python2.7/dist-packages/twisted/internet/_newtls.py", line 21, in <module>
    from twisted.protocols.tls import TLSMemoryBIOFactory, TLSMemoryBIOProtocol
  File "/usr/lib/python2.7/dist-packages/twisted/protocols/tls.py", line 41, in <module>
    from OpenSSL.SSL import Error, ZeroReturnError, WantReadError
  File "/usr/local/lib/python2.7/dist-packages/OpenSSL/__init__.py", line 8, in <module>
    from OpenSSL import rand, crypto, SSL
  File "/usr/local/lib/python2.7/dist-packages/OpenSSL/SSL.py", line 118, in <module>
    SSL_ST_INIT = _lib.SSL_ST_INIT
AttributeError: 'module' object has no attribute 'SSL_ST_INIT'
root@kali1:~#


i have kali fully booted on 3 computers so i have tried running mitmf on another kali machine to see what happens, i have MITMF VERSION 0.9.8 installed from kali repository running on both computers i haven't tried my laptop yet but the 2nd kali machine is giving me this error message instead -

root@kali1:~# mitmf --arp --spoof --gateway 10.0.1.1 --targets 10.0.1.10 -i eth0

Traceback (most recent call last):
  File "./mitmf.py", line 36, in <module>
    from plugins import *
  File "/usr/share/mitmf/plugins/filepwn.py", line 72, in <module>
    from libs.bdfactory import pebin
ImportError: No module named bdfactory
  

please see if you can help fix this

thanks so much!!
Steps To Reproduceapt-get update
apt-get upgrade
apt-get dist-upgrade

mitmf --arp --spoof --gateway 10.0.1.1 --targets 10.0.1.10 -i eth0

Activities

mrfrank25

2017-09-24 03:52

reporter  

mrfrank25

2017-09-24 05:42

reporter   ~0007401

also i tried running older versions of MITMF from GitHub and im getting the same problem even with older versions so there must be something wrong in the latest kali update that is causing this problem

sbrun

2017-09-25 10:50

manager   ~0007404

I reproduced "ImportError: No module named bdfactory": the package backdoor-factory changed and it broke mitmf.
The new version 0.9.8-0kali2 of mitmf will fix this issue.

For the issue "AttributeError: 'module' object has no attribute 'SSL_ST_INIT'":
the problem is that the module openssl imported by mitmf is a module installed "manually" in /usr/local/* (probably installed via pip). You should remove it.

Issue History

Date Modified Username Field Change
2017-09-24 03:52 mrfrank25 New Issue
2017-09-24 03:52 mrfrank25 Status new => assigned
2017-09-24 03:52 mrfrank25 Assigned To => sbrun
2017-09-24 03:52 mrfrank25 File Added: Screenshot from 2017-09-23 20-46-45.png
2017-09-24 05:42 mrfrank25 Note Added: 0007401
2017-09-25 10:50 sbrun Status assigned => resolved
2017-09-25 10:50 sbrun Resolution open => fixed
2017-09-25 10:50 sbrun Note Added: 0007404