View Issue Details

IDProjectCategoryView StatusLast Update
0004269Kali LinuxQueued Tool Additionpublic2021-05-18 11:02
Reporterg0tmi1k Assigned Tosbrun  
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Summary0004269: CherryTree - A hierarchical note taking application
Description

Name: CherryTree
Version: 0.38.2
Homepage: http://www.giuspen.com/cherrytree/
Download: http://www.giuspen.com/software/cherrytree_0.38.2-0_all.deb // https://github.com/giuspen/cherrytree/archive/0.38.2.tar.gz
Licence: GNU 3 (https://github.com/giuspen/cherrytree/blob/master/license.txt)
Description: A hierarchical note taking application, featuring rich text and syntax highlighting, storing data in a single xml or sqlite file.

  • rich text (foreground color, background color, bold, italic, underline, strikethrough, small, h1, h2, h3, subscript, superscript, monospace)
  • syntax highlighting supporting several programming languages
  • images handling: insertion in the text, edit (resize/rotate), save as png file
  • embedded files handling: insertion in the text, save to disk
  • multi-level lists handling (bulleted, numbered, to-do and switch between them, multiline with shift+enter)
  • simple tables handling (cells with plain text), cut/copy/paste row, import/export as csv file
  • codeboxes handling: boxes of plain text (optionally with syntax highlighting) into rich text, import/export as text file
  • execution of the code for code nodes and codeboxes; the terminal and the command per syntax highlighting is configurable in the preferences dialog
  • alignment of text, images, tables and codeboxes (left/center/right/fill)
  • hyperlinks associated to text and images (links to webpages, links to nodes/nodes + anchors, links to files, links to folders)
  • spell check (using pygtkspellcheck and pyenchant)
  • intra application copy/paste: supported single images, single codeboxes, single tables and a compound selection of rich text, images, codeboxes and tables
  • cross application copy/paste (tested with libreoffice and gmail): supported single images, single codeboxes, single tables and a compound selection of rich text, images, codeboxes and tables
  • copying a list of files from the file manager and pasting in cherrytree will create a list of links to files, images are recognized and inserted in the text
  • print & save as pdf file of a selection / node / node and subnodes / the whole tree
  • export to html of a selection / node / node and subnodes / the whole tree
  • export to plain text of a selection / node / node and subnodes / the whole tree
  • toc generation for a node / node and subnodes / the whole tree, based on headers h1, h2 and h3
  • find a node, find in selected node, find in selected node and subnodes, find in all nodes
  • replace in nodes names, replace in selected node, replace in selected node and subnodes, replace in all nodes
  • iteration of the latest find, iteration of the latest replace, iteration of the latest applied text formatting
  • import from html file, import from folder of html files
  • import from plain text file, import from folder of plain text files
  • import from basket, cherrytree, epim html, gnote, keepnote, keynote, knowit, mempad, notecase, rednotebook, tomboy, treepad lite, tuxcards, zim
  • export to cherrytree file of a selection / node / node and subnodes / the whole tree
  • password protection (using http://www.7-zip.org/) – NOTE: while a cherrytree password protected document is opened, an unprotected copy is extracted to a temporary folder of the filesystem; this copy is removed when you close cherrytree
  • tree nodes drag and drop
  • automatic link to web page if writing the URL
  • automatic link to node if writing node name either with no spaces and camelcase or surrounded by [[node name]]
Additional Information

We have 'KeepNote' in Kali currently, but it hasn't been updated since 2012-March-26.
CherryTree is activity being development, and has been for years (since 2010).

Relationships

related to 0004630 closed Replace / Add a tool - CherryTree editor vs KeepNote 

Activities

sbrun

sbrun

2017-10-12 07:14

manager   ~0007522

cherrytree is now in kali-rolling

Issue History

Date Modified Username Field Change
2017-09-26 15:23 g0tmi1k New Issue
2017-09-26 15:23 g0tmi1k Status new => assigned
2017-09-26 15:23 g0tmi1k Assigned To => sbrun
2017-10-12 07:14 sbrun Status assigned => resolved
2017-10-12 07:14 sbrun Resolution open => fixed
2017-10-12 07:14 sbrun Fixed in Version => 2017.3
2017-10-12 07:14 sbrun Note Added: 0007522
2018-03-13 07:52 g0tmi1k Relationship added related to 0004630
2021-05-18 11:02 g0tmi1k Category New Tool Requests => Queued Tool Addition