2017-10-16 23:53 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004273Kali Linux[All Projects] Kali Package Bugpublic2017-09-30 14:07
ReporterTrue Demon 
Assigned Torhertzog 
PriorityhighSeveritymajorReproducibilityalways
StatusresolvedResolutionfixed 
Product Version2017.2 
Target VersionFixed in Version 
Summary0004273: Unable to clone/pull repositories from git.kali.org
DescriptionYesterday after testing out a script I was writing to download Kali packages via git.kali.org, I suddenly lost the ability to clone/pull any tools from the repository. After ruling out any network errors or possible issues on my end, I asked several colleagues and attempted to connect using various means from other networks. I tried connecting through a VPN to several locations in the US, asked friends and colleagues from other locations (3 in US, 1 in Netherlands) to attempt to clone something, and none have been able to.

We all get the same error "Connection reset by peer"

Steps To ReproduceWhether it is through my script or calling git clone directly from command line, the error is the same.

Direct git clone/pull:
git clone -v git://git.kali.org/packages/commix.git
| Cloning into 'commix'...
| fatal: read error: Connection reset by peer

My script's stack trace:
git.exc.GitCommandError: Cmd('git') failed due to: exit code(128)
  |cmdline: git clone -v git://git.kali.org/packages/commix.git /tmp/commix
  |stderr: 'Cloning into '/tmp/commix'...
  |fatal: read error: Connection reset by peer

Additional InformationEssentially, the error indicates that git.kali.org is not responding to any git requests and I am unable to clone/pull any packages. I noticed that in Kali news there is a new release and that several changes have occurred in how Kali packages work when using Advanced Packaging Tool with the release of kali-bleeding-edge.

I'm mostly curious if the paths have changed to clone repositories from git.kali.org or if something actually did indeed break on your guys' end. It doesn't seem likely that the git repos would just suddenly stop working, but if the paths were changed, that would make sense.
Attached Files

-Relationships
has duplicate 0004275closedrhertzog GIT - Fatal read error 
has duplicate 0004274closedrhertzog the git repo is not accessible 
+Relationships

-Notes

~0007420

True Demon (reporter)

There is a typo in the title. Meant to say "clone/pull." Obviously, I can't push changes to Kali's repos XD

~0007423

rhertzog (administrator)

Can you try again and let me know if it's fixed for you?

~0007426

True Demon (reporter)

Working like a dream! :)
Can I ask what the issue was? If it's something I can account for in my script, I'd like to try to make it as robust as possible.

~0007431

rhertzog (administrator)

There were many stale processes on the server side and it was thus refusing new connections. I just killed the stale processes.
+Notes

-Issue History
Date Modified Username Field Change
2017-09-29 14:29 True Demon New Issue
2017-09-29 14:31 True Demon Note Added: 0007420
2017-09-29 18:23 g0tmi1k Relationship added has duplicate 0004275
2017-09-29 18:23 g0tmi1k Relationship added has duplicate 0004274
2017-09-29 18:23 g0tmi1k Summary Unable to clone/push repositories from git.kali.org => Unable to clone/pull repositories from git.kali.org
2017-09-29 19:23 rhertzog Assigned To => rhertzog
2017-09-29 19:23 rhertzog Status new => feedback
2017-09-29 19:23 rhertzog Note Added: 0007423
2017-09-29 20:18 True Demon Note Added: 0007426
2017-09-29 20:18 True Demon Status feedback => assigned
2017-09-30 14:07 rhertzog Status assigned => resolved
2017-09-30 14:07 rhertzog Resolution open => fixed
2017-09-30 14:07 rhertzog Note Added: 0007431
+Issue History