View Issue Details

IDProjectCategoryView StatusLast Update
0004273Kali LinuxKali Package Bugpublic2020-12-01 10:48
ReporterTrue Demon Assigned Torhertzog  
Status resolvedResolutionfixed 
Product Version2017.2 
Summary0004273: Unable to clone/pull repositories from

Yesterday after testing out a script I was writing to download Kali packages via, I suddenly lost the ability to clone/pull any tools from the repository. After ruling out any network errors or possible issues on my end, I asked several colleagues and attempted to connect using various means from other networks. I tried connecting through a VPN to several locations in the US, asked friends and colleagues from other locations (3 in US, 1 in Netherlands) to attempt to clone something, and none have been able to.

We all get the same error "Connection reset by peer"

Steps To Reproduce

Whether it is through my script or calling git clone directly from command line, the error is the same.

Direct git clone/pull:
git clone -v git://
| Cloning into 'commix'...
| fatal: read error: Connection reset by peer

My script's stack trace:
git.exc.GitCommandError: Cmd('git') failed due to: exit code(128)
|cmdline: git clone -v git:// /tmp/commix
|stderr: 'Cloning into '/tmp/commix'...
|fatal: read error: Connection reset by peer

Additional Information

Essentially, the error indicates that is not responding to any git requests and I am unable to clone/pull any packages. I noticed that in Kali news there is a new release and that several changes have occurred in how Kali packages work when using Advanced Packaging Tool with the release of kali-bleeding-edge.

I'm mostly curious if the paths have changed to clone repositories from or if something actually did indeed break on your guys' end. It doesn't seem likely that the git repos would just suddenly stop working, but if the paths were changed, that would make sense.


has duplicate 0004275 closedrhertzog GIT - Fatal read error 
has duplicate 0004274 closedrhertzog the git repo is not accessible 


True Demon

True Demon

2017-09-29 14:31

reporter   ~0007420

There is a typo in the title. Meant to say "clone/pull." Obviously, I can't push changes to Kali's repos XD



2017-09-29 19:23

administrator   ~0007423

Can you try again and let me know if it's fixed for you?

True Demon

True Demon

2017-09-29 20:18

reporter   ~0007426

Working like a dream! :)
Can I ask what the issue was? If it's something I can account for in my script, I'd like to try to make it as robust as possible.



2017-09-30 14:07

administrator   ~0007431

There were many stale processes on the server side and it was thus refusing new connections. I just killed the stale processes.

Issue History

Date Modified Username Field Change
2017-09-29 14:29 True Demon New Issue
2017-09-29 14:31 True Demon Note Added: 0007420
2017-09-29 18:23 g0tmi1k Relationship added has duplicate 0004275
2017-09-29 18:23 g0tmi1k Relationship added has duplicate 0004274
2017-09-29 18:23 g0tmi1k Summary Unable to clone/push repositories from => Unable to clone/pull repositories from
2017-09-29 19:23 rhertzog Assigned To => rhertzog
2017-09-29 19:23 rhertzog Status new => feedback
2017-09-29 19:23 rhertzog Note Added: 0007423
2017-09-29 20:18 True Demon Note Added: 0007426
2017-09-29 20:18 True Demon Status feedback => assigned
2017-09-30 14:07 rhertzog Status assigned => resolved
2017-09-30 14:07 rhertzog Resolution open => fixed
2017-09-30 14:07 rhertzog Note Added: 0007431
2020-12-01 10:48 g0tmi1k Priority high => normal