View Issue Details

IDProjectCategoryView StatusLast Update
0000429Kali Linux[All Projects] Tool Upgradepublic2013-07-03 20:54
Reporterg0tmi1k Assigned Todookie  
PrioritynoneSeveritytrivialReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0000429: Wordlists - symbolic link to more!
Description#--- Linking to more - folders
ln -sf /usr/share/dirb/wordlists /usr/share/wordlists/dirb
ln -sf /usr/share/dirbuster/wordlists /usr/share/wordlists/dirbuster
ln -sf /usr/share/fern-wifi-cracker/extras/wordlists /usr/share/wordlists/fern-wifi
ln -sf /usr/share/metasploit-framework/data/john/wordlists /usr/share/wordlists/metasploit-jtr
ln -sf /usr/share/metasploit-framework/data/wordlists /usr/share/wordlists/metasploit
ln -sf /opt/metasploit/apps/pro/data/wordlists /usr/share/wordlists/metasploit-pro
ln -sf /usr/share/webslayer/wordlist /usr/share/wordlists/webslayer
ln -sf /usr/share/wfuzz/wordlist /usr/share/wordlists/wfuzz
#--- Linking to more - files
unzip -o -d /usr/share/sqlmap/txt/ /usr/share/sqlmap/txt/wordlist.zip
ln -sf /usr/share/sqlmap/txt/wordlist.txt /usr/share/wordlists/sqlmap.txt
ln -sf /usr/share/dnsmap/wordlist_TLAs.txt /usr/share/wordlists/dnsmap.txt
ln -sf /usr/share/golismero/wordlist/wfuzz/Discovery/all.txt /usr/share/wordlists/wfuzz.txt
ln -sf /usr/share/nmap/nselib/data/passwords.lst /usr/share/wordlists/nmap.lst
ln -sf /usr/share/set/src/fasttrack/wordlist.txt /usr/share/wordlists/fasttrack.txt
ln -sf /usr/share/termineter/framework/data/smeter_passwords.txt /usr/share/wordlists/termineter.txt
ln -sf /usr/share/w3af/core/controllers/bruteforce/passwords.txt /usr/share/wordlists/w3af.txt
ln -sf /usr/share/wpscan/spec/fixtures/wpscan/modules/bruteforce/wordlist.txt /usr/share/wordlists/wpscan.txt
#ln -sf /usr/share/arachni/spec/fixtures/passwords.txt /usr/share/wordlists/arachni
#ln -sf /usr/share/cisco-auditing-tool/lists/passwords /usr/share/wordlists/cisco-auditing-tool/
#ln -sf /usr/share/wpscan/spec/fixtures/wpscan/wpscan_options/wordlist.txt /usr/share/wordlists/wpscan-options.txt




*** BOUNS ***
#--- Extract rockyou wordlist
gzip -dc < /usr/share/wordlists/rockyou.txt.gz > /usr/share/wordlists/rockyou.txt
#--- Extract sqlmap wordlist
unzip -o -d /usr/share/sqlmap/txt/ /usr/share/sqlmap/txt/wordlist.zip
#--- Add 10,000 Top/Worst/Common Passwords
wget http://xato.net/files/10k%20most%20common.zip -O /tmp/10kcommon.zip
unzip -o -d /usr/share/wordlists/ /tmp/10kcommon.zip
rm -f /tmp/10kcommon.zip
mv -f /usr/share/wordlists/10k{\ most\ ,_most_}common.txt
#--- Not enough? Want more? Check below!
#apt-cache search wordlist
#find / \( -iname '*wordlist*' -or -iname '*passwords*' \)
Additional InformationJust an idea.
Talked to dookie about it - and he liked the sound of it.

Activities

dookie

2013-07-03 20:54

administrator   ~0000610

Updated in wordlists_0.3-1kali1.

I have a postinst that will check for the presence of the other tools and make symlinks if they exist.
The rockyou list is staying compressed because it helps keep the size of the ISOs and overall installation small.

Thanks!

Issue History

Date Modified Username Field Change
2013-07-01 13:04 g0tmi1k New Issue
2013-07-01 13:05 dookie Assigned To => dookie
2013-07-01 13:05 dookie Status new => assigned
2013-07-03 20:54 dookie Note Added: 0000610
2013-07-03 20:54 dookie Status assigned => resolved
2013-07-03 20:54 dookie Resolution open => fixed