View Issue Details

IDProjectCategoryView StatusLast Update
0004345Kali Linux[All Projects] New Tool Requestspublic2020-03-25 13:15
Reportermazen160_ Assigned To 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0004345: BFAC (Backup File Artifacts Checker)
DescriptionBFAC (Backup File Artifacts Checker) is an automated tool that checks for backup artifacts that may disclose the web-application's source code. The artifacts can also lead to leakage of sensitive information, such as passwords, directory structure, etc.

The goal of BFAC is to be an all-in-one tool for backup-file artifacts black-box testing.


Homepage: https://github.com/mazen160/bfac

Activities

g0tmi1k

2018-01-29 14:41

administrator   ~0008359

To help speed up the process of evaluating the tool, please make sure to include the following information (the more information you include, the more beneficial it will for us):

- [Name] - The name of the tool
- [Version] - What version of the tool should be added?
--- If it uses source control (such as git), please make sure there is a release to match (e.g. git tag)
- [Homepage] - Where can the tool be found online? Where to go to get more information?
- [Download] - Where to go to get the tool?
- [Author] - Who made the tool?
- [Licence] - How is the software distributed? What conditions does it come with?
- [Description] - What is the tool about? What does it do?
- [Dependencies] - What is needed for the tool to work?
- [Similar tools] - What other tools are out there?
- [How to install] - How do you compile it?
- [How to use] - What are some basic commands/functions to demonstrate it?

mazen160_

2018-02-13 07:00

reporter   ~0008664

Hi g0tmi1k,

[NAME]: bfac

[Version]: v1.4

[Homepage]: https://github.com/mazen160/bfac

[Download]: https://github.com/mazen160/bfac/archive/master.zip

[Author]: Mazin Ahmed

[Licence]: GNU GPLv3.0

[Description]: An automated tool that checks for backup artifacts that may disclose the web-application's source code.

[Dependencies]: The tool is written in Python. It works on both Python2 and Python3. Required modules:
* requests
* colorama

Both are pre-installed by default on Kali.

[Similar tools]: bfac is currently the only tool that provides this test with this quality.

[How to install]:
sudo python setup.py install

[How to use]:
All usage instructions and commands are available at:
https://github.com/mazen160/bfac/blob/master/README.md



Thanks,
Mazin Ahmed

g0tmi1k

2020-03-25 13:15

administrator   ~0012528

This program looks like it hasn't recently received any updates.
If development picks up again, we will re-evaluate

Issue History

Date Modified Username Field Change
2017-11-11 15:51 mazen160_ New Issue
2018-01-29 14:24 g0tmi1k Summary [Tool Request] BFAC => BFAC (Backup File Artifacts Checker)
2018-01-29 14:41 g0tmi1k Note Added: 0008359
2018-02-13 07:00 mazen160_ Note Added: 0008664
2019-12-09 13:30 g0tmi1k Severity minor => feature
2020-03-25 13:15 g0tmi1k Note Added: 0012528
2020-03-25 13:15 g0tmi1k Status new => closed
2020-03-25 13:15 g0tmi1k Resolution open => suspended