View Issue Details

IDProjectCategoryView StatusLast Update
0004374Kali Linux[All Projects] Kali Package Improvementpublic2019-02-26 16:41
ReporterbusterbAssigned Tosbrun 
PrioritynormalSeveritytweakReproducibilityN/A
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version 
Summary0004374: Please update the metasploit-framework package to track the 4.x branch
DescriptionWe are transitioning master to a new major version for Metasploit Framework. Because it will be development, it would be best if metasploit-framework distributions used the 4.x branch for now until 5.x is stable.

Can you please update Kali to package from the 4.x branch for now?

See https://github.com/rapid7/metasploit-framework/pull/9259 for more information.
Additional InformationWe'd also be happy to hear what you would like to see out of a major new Metasploit Framework, as a training company and a distributor.

Activities

sbrun

2017-11-30 13:47

manager   ~0007642

Well noted. We won't package version 5.x until it's stable.

We track the tagged releases in github. Will you make releases of "unstable" version 5.x before it's stable?

busterb

2017-12-27 21:50

reporter   ~0007751

We are planning to release some pre-5.0 releases sometimes in spring/summer 2018.

Thanks!

busterb

2018-12-11 17:02

reporter   ~0010101

Hi, we are aiming for January 10th for making a 5.x branch and the release of the first 5.0 stable release. Just a heads-up for your packagers (and I believe you are also upstream for Parrotsec as well).

busterb

2018-12-11 17:07

reporter   ~0010102

Of note, the 'msfdb' command is now integrated into the source tree as well, since it includes some functionality for exposing some of Metasploit's new REST web services for the database layer.

However, this release is still 100% compatible with a local database, and still works with no database at all, so it should still work with Kali's variant of the msfdb command for now. We plan on making future changes to the data model in a new unstable branch however, after 5.0 is released.

busterb

2019-01-10 18:14

reporter   ~0010197

We tagged 5.0.0 today in master. We are not ready to open a 5.x branch yet, and will continue maintaining the 4.x branch for the next few months as well. If you want to start looking at packaging the new features with MSF5, feel free to start testing on the 5.x.y tag series. Thanks!

rhertzog

2019-01-11 11:30

administrator   ~0010199

Thanks @busterb. We are looking into packaging Metasploit 5.0.0. We have some trouble with your new "msfdb" script... it assumes pg_ctl is available in the PATH, it's not the case in Debian/Kali currently because the Debian packaging provides some higher level tool called "pg_ctlcluster" which makes it easy for admins to run multiple PostgreSQL servers side-by-side. pg_ctl is only available in a versioned directory (/usr/lib/postgresql/11/bin/)

pg_ctlcluster will automaticaly use ports 5433 and higher for new "clusters" that it creates. This means that I expect your msfdb to run into troubles on machines where those port numbers are already used for alternate databases (this happens in particular when you upgrade from one version of PostgreSQL to the next, this higher level tool is able to migrate a database by running two different versions of PostgreSQL side by side). Hence I would suggest to rather use port 5431 as an alternate port number (we will patch this in our packaging).

We will probably somehow expand the PATH so that msfdb is able to find pg_ctl but it would be better if we could somehow teach "msfdb init" to:
- eitheir use "pg_createcluster" and "pg_lsclusters" directly (the downside being that you have to know/find out the current version of PostgreSQL)
- or reuse an existing cluster and just setup the new database inside that cluster

The term "cluster" refers to a postgresql data directory and its associated configuration, it's specific to a given version of PostgreSQL

busterb

2019-01-11 14:59

reporter   ~0010200

As a general goal, we made sure that the the 5.x series continue to also work with the Kali Linux-specific version of the msfdb tool, so if you prefer for now, you can continue to ship the version that is in the 4.x package and the database will continue to function as it did before.

I'll share this with the team as well to make sure we can address the items above as well. Thanks for the update!

sbrun

2019-01-18 15:27

manager   ~0010227

I uploaded the version 5.0.1-0kali1 in kali-experimental. autopackage tests run successfully now.
For the moment we keep our msfdb version.

sbrun

2019-01-25 15:00

manager   ~0010239

We are now tracking the 5.0.* versions.
version 5.0.1-0kali1 is in kali-rolling

rhertzog

2019-02-06 09:45

administrator   ~0010263

@busterb While our msfdb still works for the database, it's not able to start the webservice so we would like to switch sooner rather than later to your msfdb. Shall I open a ticket on your side to discuss how to improve msfdb so that it works better in a Debian environment where pg_ctl is not in the PATH and where we have other helper scripts (pg_createcluster, pg_ctlcluster, etc.)?

busterb

2019-02-06 17:27

reporter   ~0010266

Thanks, a public ticket would be helpful.

rhertzog

2019-02-07 09:54

administrator   ~0010267

Filed here: https://github.com/rapid7/metasploit-framework/issues/11369

pranavperfect

2019-02-19 00:12

reporter   ~0010318

Apologies for adding a duplicate issue on Kali git repository about MSFDB service not running on Kali Linux. Issue number: 0005262: Metasploit-Framework Database API not working

sbrun

2019-02-19 09:06

manager   ~0010321

Closing this issue as we switch to the 5.x branch

The discussion about msfdb issues will continue here:
https://github.com/rapid7/metasploit-framework/issues/11369

And we keep the bug 5262 opened in Kali bug tracker.

Issue History

Date Modified Username Field Change
2017-11-29 17:19 busterb New Issue
2017-11-30 13:47 sbrun Assigned To => sbrun
2017-11-30 13:47 sbrun Status new => assigned
2017-11-30 13:47 sbrun Note Added: 0007642
2017-12-27 21:50 busterb Note Added: 0007751
2018-10-30 11:27 g0tmi1k Product Version kali-dev =>
2018-12-11 17:02 busterb Note Added: 0010101
2018-12-11 17:07 busterb Note Added: 0010102
2019-01-10 18:14 busterb Note Added: 0010197
2019-01-11 11:30 rhertzog Note Added: 0010199
2019-01-11 14:59 busterb Note Added: 0010200
2019-01-18 15:27 sbrun Note Added: 0010227
2019-01-25 15:00 sbrun Note Added: 0010239
2019-02-06 09:45 rhertzog Note Added: 0010263
2019-02-06 17:27 busterb Note Added: 0010266
2019-02-07 09:54 rhertzog Note Added: 0010267
2019-02-19 00:12 pranavperfect Note Added: 0010318
2019-02-19 09:06 sbrun Status assigned => resolved
2019-02-19 09:06 sbrun Resolution open => fixed
2019-02-19 09:06 sbrun Note Added: 0010321