View Issue Details

IDProjectCategoryView StatusLast Update
0000446Kali Linux[All Projects] Kali Package Bugpublic2014-01-09 16:17
ReporterTirn Assigned Torhertzog  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version1.0.6 
Summary0000446: ALX Drivers for Atheros 8161/8162/etc.
DescriptionIf possible, please be so kind and add the alx driver to the next package.
A Kali Linux install does not recognize/makes Eth0 available.
It has to be installed later, through Backports/compat-drivers.

The "additional information" field contains the lspci -v output.

This "bug" has already been fixed in Feb. 2013 Wheezy Linux 3.2.39-1.

Thanks in advance!
Additional Information03:00.0 Ethernet controller: Atheros Communications Inc. AR8162 Fast Ethernet (rev 10)
    Subsystem: ASUSTeK Computer Inc. Device 200f
    Flags: bus master, fast devsel, latency 0, IRQ 10
    Memory at f7c00000 (64-bit, non-prefetchable) [size=256K]
    I/O ports at e000 [size=128]
    Capabilities: [40] Power Management version 3
    Capabilities: [58] Express Endpoint, MSI 00
    Capabilities: [c0] MSI: Enable- Count=1/16 Maskable+ 64bit+
    Capabilities: [d8] MSI-X: Enable- Count=16 Masked-
    Capabilities: [100] Advanced Error Reporting
    Capabilities: [180] Device Serial Number (removed)

Relationships

has duplicate 0000563 resolvedrhertzog atheros ar8162 lan card not working 

Activities

S4b3r

2013-12-10 02:01

reporter   ~0001186

I'm having the same issue with my Asus X201E (same output). Not really an issue, but useful if it could be corrected.
I do not always have a wifi connection available, but LAN only. This makes a fresh install difficult.

This is not an issue with other distros, maybe due to a more recent Kernel version (Debian, Ubuntu, Backbox, etc.).

rhertzog

2014-01-09 16:17

administrator   ~0001313

Kali 1.0.6 uses linux 3.12 and this kernel version has the required driver (drivers/net/ethernet/atheros/alx/*). I'm thus assuming that this bug is fixed.

The default kernel configuration has the driver built as a module:
debian/config/config:CONFIG_ALX=m

Issue History

Date Modified Username Field Change
2013-07-19 01:41 Tirn New Issue
2013-12-10 02:01 S4b3r Note Added: 0001186
2014-01-09 16:12 rhertzog Relationship added has duplicate 0000563
2014-01-09 16:17 rhertzog Note Added: 0001313
2014-01-09 16:17 rhertzog Status new => resolved
2014-01-09 16:17 rhertzog Fixed in Version => 1.0.6
2014-01-09 16:17 rhertzog Resolution open => fixed
2014-01-09 16:17 rhertzog Assigned To => rhertzog