View Issue Details

IDProjectCategoryView StatusLast Update
0004473Kali Linux[All Projects] Kali Package Improvementpublic2018-01-13 08:53
Reporterguigui201Assigned Torhertzog 
PriorityhighSeverityblockReproducibilityalways
Status closedResolutionduplicate 
Product Version2017.3 
Target VersionFixed in Version 
Summary0004473: Virtualbox
DescriptionVirtualBox doesn't work anymore on Kali because of depencies since the last upgrade of the system.
Additional Informationthe problem seems to be the kernel. I let you my log when i'm starting the program.

Relationships

duplicate of 0004464 resolvedrhertzog update to linux-image-4.14.0-kali3 breaks dkms-bbswitch and nvidia-legacy-340xx 
has duplicate 0004474 closedrhertzog virtualbox's vm doesn't run anymore after update 

Activities

guigui201

2018-01-12 17:56

reporter  

Report.txt (234 bytes)
WARNING: The character device /dev/vboxdrv does not exist.
	 Please install the virtualbox-dkms package and the appropriate
	 headers, most likely linux-headers-amd64.

	 You will not be able to start VMs until this problem is fixed.
Report.txt (234 bytes)

kalibugs

2018-01-12 18:16

reporter   ~0007801

I confirm virtulbox doesn't run anymore

kalibugs

2018-01-12 18:18

reporter   ~0007802

I checked your Report.txt and probably to fix the problem you should:

apt-get install linux-headers-amd64 virtualbox-dkms

guigui201

2018-01-12 18:48

reporter   ~0007803

I have already done it but the system says me that i have the last version of those programs

rhertzog

2018-01-12 19:36

administrator   ~0007804

I believe you are all affected by 0004464, the build of the virtualbox kernel module might have failed due to a missing dependency. Can you confirm that the following commands are fixing your problem?

# apt install libelf-dev
# apt install --reinstall virtualbox-dkms

Or simply dist-upgrading when the updated kernel packages get available (likely over the night)...

kalibugs

2018-01-12 19:36

reporter   ~0007805

VirtualBox's vm doesn't run anymore after yesterday update (5.2.4-dfsg-2).
I got following errors with any VMs I try to start:


VBoxManage: error: The VM session was aborted
VBoxManage: error: Details: code NS_ERROR_FAILURE (0x80004005), component SessionMachine, interface ISession

guigui201

2018-01-12 19:54

reporter   ~0007806

Ok, the problem have been solved thanks to the solution of rhertzog.
That's really nice!
Thank you very much for your help!

rhertzog

2018-01-13 08:53

administrator   ~0007807

So closing the ticket as a duplicate of 4464.

Issue History

Date Modified Username Field Change
2018-01-12 17:56 guigui201 New Issue
2018-01-12 17:56 guigui201 File Added: Report.txt
2018-01-12 18:16 kalibugs Note Added: 0007801
2018-01-12 18:18 kalibugs Note Added: 0007802
2018-01-12 18:48 guigui201 Note Added: 0007803
2018-01-12 19:33 rhertzog Relationship added has duplicate 0004474
2018-01-12 19:36 rhertzog Note Added: 0007804
2018-01-12 19:36 kalibugs Note Added: 0007805
2018-01-12 19:54 guigui201 Note Added: 0007806
2018-01-13 08:53 rhertzog Assigned To => rhertzog
2018-01-13 08:53 rhertzog Status new => closed
2018-01-13 08:53 rhertzog Resolution open => duplicate
2018-01-13 08:53 rhertzog Note Added: 0007807
2018-01-13 08:53 rhertzog Relationship added duplicate of 0004464