2018-10-20 10:30 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004488Kali Linux[All Projects] General Bugpublic2018-01-29 11:18
Reporter1fpppostiinfo 
Assigned Torhertzog 
PriorityhighSeverityblockReproducibilityalways
StatusresolvedResolutionfixed 
Product Version2017.3 
Target VersionFixed in Version2018.1 
Summary0004488: Gnome Shell crash when you plug an USB device
Descriptionso whenever i try to plug my tablet to my kali machine via USB the machine crashes and the screen goes suddenly black and it takes me to the login screen all over again.
Steps To Reproducejust plug any device via USB port
Attached Files

-Relationships
has duplicate 0004492closedrhertzog 2018.1 Gnome interface 
has duplicate 0004493closedrhertzog Gnome Desktop Blank/Crashed when mount or umount disk 
has duplicate 0004497closed The user session is closed when iphone connected through USB 
+Relationships

-Notes

~0007839

j_jito (reporter)

I confirm that.

I had the same issue when I plug-in my external hard drive.

Whether I plug-in or plug-out any usb device, the X sessions is restarted.

~0007840

johnny_moss (reporter)

When I attached a 32GB USB thumb drive I got the black screen for a moment, then normal service was resumed.
When I attached a 64GB drive, I got the black screen and was then directed to the login screen.
I'm unable to ascertain whether the storage capacity of the device is a factor, or if it's affecting USB type 2, or type 3 ports (or both).
It only started happening within the last 48hrs.

~0007842

your.prabhjeetsingh (reporter)

Yes this bug exist.

When I plug my pendrive to my laptop it blacks out and put me to login screen.
I think problem is due to the extensions(Tweak tool).

Just turn extensions off and everything is working fine.

~0007843

rhertzog (administrator)

It would be nice if you could follow the best practices for bugs... that is provide some useful log. Please have a look at the output of "journalctl" and paste here the messages that appear right after you plugged your USB device. TIA.

If disabling all extensions works, can you try to pin-point which extension is causing the problem exactly? Enable only one extension, try to plug your USB device. If it doesn't crash, try enabling a second extension, try to plug your USB device, etc. until you get back the crash at which point we know which extension is causing the problem (you can possibly guess it from the logs and directly try with the extension that you expect to cause the problem).

~0007846

creadpag (reporter)

The problem is in the extension dash to dock

~0007847

1fpppostiinfo (reporter)

No; disabling dash to dock extension didn't solve the problem, I tried with all the extensions that I got on my machine, I disabled them for a while then I connected my device via all the USB ports and the same thing every time, I don't think it's due to some extension

~0007848

creadpag (reporter)

clear this!

~0007849

creadpag (reporter)

disable the "places status indicator" extension

~0007850

1fpppostiinfo (reporter)

here are my extensions I disabled them all !

~0007851

1fpppostiinfo (reporter)

I correct; actually I just disabled them all entirely and I couldn't reproduce the bug so we can be sure that the bug is due to some extension

~0007859

sbrun (manager)

I reproduce this bug.
I confirm : disable the extension "places status indicator" solves the issue.

~0007860

sbrun (manager)

the issue is caused by the latest version of libgjs0g 1.50.2-3.
Downgrading to version 1.50.2-2 fixes this.

~0007861

rhertzog (administrator)

I tried 1.50.3-1 from Debian unstable and it also crashes.

I filed a bug on gjs upstream: https://gitlab.gnome.org/GNOME/gjs/issues/33

~0007970

sbrun (manager)

fixed in gnome-shell-extensions version 3.26.2-2kali2
+Notes

-Issue History
Date Modified Username Field Change
2018-01-20 14:29 1fpppostiinfo New Issue
2018-01-21 16:41 j_jito Note Added: 0007839
2018-01-21 20:20 johnny_moss Note Added: 0007840
2018-01-21 20:29 your.prabhjeetsingh Note Added: 0007842
2018-01-22 13:40 rhertzog Assigned To => rhertzog
2018-01-22 13:40 rhertzog Status new => assigned
2018-01-22 13:46 rhertzog Status assigned => feedback
2018-01-22 13:46 rhertzog Note Added: 0007843
2018-01-22 19:21 creadpag Note Added: 0007846
2018-01-22 19:35 1fpppostiinfo Note Added: 0007847
2018-01-22 19:35 1fpppostiinfo Status feedback => assigned
2018-01-22 20:01 creadpag File Added: Screenshot from 2018-01-22 16-57-50.png
2018-01-22 20:01 creadpag Note Added: 0007848
2018-01-22 20:06 creadpag Note Added: 0007849
2018-01-22 20:18 1fpppostiinfo File Added: Screenshot from 2018-01-22 20-16-08.png
2018-01-22 20:18 1fpppostiinfo Note Added: 0007850
2018-01-22 20:20 1fpppostiinfo File Added: Screenshot from 2018-01-22 20-16-14.png
2018-01-22 20:30 1fpppostiinfo Note Added: 0007851
2018-01-23 10:16 rhertzog Relationship added has duplicate 0004492
2018-01-23 15:21 rhertzog Relationship added has duplicate 0004493
2018-01-23 15:21 rhertzog Summary USB Crash => Gnome Shell crash when you plug an USB device
2018-01-23 15:21 rhertzog Description Updated View Revisions
2018-01-23 16:10 sbrun Note Added: 0007859
2018-01-23 16:12 sbrun Note Added: 0007860
2018-01-23 17:51 rhertzog Note Added: 0007861
2018-01-25 08:47 sbrun Relationship added has duplicate 0004497
2018-01-29 11:18 sbrun Status assigned => resolved
2018-01-29 11:18 sbrun Resolution open => fixed
2018-01-29 11:18 sbrun Fixed in Version => 2018.1
2018-01-29 11:18 sbrun Note Added: 0007970
+Issue History