View Issue Details

IDProjectCategoryView StatusLast Update
0004518Kali Linux[All Projects] General Bugpublic2018-02-05 09:46
Reporterjapan_user Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0004518: can not do apt-get update
DescriptionGet:1 http://ftp.ne.jp/Linux/packages/kali/kali kali-rolling InRelease [30.5 kB]
Err:1 http://ftp.ne.jp/Linux/packages/kali/kali kali-rolling InRelease
  The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <devel@kali.org>

apt key expired.

Relationships

duplicate of 0004514 resolvedrhertzog apt-get update invalid signatures 

Activities

g0tmi1k

2018-02-05 09:46

administrator   ~0008616

Duplicate 0004514 (https://bugs.kali.org/view.php?id=4514)


Solution:

```
You have an old version of the kali-archive-keyring package (2015.2) which contains our old archive key which expired today. We pushed (a bit late) an updated key one week ago in the version 2018.1 of the kali-archive-keyring package. You can manually install this package:

# wget https://http.kali.org/kali/pool/main/k/kali-archive-keyring/kali-archive-keyring_2018.1_all.deb
# dpkg -i kali-archive-keyring_2018.1_all.deb

And then it should be back to normal. An alternative solution is to fetch the updated key directly and make it available to APT:

# wget https://archive.kali.org/archive-key.asc -O /etc/apt/trusted.gpg.d/kali-archive-key.asc

(you can delete /etc/apt/trusted.gpg.d/kali-archive-key.asc after having completed an upgrade that installed the new kali-archive-keyring)

Sorry for the inconvenience, now you can go back to enjoy your Kali system! ;-)
```

g0tmi1k

2018-02-05 09:46

administrator   ~0008617

Also see: https://twitter.com/kalilinux/status/959515084157538304

Issue History

Date Modified Username Field Change
2018-02-05 08:09 japan_user New Issue
2018-02-05 09:46 g0tmi1k Status new => closed
2018-02-05 09:46 g0tmi1k Resolution open => duplicate
2018-02-05 09:46 g0tmi1k Note Added: 0008616
2018-02-05 09:46 g0tmi1k Relationship added duplicate of 0004514
2018-02-05 09:46 g0tmi1k Note Added: 0008617