2018-09-23 14:13 UTC

View Issue Details Jump to Notes ]
IDProjectCategoryView StatusLast Update
0004523Kali Linux[All Projects] General Bugpublic2018-06-28 07:42
Reportervincyrei 
Assigned Tosbrun 
PrioritynormalSeverityminorReproducibilityhave not tried
StatusresolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2018.3 
Summary0004523: realtek-rtl88xx-dkms to ODROID XU4 - Bad return status for module build on kernel: 3.10.106 (armv7l)
DescriptionBad return status for module build on kernel: 3.10.106 (armv7l)
Attached Files

-Relationships
+Relationships

-Notes

~0008629

vincyrei (reporter)

root@kali:~# cat /var/lib/dkms/realtek-rtl88xxau/5.1.5~20180125/build/make.log
DKMS make.log for realtek-rtl88xxau-5.1.5~20180125 for kernel 3.10.106 (armv7l)
Wed Feb 7 14:58:29 UTC 2018
make -j 8 ARCH=armv7l CROSS_COMPILE= -C /lib/modules/3.10.106/build M=/var/lib/dkms/realtek-rtl88xxau/5.1.5~20180125/build modules
make[1]: Entering directory '/usr/src/kernel'
Makefile:582: /usr/src/kernel/arch/armv7l/Makefile: No such file or directory
make[1]: *** No rule to make target '/usr/src/kernel/arch/armv7l/Makefile'. Stop.
make[1]: Leaving directory '/usr/src/kernel'
Makefile:1871: recipe for target 'modules' failed
make: *** [modules] Error 2

~0008635

sbrun (manager)

Thank you for your interest in Kali but we only support the current version of Kali-rolling.
Your kernel version is too old. We have 4.14.13 in kali-rolling.

~0008637

vincyrei (reporter)


the kernel is the latest version 2018.1 for ODROID XU3 / 4 released by you on the downloads page of the ARM images. I think it is a good idea to make your system up and running. thank you very much for your support which I believe is essential. I need to use the wifi 8812au on odroid xu4 and I did not want to change the operating system but operate on kali OS.

~0008651

kimocoder (reporter)

Open a issue report @ https://github.com/aircrack-ng/rtl8812au

I actually think I got a solution for it, but open a issue report we could work it out right away. Thanks.

~0009310

sbrun (manager)

is this fixed with realtek-rtl88xxau-dkms version 5.1.5~20180513-0kali1 ?

~0009311

kimocoder (reporter)

Yes it should fixed (but not tested though)

The commit is here
https://github.com/aircrack-ng/rtl8812au/commit/d628a7441c6066a2e302104b7f4f99bcd81a111f

We've started on the v5.2.20 driver now, but pulling the 20180513 won't be a bad idea, as it fixes:

* Odroid C2 fix
* Some freezes and delays
* Some kernel support
* 1 more VID/PID added

~0009321

sbrun (manager)

version 5.1.5~20180513-0kali1 is in kali-rolling since May 14.
Please reopen the bug if you still have the issue.
+Notes

-Issue History
Date Modified Username Field Change
2018-02-07 14:19 vincyrei New Issue
2018-02-07 14:19 vincyrei Status new => assigned
2018-02-07 14:19 vincyrei Assigned To => sbrun
2018-02-07 15:00 vincyrei Note Added: 0008629
2018-02-08 08:42 sbrun Status assigned => closed
2018-02-08 08:42 sbrun Resolution open => won't fix
2018-02-08 08:42 sbrun Note Added: 0008635
2018-02-08 09:26 vincyrei Status closed => feedback
2018-02-08 09:26 vincyrei Resolution won't fix => reopened
2018-02-08 09:26 vincyrei Note Added: 0008637
2018-02-11 19:00 kimocoder Note Added: 0008651
2018-02-21 09:59 g0tmi1k Product Version 2018.1 =>
2018-05-08 08:53 g0tmi1k Priority high => normal
2018-05-08 08:53 g0tmi1k Severity major => minor
2018-05-08 08:53 g0tmi1k Category Tool Upgrade => General Bug
2018-05-08 08:53 g0tmi1k Summary realtek-rtl88xx-dkms to ODROID XU4 => realtek-rtl88xx-dkms to ODROID XU4 - Bad return status for module build on kernel: 3.10.106 (armv7l)
2018-06-25 09:40 sbrun Note Added: 0009310
2018-06-25 10:45 kimocoder Note Added: 0009311
2018-06-28 07:42 sbrun Status feedback => resolved
2018-06-28 07:42 sbrun Resolution reopened => fixed
2018-06-28 07:42 sbrun Fixed in Version => 2018.3
2018-06-28 07:42 sbrun Note Added: 0009321
+Issue History