View Issue Details

IDProjectCategoryView StatusLast Update
0004526Kali Linux[All Projects] General Bugpublic2018-02-07 16:50
Reportersttratg Assigned To 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionduplicate 
Product Version2017.3 
Target VersionFixed in Version 
Summary0004526: apt-get problem
DescriptionI have some problem with my repository and even when i updated it still doesnt work. It happen when i use apt-get update command:

Get:1 http://kali.koyanet.lv/kali kali-rolling InRelease [30.5 kB]
Err:1 http://kali.koyanet.lv/kali kali-rolling InRelease
The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <devel@kali.org>
Reading package lists... Done
W: GPG error: http://kali.koyanet.lv/kali kali-rolling InRelease: The following signatures were invalid: EXPKEYSIG ED444FF07D8D0BF6 Kali Linux Repository <devel@kali.org>
E: The repository 'http://http.kali.org/kali kali-rolling InRelease' is not signed.
N: Updating from such a repository can't be done securely, and is therefore disabled by default.
N: See apt-secure(8) manpage for repository creation and user configuration details.

And when i am trying to install wine32

apt-get install wine32
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package wine32 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source

E: Package 'wine32' has no installation candidate


After this i did research and i found that i have to add some links to /etc/apt/sources.list and i did it but still nothing happens PLEASE help i am beginner in Kali so be understanding. And probably someone was asking about that before but no one has the same problem. I tried to reinstall my Kali and still didn't find any solution. I am writing this bug report like 4 days because i want to be sure that i did everything what i could. :C

Relationships

duplicate of 0004514 resolvedrhertzog apt-get update invalid signatures 

Activities

g0tmi1k

2018-02-07 16:50

administrator   ~0008630

Duplicate 0004514 (https://bugs.kali.org/view.php?id=4514)

Solution:

```
You have an old version of the kali-archive-keyring package (2015.2) which contains our old archive key which expired today. We pushed (a bit late) an updated key one week ago in the version 2018.1 of the kali-archive-keyring package. You can manually install this package:

# wget https://http.kali.org/kali/pool/main/k/kali-archive-keyring/kali-archive-keyring_2018.1_all.deb
# dpkg -i kali-archive-keyring_2018.1_all.deb

And then it should be back to normal. An alternative solution is to fetch the updated key directly and make it available to APT:

# wget https://archive.kali.org/archive-key.asc -O /etc/apt/trusted.gpg.d/kali-archive-key.asc

(you can delete /etc/apt/trusted.gpg.d/kali-archive-key.asc after having completed an upgrade that installed the new kali-archive-keyring)

Sorry for the inconvenience, now you can go back to enjoy your Kali system! ;-)
```

Also see: https://twitter.com/kalilinux/status/959515084157538304

Issue History

Date Modified Username Field Change
2018-02-07 16:48 sttratg New Issue
2018-02-07 16:50 g0tmi1k Status new => closed
2018-02-07 16:50 g0tmi1k Resolution open => duplicate
2018-02-07 16:50 g0tmi1k Note Added: 0008630
2018-02-07 16:50 g0tmi1k Relationship added duplicate of 0004514