View Issue Details

IDProjectCategoryView StatusLast Update
0004546Kali Linux[All Projects] Kali Package Bugpublic2018-09-12 07:47
Reporterrm1984Assigned Torhertzog 
PrioritynormalSeverityminorReproducibilityalways
Status closedResolutionwon't fix 
Product Version2018.1 
Target VersionFixed in Version 
Summary0004546: FreeMind can't be started
DescriptionFreeMind 0.9.0+dfsg2-1 can't be started. When I run it from command line, this is what I get:

Checking Java Version...
java.io.FileNotFoundException: /home/rm1984/.freemind/auto.properties (No such file or directory)
    at java.base/java.io.FileInputStream.open0(Native Method)
    at java.base/java.io.FileInputStream.open(FileInputStream.java:196)
    at java.base/java.io.FileInputStream.<init>(FileInputStream.java:139)
    at freemind.main.FreeMindStarter.readUsersPreferences(FreeMindStarter.java:136)
    at freemind.main.FreeMindStarter.main(FreeMindStarter.java:56)
Panic! Error while loading default properties.
Gtk-Message: Failed to load module "unity-gtk-module"

STDERR: java.lang.reflect.InvocationTargetException
STDERR: at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
STDERR: at java.base/jdk.internal.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
STDERR: at java.base/jdk.internal.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
STDERR: at java.base/java.lang.reflect.Method.invoke(Method.java:564)
STDERR: at freemind.main.FreeMindStarter.main(FreeMindStarter.java:63)
STDERR: Caused by: java.lang.NoClassDefFoundError: com/lightdev/app/shtm/TextResources
STDERR: at java.base/java.lang.Class.forName0(Native Method)
STDERR: at java.base/java.lang.Class.forName(Class.java:375)
STDERR: at freemind.modes.mindmapmode.hooks.MindMapHookFactory.getRegistrations(MindMapHookFactory.java:334)
STDERR: at freemind.modes.mindmapmode.MindMapController.startupController(MindMapController.java:625)
STDERR: at freemind.controller.Controller.afterMapModuleChange(Controller.java:547)
STDERR: at freemind.controller.MapModuleManager$MapModuleChangeObserverCompound.afterMapModuleChange(MapModuleManager.java:101)
STDERR: at freemind.controller.MapModuleManager.setMapModule(MapModuleManager.java:323)
STDERR: at freemind.controller.MapModuleManager.newMapModule(MapModuleManager.java:191)
STDERR: at freemind.modes.ControllerAdapter.newMap(ControllerAdapter.java:335)
STDERR: at freemind.modes.ControllerAdapter.newMap(ControllerAdapter.java:330)
STDERR: at freemind.main.FreeMind.loadMaps(FreeMind.java:1029)
STDERR: at freemind.main.FreeMind.main(FreeMind.java:744)
STDERR: ... 5 more
STDERR: Caused by: java.lang.ClassNotFoundException: com.lightdev.app.shtm.TextResources
STDERR: at java.base/jdk.internal.loader.BuiltinClassLoader.loadClass(BuiltinClassLoader.java:582)
STDERR: at java.base/jdk.internal.loader.ClassLoaders$AppClassLoader.loadClass(ClassLoaders.java:185)
STDERR: at java.base/java.lang.ClassLoader.loadClass(ClassLoader.java:496)
STDERR: ... 17 more
Steps To ReproduceRun "freemind" from command line.

Activities

g0tmi1k

g0tmi1k

2018-09-12 07:24

administrator   ~0009689

This has been pulled from Debian (back in 2015) ~ https://pkg.kali.org/pkg/freemind
rhertzog

rhertzog

2018-09-12 07:47

administrator   ~0009699

This package is no longer part of Kali, we're not supporting it.

Issue History

Date Modified Username Field Change
2018-02-19 13:32 rm1984 New Issue
2018-05-08 07:41 g0tmi1k Category General Bug => Kali Package Bug
2018-09-12 07:24 g0tmi1k Note Added: 0009689
2018-09-12 07:47 rhertzog Assigned To => rhertzog
2018-09-12 07:47 rhertzog Status new => closed
2018-09-12 07:47 rhertzog Resolution open => won't fix
2018-09-12 07:47 rhertzog Note Added: 0009699