View Issue Details

IDProjectCategoryView StatusLast Update
0004657Kali Linux[All Projects] General Bugpublic2018-09-21 08:16
ReporterbroomdodgerAssigned Torhertzog 
PrioritynormalSeverityminorReproducibilityalways
Status resolvedResolutionfixed 
Product Versionkali-dev 
Target VersionFixed in Version2018.4 
Summary0004657: eject drives "Writing data to device" dialog never closes
Descriptioneject drives "Writing data to device" dialog never closes

Toshiba L675 - cpu i5 - ram 4 GB
also other machines with kali linux light amd64 (fully upgraded

SanDisk cruzer mini USB flash drives (all 3)
eject drives "Writing data to device" dialog never closes
then about 30 minutes later another dialog:
  Failed to eject "DATA-DISK".
  Timeout was reached.

most other brand USB flash drives eject correctly

Formatted with either:
gnome-disk-utility
gparted

I expect all drives to mount and eject correctly.

Steps To Reproduceinsert drive
add or remove files
eject drive
dialog appears

Activities

broomdodger

2018-03-28 19:08

reporter  

broomdodger

2018-03-29 05:42

reporter   ~0008968

Another machine that had not been upgraded since 20180116 did not have the problem with the SanDisk cruzer mini USB flash drives.

I upgraded it, now has the same problem:
eject drives "Writing data to device" dialog never closes

time-out.jpg (7,634 bytes)
time-out.jpg (7,634 bytes)

rhertzog

2018-03-29 06:28

administrator   ~0008969

Is this problem specific to the "light" image or can you reproduce with another image too?

I expect it to not be specific to the light images, and to be a kernel problem. We will soon switch to kernel 4.15, you might want to try out this one (it's already available in kali-experimental if you want to try it out right now).

broomdodger

2018-03-29 15:57

reporter   ~0008971

Yes I will try other than light.

Is 'kali-experimental' the daily?
If not where?

Also the problem just occurred with a USB hard drive.

broomdodger

2018-03-29 16:08

reporter   ~0008972

I tried the daily
kali-linux-light-rolling-amd64.iso 29-Mar-2018 02:15 943390720
It has kernel 4.14

Where is 'kali-experimental' ?

rhertzog

2018-03-29 20:23

administrator   ~0008973

kali-experimental is a repository that you add to /etc/apt/sources.list

You duplicate the line with "kali-rolling" and replace "kali-rolling" with "kali-experimental".

But the package of this repository will not be installed automatically, you will have to add "-t kali-experimental" to your apt command:

apt -t kali-experimental full-upgrade

broomdodger

2018-03-30 04:50

reporter   ~0008974

I made the change to /etc/apt/sources.list adding the line:
deb http://http.kali.org/kali/ kali-experimental main non-free contrib

reboot

root@kali:~# apt -t kali-experimental full-upgrade
Reading package lists... Done
E: The value 'kali-experimental' is invalid for APT::Default-Release as such a release is not available in the sources

broomdodger

2018-03-30 05:13

reporter   ~0008975

I needed to do:

apt update

BEFORE

apt -t kali-experimental full-upgrade

now the kernel is 4.15.11

The problem ejecting the drives still exists!

Tomorrow I will test other images.

rhertzog

2018-03-30 07:27

administrator   ~0008976

I'm afraid that we will not be able to help you further with this hardware support issue.

However this looks like a recent regression since you said that on January 16th, it was working. At that date, we have linux 4.14.12 (see https://pkg.kali.org/pkg/linux). And you also said that 4.14.17 was not working for you.

It would be really helpful if you could "git bisect" the kernel to find out the problematic commit. As a first step, you could try to build 4.14.14 or 4.14.15 and see if the problem is present.

rhertzog

2018-03-30 07:29

administrator   ~0008977

https://kali.training/topic/recompiling-the-linux-kernel/ if you need help to rebuild the kernel you download from kernel.org (or from git).

broomdodger

2018-03-31 00:31

reporter   ~0008979

The 'kali-linux-light-2018-W12-amd64.iso' (most recent weekly) image does NOT have the 'Writing data to device" stuck dialog problem.

It has kernel 4.14.17. The after 'apt update && apt upgrade' it has the eject problem and still has kernel 4.14.17.
So... it is NOT a kernel problem.

I looked at the upgrade list, sorted for the most likely problem files, then upgraded the least likely first.

And yes, my guess was correct, it is 'gvfs', which I upgraded last. 'gvfs' had the most extreme revision number.

install a fresh kali-linux-light-2018-W12-amd64.iso
upgrade gvfs, gvfs-common, gvfs-daemons, gvfs-libs
reboot
eject certain usb flash or usb hard drives and...
BAM! 'Writing data to device" stuck dialog problem

These were my suspect files:

# 04 upgrade 'Writing data to device" stuck dialog problem
01 gvfs/kali-rolling 1.36.0-1 amd64 [upgradable from: 1.34.1-2]
01 gvfs-common/kali-rolling 1.36.0-1 all [upgradable from: 1.34.1-2]
01 gvfs-daemons/kali-rolling 1.36.0-1 amd64 [upgradable from: 1.34.1-2]
01 gvfs-libs/kali-rolling 1.36.0-1 amd64 [upgradable from: 1.34.1-2]

# 01 upgrade no problem
02 mount/kali-rolling 2.31.1-0.5 amd64 [upgradable from: 2.31.1-0.4]
02 libmount1/kali-rolling 2.31.1-0.5 amd64 [upgradable from: 2.31.1-0.4]

# 02 upgrade no problem
04 libblkid1/kali-rolling 2.31.1-0.5 amd64 [upgradable from: 2.31.1-0.4]

# 03 upgrade no problem
05 udev/kali-rolling 238-3 amd64 [upgradable from: 238-2]
05 libudev1/kali-rolling 238-3 amd64 [upgradable from: 238-2]

broomdodger

2018-05-16 16:04

reporter   ~0009158

On another laptop
+ install Kali 2018 w12
+ install synaptic
+ update and upgrade but HOLD BACK ALL gvfs to 1.34.1-2

All usb storage devices work without the eject problem

Kali 2018 w19 has gvfs 1.36.1-1 has problem ejecting many storage devices

broomdodger

2018-06-12 01:33

reporter   ~0009234

Please update gvfs to at least gvfs 1.36.2-2

I install Manjaro 17.1.10 mini on another laptop, Lenovo IdeaPad U400.
It initially installed:

kernel 4.14.39-1
gvfs 1.36.1-1

Before the update, as mentioned previously,
many flash and hard drives had the persistent eject warning.
To work around the problem,
I have been selecting 'unmount' rather than 'eject'.
But now there seems to be a fix.

I ran the recommended Manjaro upgrade:

kernel 4.14.48-2
gvfs 1.36.2-2

After the update,
ALL flash and hard drives ejected without problem.

broomdodger

2018-09-20 13:03

reporter   ~0009753

Package: gvfs
Version: 1.38.0-2
This update fixes the problem:
eject drives "Writing data to device" dialog never closes

Please mark as resolved.

rhertzog

2018-09-21 08:16

administrator   ~0009756

Thanks for the notice, closing.

Issue History

Date Modified Username Field Change
2018-03-28 19:08 broomdodger New Issue
2018-03-28 19:08 broomdodger File Added: writing-data-to-device.jpg
2018-03-29 05:42 broomdodger File Added: time-out.jpg
2018-03-29 05:42 broomdodger Note Added: 0008968
2018-03-29 06:28 rhertzog Note Added: 0008969
2018-03-29 15:57 broomdodger Note Added: 0008971
2018-03-29 16:08 broomdodger Note Added: 0008972
2018-03-29 20:23 rhertzog Note Added: 0008973
2018-03-30 04:50 broomdodger Note Added: 0008974
2018-03-30 05:13 broomdodger Note Added: 0008975
2018-03-30 07:27 rhertzog Note Added: 0008976
2018-03-30 07:29 rhertzog Note Added: 0008977
2018-03-31 00:31 broomdodger Note Added: 0008979
2018-05-16 16:04 broomdodger Note Added: 0009158
2018-06-12 01:33 broomdodger Note Added: 0009234
2018-06-13 13:52 elwood Status new => acknowledged
2018-09-20 13:03 broomdodger Note Added: 0009753
2018-09-21 08:16 rhertzog Assigned To => rhertzog
2018-09-21 08:16 rhertzog Status acknowledged => resolved
2018-09-21 08:16 rhertzog Resolution open => fixed
2018-09-21 08:16 rhertzog Fixed in Version => 2018.4
2018-09-21 08:16 rhertzog Note Added: 0009756