View Issue Details

IDProjectCategoryView StatusLast Update
0004660Kali Linux[All Projects] New Tool Requestspublic2018-04-02 08:18
Reporterbobert Assigned To 
PrioritynormalSeverityminorReproducibilityN/A
Status closedResolutionduplicate 
Product Version 
Target VersionFixed in Version 
Summary0004660: S3Scanner - Scan for open AWS S3 buckets and dump
Descriptions3scanner is a tool I wrote to scan for open s3 buckets. If a bucket is found, the tools can:
-Dump the contents of the bucket
-List the files in the bucket
-Get bucket size
-Get the ACL's currently applied to the bucket

In the last few versions I focused heavily on adding tests for all features and making sure to have good code coverage. I feel that the tool is now ready for use.

Repo: https://github.com/sa7mon/S3Scanner
Compatibility: Python 2.7 & 3.6
Author: https://github.com/sa7mon
Current Version: 1.0.0 (semver)

If this tool doesn't seem ready to integrate into Kali, please let me know how I can improve it to fit the needs of Kali users. I'd really love to get this project into the Kali list of packages.

Relationships

duplicate of 0004611 acknowledged S3Scanner - Scan for open S3 buckets and dump 

Activities

g0tmi1k

2018-04-02 08:18

administrator   ~0008980

Duplicate of 0004611 (https://bugs.kali.org/view.php?id=4611)
Closing

Issue History

Date Modified Username Field Change
2018-03-31 20:36 bobert New Issue
2018-04-02 08:18 g0tmi1k Status new => closed
2018-04-02 08:18 g0tmi1k Resolution open => duplicate
2018-04-02 08:18 g0tmi1k Note Added: 0008980
2018-04-02 08:18 g0tmi1k Relationship added duplicate of 0004611