View Issue Details

IDProjectCategoryView StatusLast Update
0004868Kali Linux[All Projects] Tool Upgradepublic2018-09-06 08:07
Reporterfaraday-devAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version 
Target VersionFixed in Version2018.4 
Summary0004868: Update python-faraday v3.0
DescriptionWe are releasing the new version of Faraday v3.0.
Big improvements were made like removing couchdb as a dependency.

You can download latest version on https://github.com/infobyte/faraday
The release link for v3.0 is https://github.com/infobyte/faraday/releases/tag/v3.0

Kali required packages are:

apt-get install -y build-essential ipython python-setuptools python-pip python-dev \
                libssl-dev libffi-dev pkg-config libssl-dev libffi-dev libxml2-dev \
                libxslt1-dev libfreetype6-dev libpng-dev postgresql postgresql-client \
                libsasl2-dev libldap2-dev

apt-get install -y libpq-dev gir1.2-gtk-3.0 gir1.2-vte-2.91 python-gobject zsh curl

Activities

sbrun

2018-07-30 07:49

manager   ~0009405

I started working on the update. As we don't use pip, we will have to package many Python modules.

But I found two Python modules with really strong restrictions on required versions: flask and marshmallow. In Kali we already have too high versions for faraday.
I didn't find exactly why there are these restrictions, just found this commit:
https://github.com/infobyte/faraday/commit/8c3a0254cc236543cb2c93bc7cf317bd087f462f

faraday-dev

2018-07-30 15:32

reporter   ~0009407

Hi,

We will try to update faraday to use Flask 1.0. We are using Marshmallow 2.15.3 since version 3 is a beta version.

Let us know if you have problems with our filteralchemy version on git+https://github.com/infobyte/filteralchemy@dev#egg=filteralchemy, since the original library is not maintained anymore and we had to create a fork of it.

Should we check library versions on kali dev build?

Thanks a lot!

sbrun

2018-07-31 10:05

manager   ~0009411

As we don't use pip but packaged python modules in Kali (mostly imported from Debian Testing), we can't manage when there are restrictions on versions like "==" or "<" or "<=". The packaged python modules are common to all the applications using them in Kali/Debian.
But if a minimal version is required, usually we can update the package.

I haven't look at https://github.com/infobyte/filteralchemy yet. I'll let you know if I find a problem.

faraday-dev

2018-07-31 21:58

reporter   ~0009412

We will update all requirements to always use >=.
Currently we manage to update our server to Flask 1.0.
I will keep you updated when the fixes are published on github.
Let me know if you find any other issue.

Thanks!

faraday-dev

2018-08-27 21:05

reporter   ~0009531

Hi,

we release v3.0.1 and fixed the requirements*.txt issues.

https://github.com/infobyte/faraday/releases

sbrun

2018-08-30 12:51

manager   ~0009547

Thanks for the new release. I'm working on the package.
I will keep you posted when package is ready.

sbrun

2018-09-06 08:07

manager   ~0009588

version 3.0.1-0kali1 is now in kali-rolling

Issue History

Date Modified Username Field Change
2018-07-26 20:07 faraday-dev New Issue
2018-07-26 20:07 faraday-dev Status new => assigned
2018-07-26 20:07 faraday-dev Assigned To => sbrun
2018-07-30 07:49 sbrun Note Added: 0009405
2018-07-30 15:32 faraday-dev Note Added: 0009407
2018-07-31 10:05 sbrun Note Added: 0009411
2018-07-31 21:58 faraday-dev Note Added: 0009412
2018-08-23 12:07 g0tmi1k Summary Upgrade faraday to v3.0 => Update python-faraday v3.0
2018-08-27 21:05 faraday-dev Note Added: 0009531
2018-08-30 12:51 sbrun Note Added: 0009547
2018-09-06 08:07 sbrun Status assigned => resolved
2018-09-06 08:07 sbrun Resolution open => fixed
2018-09-06 08:07 sbrun Fixed in Version => 2018.4
2018-09-06 08:07 sbrun Note Added: 0009588