View Issue Details

IDProjectCategoryView StatusLast Update
0004903Kali Linux[All Projects] Kali Package Bugpublic2018-12-20 19:14
ReporteryesimxevAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status acknowledgedResolutionopen 
Product Version2018.2 
Target VersionFixed in Version 
Summary0004903: Dbus and bluetooth are not working on armhf, Nethunter Oneplus One
DescriptionI hope I am writing to the correct bug report site, I've tried forums, built kernels, roms, possibly everything I could find on the net and in my brain.

Device: OnePlus One
OS version: Marshmallow on CM13.1.2.
Built from repo (date and build command) or downloaded from website (links):

Kali nightly with same kernel (2017.11-18-1618)
Output of cat /proc/version in adb shell or NetHunter Terminal:

Linux version 3.4.112-cyanogenmod-g8fbc62e (root@nhbuild-box) (gcc version 4.7 (GCC) ) #3 SMP PREEMPT Fri Aug 12 19:57:27 CDT 2016

My new bt adapter has finally arrived, the Sena UD100-G03. Didn't work on CM13.0 Kali nightly 1 before latest build, so re-flashed latest Kali nightly (2017.11-18-1618), with same build latest kernel.
Updated with apt-get update, dist-upgrade but still not getting it. Has the bluetooth package, bluez, blueman. With dbus running, bluetooth service/bluetoothd does not want to start. Couldn't find any solution for weeks now, hope there is a chance to get it working.
Everything else is working like HID, wlan injection, etc.

root@kali:~# service bluetooth start
[ ok ] Starting bluetooth: bluetoothd.
root@kali:~# service bluetooth status
[FAIL] bluetooth is not running ... failed!
root@kali:~# bluetoothd -n
bluetoothd[30492]: Bluetooth daemon 5.49
bluetoothd[30492]: Failed to access management interface
bluetoothd[30492]: Adapter handling initialization failed

Also a strange thing that dbus struggles to start since the last few updates (not sure when). Takes about 3mins to start and seems like not doing it's job properly.
Managed to see a dbus-monitor to see what happens when starting bluetooth service:

root@kali:/# dbus-monitor --system
signal time=1532327145.748679 sender=org.freedesktop.DBus -> destination=:1.0 serial=2 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameAcquired
   string ":1.0"
signal time=1532327145.754697 sender=org.freedesktop.DBus -> destination=:1.0 serial=4 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameLost
   string ":1.0"
method call time=1532327345.837790 sender=:1.1 -> destination=org.freedesktop.DBus serial=1 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=Hello
method return time=1532327345.837857 sender=org.freedesktop.DBus -> destination=:1.1 serial=1 reply_serial=1
   string ":1.1"
signal time=1532327345.837901 sender=org.freedesktop.DBus -> destination=(null destination) serial=5 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string ":1.1"
   string ""
   string ":1.1"
signal time=1532327345.837962 sender=org.freedesktop.DBus -> destination=:1.1 serial=2 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameAcquired
   string ":1.1"
method call time=1532327345.838793 sender=:1.1 -> destination=org.freedesktop.DBus serial=2 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=RequestName
   string "org.bluez"
   uint32 4
signal time=1532327345.838852 sender=org.freedesktop.DBus -> destination=(null destination) serial=6 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string "org.bluez"
   string ""
   string ":1.1"
signal time=1532327345.838910 sender=org.freedesktop.DBus -> destination=:1.1 serial=3 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameAcquired
   string "org.bluez"
method return time=1532327345.838947 sender=org.freedesktop.DBus -> destination=:1.1 serial=4 reply_serial=2
   uint32 1
method call time=1532327345.839649 sender=:1.1 -> destination=org.freedesktop.DBus serial=3 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=AddMatch
   string "type='signal',interface='org.freedesktop.DBus.Local',member='Disconnected'"
method return time=1532327345.839698 sender=org.freedesktop.DBus -> destination=:1.1 serial=5 reply_serial=3
signal time=1532327345.841698 sender=org.freedesktop.DBus -> destination=:1.1 serial=7 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameLost
   string "org.bluez"
signal time=1532327345.841757 sender=org.freedesktop.DBus -> destination=(null destination) serial=8 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string "org.bluez"
   string ":1.1"
   string ""
signal time=1532327345.841820 sender=org.freedesktop.DBus -> destination=:1.1 serial=9 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameLost
   string ":1.1"
signal time=1532327345.841859 sender=org.freedesktop.DBus -> destination=(null destination) serial=10 path=/org/freedesktop/DBus; interface=org.freedesktop.DBus; member=NameOwnerChanged
   string ":1.1"
   string ":1.1"
   string ""

I tried many configs for to let everything through, but whenever I reload and start again, it is still slow, and bluetooth is not working. Seems like dbus refuses everything even when I am apt-get upgrading.
Also FYI, dbus can not start on boot - should it start on nethunter like on laptop?

Thanks for reading!



2018-09-21 23:34

reporter   ~0009761

Installing bluez-4.7 from makes the bluetooth service running. Please check the difference in the services as rfcomm does not work without bt service. Even 4.99 from does not work in terms of service. Dbus can be removed actually that works after creating a new kalifs. Thanks!


2018-12-20 19:14

reporter   ~0010125

It all works until bluez 4.101, but some features are not working, eg. audio though bluetooth, and bluesnarfer, and who knows what else.

**Kind of an RTFM for me, the bluez page clearly says what happened since bluez4**

So it turns out, that the

`Failed to access management interface`

comes from when I want to run btmgmt (which replaces the old org.bluez dbus way of working), which says

`Unable to open btmgmt_socket`

I can't see anything related to this in the kernel config, nor the kali side of packages

Issue History

Date Modified Username Field Change
2018-08-17 06:27 yesimxev New Issue
2018-08-18 04:38 elwood Status new => acknowledged
2018-09-21 23:34 yesimxev Note Added: 0009761
2018-12-20 19:14 yesimxev Note Added: 0010125