View Issue Details

IDProjectCategoryView StatusLast Update
0004988Kali Linux[All Projects] General Bugpublic2018-09-16 09:14
Reporteralfamyk Assigned Torhertzog  
PrioritynormalSeverityminorReproducibilityhave not tried
Status closedResolutionduplicate 
Product Version2018.3 
Target VersionFixed in Version 
Summary0004988: Desktop Items missings
DescriptionI recently upgraded kernel to 4.17.0-kali3-amd64 and Kali version 2018.3
It seems desktop items are missing/not showing up, whereas in the Desktop folder, there are multiple desktop entries, which were supposed to be displayed.

Relationships

duplicate of 0004983 resolvedsbrun Desktop Icons Missing After Latest Upgrade 

Activities

alfamyk

2018-09-15 06:02

reporter  

screen_desktop_issue.png (858,816 bytes)

alfamyk

2018-09-15 08:58

reporter   ~0009728

It seems the same thing happens with 4.17.0-kali1-amd64 also.

blackhat

2018-09-15 10:07

reporter   ~0009729

hi guys,
I have exactly the same problem and when install kali 2018.3 and upgrade.

when see the release no :

grep VERSION /etc/os-release

i see the :

VERSION="2018.4"
VERSION_ID="2018.4"

and can not solved by dconf & gconfig

Screenshot from 2018-09-15 14-33-23.png (1,535,909 bytes)

blackhat

2018-09-15 10:10

reporter  

Screenshot from 2018-09-15 14-33-23-min.png (619,720 bytes)

blackhat

2018-09-15 10:11

reporter   ~0009730

hi guys,
I have exactly the same problem and when install kali 2018.3 and upgrade.

when see the release no :

grep VERSION /etc/os-release

i see the :

VERSION="2018.4"
VERSION_ID="2018.4"

and can not solved by dconf & gconfig

Screenshot from 2018-09-15 14-33-23-min-2.png (619,720 bytes)

Ivanoff

2018-09-15 11:56

reporter   ~0009731

Hi and i have same bug
+ no "normal" desktop right click (with copy/past and etc)
+ no "desktop menu" in gnome tweaks

PS (if it depend):
   install new
 + update
 + full-upgrade
 + install open-vm-tools-desktop
 + small setup settings

Kali 2018.3-2018-09-15-14-47-43.png (699,162 bytes)

rhertzog

2018-09-16 09:14

administrator   ~0009735

Please don't report duplicate bugs, see 0004983

Anyway the summary is it's not a Kali issue. Unfortunately the feature has been removed from nautilus.

https://csorianognome.wordpress.com/2017/12/21/nautilus-desktop-plans/
https://gitlab.gnome.org/GNOME/nautilus/issues/158#alternative-solution

Gnome people are working on an extension to replace it but it looks like they have not made a release yet and it's not packaged in Debian/Kali
https://gitlab.gnome.org/World/ShellExtensions/desktop-icons

But you can install it manually, it's available here:
https://extensions.gnome.org/extension/1465/desktop-icons/

Issue History

Date Modified Username Field Change
2018-09-15 06:02 alfamyk New Issue
2018-09-15 06:02 alfamyk File Added: screen_desktop_issue.png
2018-09-15 08:58 alfamyk Note Added: 0009728
2018-09-15 10:07 blackhat File Added: Screenshot from 2018-09-15 14-33-23.png
2018-09-15 10:07 blackhat Note Added: 0009729
2018-09-15 10:10 blackhat File Added: Screenshot from 2018-09-15 14-33-23-min.png
2018-09-15 10:11 blackhat File Added: Screenshot from 2018-09-15 14-33-23-min-2.png
2018-09-15 10:11 blackhat Note Added: 0009730
2018-09-15 11:56 Ivanoff File Added: Kali 2018.3-2018-09-15-14-47-43.png
2018-09-15 11:56 Ivanoff Note Added: 0009731
2018-09-16 09:14 rhertzog Assigned To => rhertzog
2018-09-16 09:14 rhertzog Status new => closed
2018-09-16 09:14 rhertzog Resolution open => duplicate
2018-09-16 09:14 rhertzog Note Added: 0009735
2018-09-16 09:14 rhertzog Relationship added duplicate of 0004983