View Issue Details

IDProjectCategoryView StatusLast Update
0004983Kali Linux[All Projects] General Bugpublic2018-11-15 11:13
ReporterrojdojAssigned Tosbrun 
PrioritynormalSeverityminorReproducibilityhave not tried
Status resolvedResolutionfixed 
Product Version2018.3 
Target VersionFixed in Version 
Summary0004983: Desktop Icons Missing After Latest Upgrade
DescriptionI did a fresh install of Kali 2018.3 and then proceeded to update it with apt-get update && apt-get dist-upgrade and noticed after rebooting, my desktop icons were gone and I was unable to left-click and drag my mouse on the background to create a selection box. This happened with both the VMware image, as well as the .ISO install.

I noticed that it only happened after the upgrade. Starting a fresh 2018.3 installation without updating will have the icons and the ability to create a selection box by dragging the mouse pointer.

Side note: Gnome Tweak Tools also doesn't have a "Desktop" tab, which it should. I attached a screenshot for easier visualization.

Relationships

has duplicate 0004988 closedrhertzog Desktop Items missings 
has duplicate 0004997 closed DESKTOP DOESN'T WORK 
has duplicate 0005004 closed Graphical desktop icons not showing 
has duplicate 0005020 closedsbrun Kali Linux desktop icons disappeared after apt-get upgrade 
related to 0005097 closedsbrun there are some problems with desktop that can't show conventional view for me 

Activities

rojdoj

rojdoj

2018-09-12 07:12

reporter  

no_desktop_tab.png (50,199 bytes)
no_desktop_tab.png (50,199 bytes)
atdtphreaker

atdtphreaker

2018-09-13 01:44

reporter   ~0009705

I'm experiencing the SAME issue. I appreciate your time, thanks.
daxueba

daxueba

2018-09-13 02:03

reporter   ~0009706

mouse right click´╝îmenu missing server items.
atdtphreaker

atdtphreaker

2018-09-13 04:44

reporter  

Screenshot from 2018-09-13 00-03-35-dualboot_root.png (830,379 bytes)
atdtphreaker

atdtphreaker

2018-09-13 04:44

reporter  

Screenshot from 2018-09-13 00-25-07-kalilive_root.png (1,295,780 bytes)
atdtphreaker

atdtphreaker

2018-09-13 04:45

reporter  

Screenshot from 2018-09-13 00-30-45-kalilive_user.png (1,301,639 bytes)
atdtphreaker

atdtphreaker

2018-09-13 04:47

reporter   ~0009708

I uploaded 3 screenshots. Kali dual-boot (root), Kali 'Live' usb (root), Kali 'Live' usb (user).


Thanks.
rojdoj

rojdoj

2018-09-13 13:28

reporter   ~0009716

Any updates on this?
sbrun

sbrun

2018-09-13 15:16

manager   ~0009717

I confirmed the issue, it's not a Kali issue. Unfortunately the feature has been removed from nautilus.

https://csorianognome.wordpress.com/2017/12/21/nautilus-desktop-plans/
https://gitlab.gnome.org/GNOME/nautilus/issues/158#alternative-solution

Gnome people are working on an extension to replace it but it looks like they have not made a release yet and it's not packaged in Debian/Kali
https://gitlab.gnome.org/World/ShellExtensions/desktop-icons

But you can install it manually, it's available here:
https://extensions.gnome.org/extension/1465/desktop-icons/
rojdoj

rojdoj

2018-09-13 15:55

reporter   ~0009718

Thanks sbrun! I can confirm that fixed it for me. Just make sure you guys rename the UUID in the metadata.json file to the name of the folder that you place in the /.local/share/gnome-shell/extensions directory.
atdtphreaker

atdtphreaker

2018-09-13 21:30

reporter   ~0009720

@sbrun

...installed IT manually BUT found IT to be extremely limited. It's NOT 'tweakable'. BUT it will work for now.

I appreciate the feedback and time. Thanks.
filebe777

filebe777

2018-09-13 23:23

reporter   ~0009721

I experience thesame issue too. icons/folders doesn't show on Desktop, but it shows in desktop folder.
filebe777

filebe777

2018-09-13 23:35

reporter   ~0009722

the desktop-icon size from gnome is really big, how do i reduce the icons?
fl0

fl0

2018-10-02 15:44

reporter   ~0009776

The extension "desktop-icons" is stable now.

https://extensions.gnome.org/extension/1465/desktop-icons/

Could you package it ?
LeeRock

LeeRock

2018-10-02 20:08

reporter   ~0009778

I am able to create new files and folders on the Desktop, but unable to see them.

I can see the content of the Desktop by doing the following:
1. Use the file Explorer.
2. ls -l /root/Desktop/
DIGITAL101

DIGITAL101

2018-10-02 20:24

reporter   ~0009779

Have you activate de extension in the extensions manager ?
atdtphreaker

atdtphreaker

2018-10-04 06:15

reporter   ~0009781

...wanted to 'touch base' ... "desktop-icons" seemed to be updated in latest update/upgrade/dist-upgrade, BUT still DO NOT appear.

*(TESTED on Kali dual-boot (root), Kali 'Live' usb (root), Kali 'Live' usb (user)).

Thank you, for your time and effort.
UN5T48L3

UN5T48L3

2018-10-05 21:41

reporter   ~0009792

I experience same issue.
Installed this extension: https://extensions.gnome.org/extension/1465/desktop-icons/

GNOME makes me sick!
sbrun

sbrun

2018-11-08 13:55

manager   ~0009932

the package gnome-shell-extension-desktop-icons is now available in kali
atdtphreaker

atdtphreaker

2018-11-10 01:27

reporter   ~0009936

The 'Desktop icons' extension has returned following ADDED "gnome-shell-extension-desktop-icons" package. (apt-get update && apt-get upgrade && apt-get dist-upgrade) *Screenshot attached (Kali dual-boot (root))

Thank you.

Screenshot from 2018-11-09 20-17-48_ Kali dual-boot (root).png (868,726 bytes)
atdtphreaker

atdtphreaker

2018-11-10 02:32

reporter  

Screenshot from 2018-11-09 21-07-41_Kali 'Live' usb (root).png (1,345,397 bytes)
atdtphreaker

atdtphreaker

2018-11-10 02:32

reporter   ~0009937

* Screenshots attached showing (Kali 'Live' usb (root)) + (Kali 'Live' usb (user)) 'Desktop icons' extension WORKING...

Screenshot from 2018-11-09 21-07-41_Kali 'Live' usb (root).png
Screenshot from 2018-11-09 21-15-15_Kali 'Live' usb (user).png

Screenshot from 2018-11-09 21-15-15_Kali 'Live' usb (user).png (1,366,898 bytes)
sbrun

sbrun

2018-11-12 14:59

manager   ~0009944

package gnome-shell-extension-desktop-icons is available in kali
And the extension is automatically installed with kali-desktop-gnome version 2019.1.0.

Issue History

Date Modified Username Field Change
2018-09-12 07:12 rojdoj New Issue
2018-09-12 07:12 rojdoj File Added: no_desktop_tab.png
2018-09-13 01:44 atdtphreaker Note Added: 0009705
2018-09-13 02:03 daxueba Note Added: 0009706
2018-09-13 04:44 atdtphreaker File Added: Screenshot from 2018-09-13 00-03-35-dualboot_root.png
2018-09-13 04:44 atdtphreaker File Added: Screenshot from 2018-09-13 00-25-07-kalilive_root.png
2018-09-13 04:45 atdtphreaker File Added: Screenshot from 2018-09-13 00-30-45-kalilive_user.png
2018-09-13 04:47 atdtphreaker Note Added: 0009708
2018-09-13 13:28 rojdoj Note Added: 0009716
2018-09-13 15:16 sbrun Assigned To => sbrun
2018-09-13 15:16 sbrun Status new => acknowledged
2018-09-13 15:16 sbrun Note Added: 0009717
2018-09-13 15:55 rojdoj Note Added: 0009718
2018-09-13 21:30 atdtphreaker Note Added: 0009720
2018-09-13 23:23 filebe777 Note Added: 0009721
2018-09-13 23:35 filebe777 Note Added: 0009722
2018-09-16 09:14 rhertzog Relationship added has duplicate 0004988
2018-09-17 14:56 g0tmi1k Relationship added has duplicate 0004997
2018-09-19 19:03 elwood Relationship added has duplicate 0005004
2018-10-02 07:33 sbrun Relationship added has duplicate 0005020
2018-10-02 15:44 fl0 Note Added: 0009776
2018-10-02 20:08 LeeRock Note Added: 0009778
2018-10-02 20:24 DIGITAL101 Note Added: 0009779
2018-10-04 06:15 atdtphreaker Note Added: 0009781
2018-10-05 21:41 UN5T48L3 Note Added: 0009792
2018-11-08 13:55 sbrun Note Added: 0009932
2018-11-10 01:27 atdtphreaker File Added: Screenshot from 2018-11-09 20-17-48_ Kali dual-boot (root).png
2018-11-10 01:27 atdtphreaker Note Added: 0009936
2018-11-10 02:32 atdtphreaker File Added: Screenshot from 2018-11-09 21-07-41_Kali 'Live' usb (root).png
2018-11-10 02:32 atdtphreaker File Added: Screenshot from 2018-11-09 21-15-15_Kali 'Live' usb (user).png
2018-11-10 02:32 atdtphreaker Note Added: 0009937
2018-11-12 14:59 sbrun Status acknowledged => resolved
2018-11-12 14:59 sbrun Resolution open => fixed
2018-11-12 14:59 sbrun Note Added: 0009944
2018-11-15 11:13 sbrun Relationship added related to 0005097