View Issue Details

IDProjectCategoryView StatusLast Update
0005036Kali Linux[All Projects] New Tool Requestspublic2018-10-08 13:59
ReporterakiAssigned To 
PrioritynormalSeverityminorReproducibilityhave not tried
Status newResolutionopen 
Product Versionkali-dev 
Target VersionFixed in Version 
Summary0005036: Replace jd-gui/jad against up-to-date decompilers.
DescriptionJD-gui (https://tools.kali.org/reverse-engineering/jd-gui) and especially jad (https://tools.kali.org/reverse-engineering/jad) are really old and outdated java decompilers that break in most cases where the bytecode slightly differs form the result of javac.

Resilient, up-to-date alternative are:
- cfr (http://www.benf.org/other/cfr/)
- procyon (https://bitbucket.org/mstrobel/procyon/wiki/Java%20Decompiler)
- fernflower (https://github.com/JetBrains/intellij-community/tree/master/plugins/java-decompiler/engine)

Activities

There are no notes attached to this issue.

Issue History

Date Modified Username Field Change
2018-10-07 11:01 aki New Issue
2018-10-07 11:01 aki Status new => assigned
2018-10-07 11:01 aki Assigned To => sbrun
2018-10-08 13:59 sbrun Assigned To sbrun =>
2018-10-08 13:59 sbrun Status assigned => new
2018-10-08 13:59 sbrun Category Tool Upgrade => New Tool Requests