View Issue Details

IDProjectCategoryView StatusLast Update
0000505Kali Linux[All Projects] General Bugpublic2013-12-28 13:42
Reporterwifi-e Assigned Tosteev  
PrioritylowSeveritytweakReproducibilityalways
Status resolvedResolutionfixed 
Product Version1.0.4 
Target VersionFixed in Version1.0.5 
Summary0000505: RT3070 drivers not working ONLY in Kali Linux RPI version
DescriptionI have a laptop and a Raspberry Pi running Kali Linux 1.0.4. It seems that Kali Linux on the Raspberry Pi does not support the Ralink 3070 chipset. On my laptop running Kali Linux 1.0.4 64-Bit the Ralink 3070 is supported.
When using lsusb I see the Ralink 3070 is recognized in the Raspberry Pi. But when using iwconfig or airmon-ng the wireless card does not show up.
Steps To ReproduceInstall Kali Linux 1.0.4 on a Raspberry Pi and insert a Ralink with chipset 3070 in it and it will not work.
Additional InformationIf you guys need any more information, please let me know and I will give it to you. My Raspberry pi can used to test everything. It is not a production RPI, so I can test and re-install as many times as I like.

Hope you guys can help me.

Activities

muts

2013-08-14 14:35

administrator   ~0000748

Can you add some debugging information such as dmesg output, etc ?

wifi-e

2013-08-14 18:27

reporter   ~0000749

Thanks for the reply. I got a clean version of the Kali linux 1.0.4. No apt-get update/upgrade or dist-upgrade, and this was result when I inserted the Ralink 3070 USB stick:


root@kali:~# dmesg | tail
smsc95xx 1-1.1:1.0: eth0: register 'smsc95xx' at usb-bcm2708_usb-1.1, smsc95xx USB 2.0 Ethernet, b8:27:eb:82:82:4a
udevd[149]: starting version 175
EXT4-fs (mmcblk0p2): re-mounted. Opts: (null)
smsc95xx 1-1.1:1.0: eth0: link up, 100Mbps, full-duplex, lpa 0xCDE1
usb 1-1.2: new high-speed USB device number 4 using dwc_otg
usb 1-1.2: New USB device found, idVendor=148f, idProduct=3070
usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1.2: Product: 802.11 n WLAN
usb 1-1.2: Manufacturer: Ralink
usb 1-1.2: SerialNumber: 1.0


root@kali:~# uname -r
3.6.11-cutdown


root@kali:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.


root@kali:~# airmon-ng


Interface Chipset Driver


root@kali:~# lsusb
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 004: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter





This is the same output, but after the apt-get update && apt-get upgrade && apt-get dist-upgrade


root@kali:~# dmesg | tail
usb 1-1.2: Manufacturer: Ralink
usb 1-1.2: SerialNumber: 1.0
smsc95xx 1-1.1:1.0: eth0: kevent 2 may have been dropped
usb 1-1.2: USB disconnect, device number 4
usb 1-1.2: new high-speed USB device number 5 using dwc_otg
usb 1-1.2: New USB device found, idVendor=148f, idProduct=3070
usb 1-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
usb 1-1.2: Product: 802.11 n WLAN
usb 1-1.2: Manufacturer: Ralink
usb 1-1.2: SerialNumber: 1.0
root@kali:~#


root@kali:~# uname -r
3.6.11-cutdown


root@kali:~# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.


root@kali:~# airmon-ng


Interface Chipset Driver


root@kali:~#



root@kali:~# lsusb
Bus 001 Device 002: ID 0424:9512 Standard Microsystems Corp.
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 003: ID 0424:ec00 Standard Microsystems Corp.
Bus 001 Device 005: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
root@kali:~#

If I can get you any more information please let me know.

wifi-e

2013-08-14 18:37

reporter   ~0000751

I did the same test with a laptop running Kali Linux 1.0.4 after I did apt-get update && apt-get upgrade && apt-get dist-upgrade. This is a laptop running Kali Linux 1.0.4 64. On the laptop Ralink 3070 chipset works:

root@Kali-R:~# dmesg | tail
[ 8783.587768] usb 2-2: Product: 802.11 n WLAN
[ 8783.587775] usb 2-2: Manufacturer: Ralink
[ 8783.587782] usb 2-2: SerialNumber: 1.0
[ 8783.704379] usb 2-2: reset high-speed USB device number 5 using ehci_hcd
[ 8783.864860] ieee80211 phy3: Selected rate control algorithm 'minstrel_ht'
[ 8783.865749] Registered led device: rt2800usb-phy3::radio
[ 8783.865809] Registered led device: rt2800usb-phy3::assoc
[ 8783.865875] Registered led device: rt2800usb-phy3::quality
[ 8783.907136] rt2800usb 2-2:1.0: firmware: agent loaded rt2870.bin into memory
[ 8784.287208] IPv6: ADDRCONF(NETDEV_UP): wlan1: link is not ready
root@Kali-R:~# iwconfig
hso0 no wireless extensions.

wlan1 IEEE 802.11bgn ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=20 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:on
          
eth0 no wireless extensions.

lo no wireless extensions.

wlan0 IEEE 802.11abgn ESSID:off/any
          Mode:Managed Access Point: Not-Associated Tx-Power=14 dBm
          Retry long limit:7 RTS thr:off Fragment thr:off
          Encryption key:off
          Power Management:off
          
root@Kali-R:~# airmon-ng


Interface Chipset Driver

wlan1 Ralink RT2870/3070 rt2800usb - [phy3]
wlan0 Intel 5300AGN iwlwifi - [phy0]

root@Kali-R:~# uname -r
3.7-trunk-amd64
root@Kali-R:~# lsusb
Bus 001 Device 004: ID 5986:0240 Acer, Inc
Bus 002 Device 005: ID 148f:3070 Ralink Technology, Corp. RT2870/RT3070 Wireless Adapter
Bus 002 Device 003: ID 0af0:7601 Option Globetrotter MO40x 3G Modem (GTM 382)
Bus 004 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)
Bus 005 Device 002: ID 0b97:7761 O2 Micro, Inc. Oz776 1.1 Hub
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 006 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 007 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 008 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 003: ID 0b97:7772 O2 Micro, Inc. OZ776 CCID Smartcard Reader
root@Kali-R:~#

Hope this information is useful.

wifi-e

2013-08-19 11:25

reporter   ~0000763

Hi guys,

i did some more testing this weekend. I got several WiFi dongles and it seemed that none of the dongles worked on my RPI in combination with the 1.0.4 version of Kali Linux. I downloaded Kali Linux 1.0 for the RPI and all my dongles worked right away.
After that I did a apt-get update && apt-get upgrade && apt-get dist-upgrade and everything still worked. I gave a reboot of the system and still everything worked ok.
I will download Kali Linux 1.0.4. Maybe there was something wrong with my download of the image. I will keep you up to date on my findings.

wifi-e

2013-08-20 10:29

reporter   ~0000771

Last edited: 2013-08-20 10:31

View 3 revisions

I did a test yesterday and there was nothing wrong with the 1.0.4 image I was using, but the wireless dongles still did not work. This is the work around:

Best way to use Kali Linux for the Raspberry Pi is to download Kali Linux at http://cdimage.kali.org/kali-images/ and choose kali-linux-1.0-armel-raspberrypi.img.gz.
After booting from that image, do a apt-get update && apt-get upgrade -y && apt-get dist-upgrade - y.
Now you should have a working up to date Kali Linux version for all your wireless security scans.

steev

2013-08-26 04:15

developer   ~0000792

The issue is the 1.0.4 on the website was generated incorrectly by myself (I forgot to install the modules) - there will be a new one posted soon.

wifi-e

2013-08-26 10:36

reporter   ~0000793

Thanks for the reply. Great to see you found out what was wrong with the 1.0.4 version. Looking forward to the update.

silentvuer

2013-09-03 02:19

reporter   ~0000820

Any updates on installing the modules in 1.0.4? I believe this will resolve my problem as well.

steev

2013-09-05 18:10

developer   ~0000823

Thanks again for the report, 1.0.5 is out with the fix.

Issue History

Date Modified Username Field Change
2013-08-14 12:01 wifi-e New Issue
2013-08-14 14:35 muts Note Added: 0000748
2013-08-14 18:27 wifi-e Note Added: 0000749
2013-08-14 18:37 wifi-e Note Added: 0000751
2013-08-19 11:25 wifi-e Note Added: 0000763
2013-08-20 10:29 wifi-e Note Added: 0000771
2013-08-20 10:30 wifi-e Note Edited: 0000771 View Revisions
2013-08-20 10:31 wifi-e Note Edited: 0000771 View Revisions
2013-08-26 04:15 steev Note Added: 0000792
2013-08-26 10:36 wifi-e Note Added: 0000793
2013-09-03 02:19 silentvuer Note Added: 0000820
2013-09-05 18:10 steev Note Added: 0000823
2013-09-05 18:10 steev Fixed in Version => 1.0.5
2013-09-05 18:11 steev Status new => resolved
2013-09-05 18:11 steev Resolution open => fixed
2013-09-05 18:11 steev Assigned To => steev
2013-09-21 05:11 thrasher12ga Issue cloned: 0000604