View Issue Details

IDProjectCategoryView StatusLast Update
0005063Kali Linux[All Projects] General Bugpublic2019-09-04 13:52
Reportersteev Assigned Tosteev  
PrioritynormalSeverityminorReproducibilityhave not tried
Status assignedResolutionopen 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005063: firefox-esr segfaults on arm64
DescriptionWhen launching firefox-esr on arm64 (tested on odroid-c2 and raspberrypi3 in 64bit mode) it simply crashes with a segfault.

This has happened ever since the upgrade to 60. I have tried the different upgrades from Debian, including 60.1.x, 60.2.x and 60.3.x and they all have the same issue.

What did work for me was taking the version from Debian stretch, which relies on an older libvpx and an older libevent-2 than the versions we have.

Debian stretch versions:

Does not work:
Kali versions:



2018-10-31 23:44

developer   ~0009887

Also, there is already an upstream Debian bug regarding failures of firefox-esr on arm64, it's debian bug #906570


2019-09-04 12:36

administrator   ~0011015

Due to the age of the OS (Kali Moto [v1], Kali Safi [v2], Kali Rolling <= 2018.4), these legacy versions are no longer supported.
We will be closing this ticket due to inactivity.

Please could you see if you are able to replicate this issue with the latest version of Kali Linux -

If you are still facing the same problem, feel free to re-open the ticket. If you choose to do this, could you provide more information to the issue you are facing, and also give information about your setup?
For more information, please read:

Issue History

Date Modified Username Field Change
2018-10-31 23:26 steev New Issue
2018-10-31 23:44 steev Note Added: 0009887
2019-09-04 12:36 g0tmi1k Note Added: 0011015
2019-09-04 12:36 g0tmi1k Status new => closed
2019-09-04 13:52 rhertzog Assigned To => steev
2019-09-04 13:52 rhertzog Status closed => assigned