View Issue Details

IDProjectCategoryView StatusLast Update
0005182Kali Linux[All Projects] General Bugpublic2019-01-17 14:03
Reporterj_jitoAssigned Torhertzog 
PriorityurgentSeveritycrashReproducibilityalways
Status closedResolutionwon't fix 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005182: Gnome-Control-Center crash when go to Thunderbolt section
DescriptionWhen I go to Thunderbolt section in gnome-control-center, it crashed immediately.
Steps To ReproduceThis is what I get:

dmesg -w
gnome-control-center -v
Additional InformationI tried to reinstall libglib2.0-dev, libglib2.0-0 and gnome-settings-daemon "apt install --reinstall libglib2.0-0 libglib2.0-dev gnome-settings-daemon" and I even restarted my PC, but it continues to crash with the same error.

Activities

j_jito

2018-12-30 12:27

reporter  

2018-12-30_13-24.png (32,100 bytes)
2018-12-30_13-24.png (32,100 bytes)
2018-12-30_13-24_1.png (20,360 bytes)
2018-12-30_13-24_1.png (20,360 bytes)

j_jito

2018-12-30 12:30

reporter   ~0010133

Please remove the issue, I've just resolved it by unmasking bolt.service

Everything is working now

rhertzog

2018-12-30 16:50

administrator   ~0010134

No need to close the bug, we should rather enable the "bolt" service by default. It doesn't interact with the network so doesn't need to be masked by default.

j_jito

2018-12-31 19:19

reporter   ~0010135

I agree with you on that.

The bolt.service was active, but I masked it because my laptop hasn't any USB C ports.

rhertzog

2019-01-17 14:03

administrator   ~0010224

There's nothing I can fix on my side in that case. It's a service that gets activated by dbus and the enabled by default status doesn't change much here. The problem was really the fact that you masked the unit. So closing the ticket.

Issue History

Date Modified Username Field Change
2018-12-30 12:27 j_jito New Issue
2018-12-30 12:27 j_jito File Added: 2018-12-30_13-24.png
2018-12-30 12:27 j_jito File Added: 2018-12-30_13-24_1.png
2018-12-30 12:30 j_jito Note Added: 0010133
2018-12-30 16:49 rhertzog Assigned To => rhertzog
2018-12-30 16:49 rhertzog Status new => assigned
2018-12-30 16:50 rhertzog Note Added: 0010134
2018-12-31 19:19 j_jito Note Added: 0010135
2019-01-17 14:03 rhertzog Status assigned => closed
2019-01-17 14:03 rhertzog Resolution open => won't fix
2019-01-17 14:03 rhertzog Note Added: 0010224