View Issue Details

IDProjectCategoryView StatusLast Update
0005183Kali Linux[All Projects] General Bugpublic2019-01-08 21:00
ReporterJesbel johnsonAssigned To 
PriorityurgentSeveritymajorReproducibilityalways
Status newResolutionopen 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005183: kali linux login gray screen
Descriptionwhen i installed kali linux it get installed properly. But when i enter the username and password in the login page produce gray screen error .sir i have attached an image of the error kindly check it and help to fix the error.

Relationships

has duplicate 0005188 closedrhertzog Installed the latest version of kali. No problem then grey screen, stuck on it. 

Activities

Jesbel johnson

2018-12-31 02:37

reporter  

IMG_20181231_075600.jpg (724,595 bytes)

wwwy

2019-01-03 19:05

reporter   ~0010143

Same here, everything works fine till I try to update it to latest version. Reset everything tried again. Still same issues as you. Need help.

rhertzog

2019-01-03 20:24

administrator   ~0010146

Are you able to pin-point the problem to a specific package upgrade? Can you go back to the working versionand upgrade only some packages at a time until you find the one that introduces this problem for you?

Start first with the kernel, then maybe gdm3, then maybe Xorg.

wwwy

2019-01-03 21:40

reporter   ~0010147

I'm updating it again in a fresh install, there's a problem with "dpkg directory already exists" If that has anything to do with it. I'm going to try...
login to tty1
apt-get update
apt-get upgrade -y
apt-get install -f gdm3
But the problem is when I'm on the gray screen I can't get my terminal to open, there's no mouse. So I'm pretty stuck.

wwwy

2019-01-03 21:42

reporter   ~0010148

Coming up with a lot of dpkg warnings. Unanle to delete old directory /etc/kernal/signed_postinst.d directory not empty. A few other warnings as well could it be that?

wwwy

2019-01-03 21:49

reporter   ~0010149

I think I have over 40 warnings dpkg unable to delete old directory. I'm going to try to attempt to fix them.

wwwy

2019-01-04 00:05

reporter   ~0010150

Still no use, just stuck on a gray screen, can't open uo terminal. Can't do anything. Everything was fine fixed the packages I think. As soon as I shut it down and then try to start it up again gray screen. Please any advice would be highly appreciated.

wwwy

2019-01-04 01:20

reporter   ~0010151

Found out what it is... Grub installation failed. 'grub-pc' package failed to install into target.

wwwy

2019-01-04 03:16

reporter   ~0010152

After maybe 4 hours, I did it. I'm not sure if this person came to the gray screen by doing an update like I did or did a fresh install. I was updating mine just as it was about to finish it stopped because I ran out of space so I ran the command apt autoremove to clear some space then turned it off and then came to the gray screen. So I'm not sure if it was because I didn't fully finish the update or if it was because I ran that command. I tried to do a fresh install but grub wouldn't install. So I don't know if that is a separate issue or part of it. To fix the grub issue I selected no on mirror sharing then the grub installed just fine. I used a usb, but didn't select graphical install I selected install. So I don't know if I'll run back into this problem but not sure if I want to update it to the latest version just in case. Let me know if you need help. I will try to help because I tried everything out there. In a way I enjoy these problems just hate it when I can't fix it. Can you suggest how I can clear space for the OS next time properly because that command probably deleted some essential things :)

wwwy

2019-01-04 13:31

reporter   ~0010154

Update, something to do with the update. Update installed fine won't allow me to login or do anything just a gray screen.

wwwy

2019-01-04 15:14

reporter   ~0010156

Fixed it by adding the nomodest into the code just before booting up into it. But now it's like the screen shot this person added glitchy it just about loads in.

Jesbel johnson

2019-01-06 02:20

reporter   ~0010165

sir can u give your email address I will send the video of error .

Jesbel johnson

2019-01-06 02:23

reporter   ~0010166

sir I have installed old version of kali 2016 and kali Linux kde 2018.4 all works properly.
sir how to add nomodset in the bootloader

wwwy

2019-01-06 19:42

reporter   ~0010168

Does the new version work for you now? It only works for me after I added the nomodest but it still is very glitchy I don't think this is a permanent solution. I forgot how I did it but when you load in and you can choose kali or advanced options. Select kali then press e and I think it's the line that starts with Linux but you put it at the end. This won't be saved though you have to edit it and save it through terminal but I forgot. Search it online. You'll find it if you don't let me know and I'll try to help you.

wwwy

2019-01-06 19:43

reporter   ~0010169

I don't know why we have this problem though I think our bootloaders are broken.

wwwy

2019-01-08 21:00

reporter   ~0010179

This is the reason why it doesn't work.
nomodeset
The newest kernels have moved the video mode setting into the kernel. So all the programming of the hardware specific clock rates and registers on the video card happen in the kernel rather than in the X driver when the X server starts.. This makes it possible to have high resolution nice looking splash (boot) screens and flicker free transitions from boot splash to login screen. Unfortunately, on some cards this doesnt work properly and you end up with a black screen. Adding the nomodeset parameter instructs the kernel to not load video drivers and use BIOS modes instead until X is loaded.

Issue History

Date Modified Username Field Change
2018-12-31 02:37 Jesbel johnson New Issue
2018-12-31 02:37 Jesbel johnson File Added: IMG_20181231_075600.jpg
2019-01-03 19:03 wwwy Issue cloned: 0005187
2019-01-03 19:05 wwwy Note Added: 0010143
2019-01-03 20:21 rhertzog Relationship added has duplicate 0005188
2019-01-03 20:24 rhertzog Note Added: 0010146
2019-01-03 21:40 wwwy Note Added: 0010147
2019-01-03 21:42 wwwy Note Added: 0010148
2019-01-03 21:49 wwwy Note Added: 0010149
2019-01-04 00:05 wwwy Note Added: 0010150
2019-01-04 01:20 wwwy Note Added: 0010151
2019-01-04 03:16 wwwy Note Added: 0010152
2019-01-04 13:31 wwwy Note Added: 0010154
2019-01-04 15:14 wwwy Note Added: 0010156
2019-01-06 02:20 Jesbel johnson Note Added: 0010165
2019-01-06 02:23 Jesbel johnson Note Added: 0010166
2019-01-06 19:42 wwwy Note Added: 0010168
2019-01-06 19:43 wwwy Note Added: 0010169
2019-01-07 09:19 jauharvp Issue cloned: 0005196
2019-01-08 21:00 wwwy Note Added: 0010179