View Issue Details

IDProjectCategoryView StatusLast Update
0005252Kali Linux[All Projects] Kali Package Bugpublic2019-03-08 13:09
ReporterfahimpavelAssigned Tosbrun 
PriorityurgentSeveritymajorReproducibilityalways
Status closedResolutionno change required 
Product Version2018.4 
Target VersionFixed in Version 
Summary0005252: wpscan is not running and showing loaderror.
DescriptionI have tried all supporting tools but got stuck . I uninstalled wpscan from gem, cleaned it up and again installed from kali repo. But it's not working. Details of that message is below:


1. gem uninstall wpscan

2. apt remove wpscan

3. apt-get autoremove

4. apt-get autoclean

5. apt install wpscan


wpscan
Traceback (most recent call last):
25: from /usr/bin/wpscan:23:in <main>' 24: from /usr/bin/wpscan:23:in load'
23: from /usr/share/rubygems-integration/all/gems/wpscan-3.4.4/bin/wpscan:3:in <top (required)>' 22: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require'
21: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require' 20: from /usr/share/rubygems-integration/all/gems/wpscan-3.4.4/lib/wpscan.rb:5:in <top (required)>'
19: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require' 18: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require'
17: from /usr/lib/ruby/vendor_ruby/active_support/all.rb:5:in <top (required)>' 16: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require'
15: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require' 14: from /usr/lib/ruby/vendor_ruby/active_support/core_ext.rb:3:in <top (required)>'
13: from /usr/lib/ruby/vendor_ruby/active_support/core_ext.rb:3:in each' 12: from /usr/lib/ruby/vendor_ruby/active_support/core_ext.rb:4:in block in <top (required)>'
11: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require' 10: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require'
9: from /usr/lib/ruby/vendor_ruby/active_support/core_ext/big_decimal.rb:3:in <top (required)>' 8: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require'
7: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require' 6: from /usr/lib/ruby/vendor_ruby/active_support/core_ext/big_decimal/conversions.rb:4:in <top (required)>'
5: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require' 4: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:59:in require'
3: from /var/lib/gems/2.5.0/gems/bigdecimal-1.4.3/lib/bigdecimal/util.rb:9:in <top (required)>' 2: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:39:in require'
1: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:135:in rescue in require' /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:135:in require': /var/lib/gems/2.5.0/gems/bigdecimal-1.4.3/lib/bigdecimal/util.so: undefined symbol: rmpd_util_str_to_d - /var/lib/gems/2.5.0/gems/bigdecimal-1.4.3/lib/bigdecimal/util.so (LoadError)
Additional InformationI have tried also with bundle and rake install, active support. But it's not working in kali os.

Activities

sbrun

2019-02-13 16:10

manager   ~0010294

I think you still have gems installed with "gem install" on your system and they conflict with the system packages.
See the line:
"3: from /var/lib/gems/2.5.0/gems/bigdecimal-1.4.3/lib/bigdecimal/util.rb:9:in <top (required)>' 2: from /usr/lib/ruby/2.5.0/rubygems/core_ext/kernel_require.rb:39:in require'"
In Kali it's installed in /usr/lib/ruby/

Remove the gem bigdecimal in var/lib/gems/2.5.0/gems and try again wpscan.

sbrun

2019-03-08 13:09

manager   ~0010406

issue caused by manual installation.

Issue History

Date Modified Username Field Change
2019-02-13 10:52 fahimpavel New Issue
2019-02-13 16:10 sbrun Assigned To => sbrun
2019-02-13 16:10 sbrun Status new => feedback
2019-02-13 16:10 sbrun Note Added: 0010294
2019-03-08 13:09 sbrun Status feedback => closed
2019-03-08 13:09 sbrun Resolution open => no change required
2019-03-08 13:09 sbrun Note Added: 0010406