View Issue Details

IDProjectCategoryView StatusLast Update
0005359Kali Linux[All Projects] Kali Package Bugpublic2019-03-25 13:51
Reporterfl0 Assigned Tosbrun  
PriorityhighSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.1 
Target VersionFixed in Version 
Summary0005359: bundler 1.17.3-3 packages break metasploit
DescriptionSince bundler and ruby-bundler update to 1.17.3-3, msfconsole does not start anymore
Steps To Reproduce# apt update && apt dist-upgrade -y
# msfconsole
[*] Metasploit requires the Bundler gem to be installed
    $ gem install bundler
Additional InformationQuick fix:
# gem install bundler -v 1.17.2
Fetching: bundler-1.17.2.gem (100%)
Successfully installed bundler-1.17.2
Parsing documentation for bundler-1.17.2
Installing ri documentation for bundler-1.17.2
Done installing documentation for bundler after 6 seconds
1 gem installed

Activities

fl0

2019-03-20 15:57

reporter   ~0010430

Maybe the newly released 5.0.12 fix the issue.
https://github.com/rapid7/metasploit-framework/releases

rhertzog

2019-03-20 21:37

administrator   ~0010431

We confirm the issue. Until we can figure out the problem and a fix, we have put back an old version of bundler in kali-rolling (1.16.1-3). The issue is introduced by the way bundler is packaged in 1.17.3-3. It moved the files from the usual /usr/lib/ruby/ to /usr/share/rubygems-integrations/all/gems/

sbrun

2019-03-25 13:51

manager   ~0010439

fixed with metasploit-framework version 5.0.12-0kali1

Issue History

Date Modified Username Field Change
2019-03-20 15:55 fl0 New Issue
2019-03-20 15:57 fl0 Note Added: 0010430
2019-03-20 21:31 rhertzog Assigned To => sbrun
2019-03-20 21:31 rhertzog Status new => assigned
2019-03-20 21:37 rhertzog Note Added: 0010431
2019-03-25 13:51 sbrun Status assigned => resolved
2019-03-25 13:51 sbrun Resolution open => fixed
2019-03-25 13:51 sbrun Note Added: 0010439