View Issue Details

IDProjectCategoryView StatusLast Update
0000550Kali Linux[All Projects] New Tool Requestspublic2020-03-18 17:41
Reporterdookie Assigned To 
PrioritynormalSeverityfeatureReproducibilityhave not tried
Status closedResolutionsuspended 
Product Version 
Target VersionFixed in Version 
Summary0000550: darm - Efficient ARMv7 Disassembler
DescriptionThis project looks promising.

Darm is a lightweight and efficient Disassembler for the ARMv7 Instruction Set.
Darm has been written in C and features bindings for Python (Ruby upcoming!)
Darm is licensed under the 3-BSD license (also known as Simplified BSD.)
Darm is working towards full ARMv7 support (but is not yet there.)

Homepage: http://darm.re/
Code: https://github.com/jbremer/darm

Activities

dookie

2013-08-28 19:58

administrator   ~0000809

We'll hold off on this until it matures a bit more and has an actual install routine.

g0tmi1k

2018-01-29 14:50

administrator   ~0008376

To help speed up the process of evaluating the tool, please make sure to include the following information (the more information you include, the more beneficial it will for us):

- [Name] - The name of the tool
- [Version] - What version of the tool should be added?
--- If it uses source control (such as git), please make sure there is a release to match (e.g. git tag)
- [Homepage] - Where can the tool be found online? Where to go to get more information?
- [Download] - Where to go to get the tool?
- [Author] - Who made the tool?
- [Licence] - How is the software distributed? What conditions does it come with?
- [Description] - What is the tool about? What does it do?
- [Dependencies] - What is needed for the tool to work?
- [Similar tools] - What other tools are out there?
- [How to install] - How do you compile it?
- [How to use] - What are some basic commands/functions to demonstrate it?

g0tmi1k

2020-03-18 17:41

administrator   ~0012439

No response since 2018 (2 years).... Closing.

Please reopen if the information can be provided.

Issue History

Date Modified Username Field Change
2013-08-28 11:57 dookie New Issue
2013-08-28 19:58 dookie Target Version => 1.0.6
2013-08-28 19:58 dookie Note Added: 0000809
2018-01-29 10:22 g0tmi1k Summary Add darm - Efficient ARMv7 Disassembler => darm - Efficient ARMv7 Disassembler
2018-01-29 14:50 g0tmi1k Note Added: 0008376
2018-02-21 09:34 g0tmi1k Target Version 1.0.6 =>
2019-12-09 13:30 g0tmi1k Severity minor => feature
2020-03-18 17:41 g0tmi1k Status new => closed
2020-03-18 17:41 g0tmi1k Resolution open => suspended
2020-03-18 17:41 g0tmi1k Note Added: 0012439