View Issue Details

IDProjectCategoryView StatusLast Update
0005526Kali Linux[All Projects] New Tool Requestspublic2019-06-13 14:28
Reportergcla Assigned Tosbrun  
PrioritynormalSeverityfeatureReproducibilityN/A
Status resolvedResolutionfixed 
Product Version2019.2 
Target VersionFixed in Version 
Summary0005526: termshark - a terminal UI for tshark
Description- [Name] - termshark
- [Version] - 1.0.0
- [Homepage] - https://termshark.io
- [Download] - https://github.com/gcla/termshark/releases
- [Author] - Graham Clark
- [Licence] - MIT - https://github.com/gcla/termshark/blob/master/LICENSE
- [Description] - termshark - a terminal UI for tshark, inspired by Wireshark
- [Dependencies] - tshark
- [Similar tools] - wireshark
- [How to install] - https://github.com/gcla/termshark#building
- [How to use] - ./termshark -i eth0, ./termshark -r my.pcap

Termshark is written in golang, and is most easily compiled using golang >= 1.11 (i.e. golang with modules). In brief:

export GO111MODULE=on
export GOPATH=/tmp/termshark
mkdir -p $GOPATH
cd $GOPATH
go get -d -v github.com/gcla/termshark@v1.0.0
go build -ldflags="-X github.com/gcla/termshark.Version=1.0.0" github.com/gcla/termshark/cmd/termshark

The binary will be $GOPATH/termshark. That's all that needs to be shipped.

Termshark depends on tshark at runtime, so tshark is a dependency.

I'm the author of termshark and more than happy to help with the work required to package termshark for Kali linux. If it helps, there is already a debian package for termshark in unstable here: https://packages.debian.org/sid/termshark.

Activities

gcla

2019-06-09 21:54

reporter   ~0010661

Apologies, here are updated build instructions.

export GO111MODULE=on
cd /tmp/
git clone https://github.com/gcla/termshark
cd termshark
git checkout v1.0.0
go install -ldflags="-X github.com/gcla/termshark.Version=1.0.0" ./...

j_jito

2019-06-11 06:41

reporter   ~0010669

Termshark will not work, unless kali update wireshark to 3.0.2
This is the error I get when I launch it:

panic: runtime error: index out of range
goroutine 1 [running]:
main.makePacketListModel(0xc0000ee000, 0x4, 0xa, 0xc001ee0a60, 0x1, 0x1, 0xb45e20, 0xc000490000, 0xc0001c4c20)
    /usr/gocode/src/github.com/gcla/termshark/cmd/termshark/termshark.go:1531 +0x721
main.updatePacketListWithData(0xc0000ee000, 0x4, 0xa, 0xc001ee0a60, 0x1, 0x1, 0xb45e20, 0xc000490000)
    /usr/gocode/src/github.com/gcla/termshark/cmd/termshark/termshark.go:1538 +0x7e
main.updatePacketViews.BeforeBegin.func1.1.1.1(0xb45e20, 0xc000490000)
    /usr/gocode/src/github.com/gcla/termshark/cmd/termshark/termshark.go:1050 +0xd0
github.com/gcla/gowid.RunFunction.RunThenRenderEvent(0xab8d50, 0xb45e20, 0xc000490000)
    /usr/gocode/src/github.com/gcla/gowid/app.go:720 +0x3a
github.com/gcla/gowid.(*App).RunThenRenderEvent(0xc000490000, 0xb39680, 0xab8d50)
    /usr/gocode/src/github.com/gcla/gowid/app.go:600 +0x47
main.cmain(0x0)
    /usr/gocode/src/github.com/gcla/termshark/cmd/termshark/termshark.go:3124 +0x61f2
main.main()
    /usr/gocode/src/github.com/gcla/termshark/cmd/termshark/termshark.go:2111 +0x4b

Github issue: https://github.com/gcla/termshark/issues/19

sbrun

2019-06-11 07:07

manager   ~0010671

As termshark is now in Debian Unstable, we don't need to package it in Kali.
The Debian packages are automatically imported in kali-rolling when they are in Debian Testing.

We don't have wireshark version >= 3 in Kali for the moment. We will import the Debian package version 3.0.2-1~exp0
when it will be available.
Then we can import manually termshark in Kali (the migration to Debian Testing might be long due to the freeze)

gcla

2019-06-13 03:06

reporter   ~0010684

Thanks for the information. @j_lito - sorry, I didn't notice that github issue. I'll open it again - I don't believe version 3 of wireshark is necessary. I tested with tshark as old as 1.10.2, and am running happily now myself with 2.6.8. So I think something else might be going wrong when running termshark on your system. I'll ask more questions about that issue on github.

@sbrun - assuming termshark has no dependency on v3 of wireshark, would that change any potential plan for adding termshark to kali linux? Would it still be best to rely on termshark coming for "free" with debian testing -> kali rolling? Thanks!

gcla

2019-06-13 03:07

reporter   ~0010685

Sorry @j_jito, I mistyped your username!

j_jito

2019-06-13 07:07

reporter   ~0010687

@gcla, I replied to the opened issue on your github page.

https://github.com/gcla/termshark/issues/19

sbrun

2019-06-13 14:28

manager   ~0010690

@gcla I just imported termshark in Kali.
I quickly tested the package and don't reproduce the issue even if wireshark version is lower than 3.*

Issue History

Date Modified Username Field Change
2019-06-09 21:35 gcla New Issue
2019-06-09 21:54 gcla Note Added: 0010661
2019-06-11 06:41 j_jito Note Added: 0010669
2019-06-11 07:00 sbrun Assigned To => sbrun
2019-06-11 07:00 sbrun Status new => assigned
2019-06-11 07:07 sbrun Note Added: 0010671
2019-06-13 03:06 gcla Note Added: 0010684
2019-06-13 03:07 gcla Note Added: 0010685
2019-06-13 07:07 j_jito Note Added: 0010687
2019-06-13 14:28 sbrun Note Added: 0010690
2019-06-13 14:28 sbrun Status assigned => resolved
2019-06-13 14:28 sbrun Resolution open => fixed