View Issue Details

IDProjectCategoryView StatusLast Update
0005572Kali Linux[All Projects] General Bugpublic2019-07-01 01:33
ReporterzubairdroidAssigned To 
PriorityhighSeverityminorReproducibilityalways
Status newResolutionopen 
Product Version2019.2 
Target VersionFixed in Version 
Summary0005572: packet injection not working on rtl8xxxu driver in kali arm for raspberry pi 3b
Descriptionthe driver rtl8xxxu does currently not support packet injection with the chip rtl8192eu.the re4son kernel website states that packet injection is available for this chip
the chip goes into monitor mode and is able to monitor packets however when packet injection is tried nothing seems to happen and deauth and many other packets are not sent.the chip is also not able to connect to access points, the network manger shows that the handshake is taking place however it never connects. different access points tried but to no avail.also the chip is showing that it only supports monitor and managed but with kimocoder's driver installed the chip supports additional modes such as master and many other. it however with kimocode's driver loses the ability to go into monitor mode saying operation not supported.
Steps To Reproduceflash a 32bit or 64 bit image for raspberry pi 3.and all the above mentioned problems will be present

Activities

Mister_X

2019-07-01 01:33

reporter   ~0010755

There might be some confusion, I'm pretty sure that chipset is handled by another driver.

Could you paste the output of 'airmon-ng' (with no parameters) as well as 'lsusb' when the adapter is plugged?

Note: the 64 bit image is experimental, so do that on the 32bit.

Issue History

Date Modified Username Field Change
2019-07-01 01:02 zubairdroid New Issue
2019-07-01 01:33 Mister_X Note Added: 0010755