View Issue Details

IDProjectCategoryView StatusLast Update
0005581Kali Linux[All Projects] Kali Package Bugpublic2019-07-09 18:20
ReporterBarackoAssigned Tosteev 
PriorityurgentSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.2 
Target VersionFixed in Version2019.3 
Summary0005581: Impossible to setup VNC connection fatal error
DescriptionToday (7-7-2019) downloaded and installed Kali 2019.2 32bit on Rpi 3b.

Out of the box, even after apt-get update and apt-get upgrade there was no way to setup a VNC via SSH.

It took me 5(!) hours to figure out what the issue was, tried tons of suggestions elsewhere online and Youtube videos.
Tried 3 different VNC servers, just couldn't get it running, tightvnc, Realvnc, X11vnc.

Then i signed up on the kali forums and before creating a thread myself for it i found out other people having exact the same issue and error, described in this thread https://forums.kali.org/showthread.php?44565-Problem-with-vncserver-running-Kali-2019-2-arm32-bit

So this looks like a general bug in 2019.2 at least for the 32bit version.

The error the drove me nuts for 5 hours was:

Font directory '/usr/share/fonts/X11/Speedo/' not found - ignoring

Fatal server error:
could not open default font 'fixed'


SOLUTION ====> https://forums.kali.org/showthread.php?44565-Problem-with-vncserver-running-Kali-2019-2-arm32-bit&p=86493#post86493

So my suggestion would be to add this command to the Kali installe:

dpkg-reconfigure xfonts-base
Steps To ReproduceInstall 2019.2 32bit on a clean SD and try to start/setup any VNC.
Additional InformationSOLUTION ====> https://forums.kali.org/showthread.php?44565-Problem-with-vncserver-running-Kali-2019-2-arm32-bit&p=86493#post86493

So my suggestion would be to add this command to the Kali installe:

dpkg-reconfigure xfonts-base

Activities

steev

2019-07-09 08:56

developer   ~0010771

Added as https://gitlab.com/kalilinux/build-scripts/kali-arm/issues/164 to the build scripts, will add to the script tomorrow so it will make it into the 2019.3 release.

steev

2019-07-09 18:20

developer   ~0010777

https://gitlab.com/kalilinux/build-scripts/kali-arm/commit/32166f666665403828cbdb11e617b0109308a690 is the commit to add the reconfigure.

Thanks for the report. Pull requests to add fixes like this are always welcome as well!

Issue History

Date Modified Username Field Change
2019-07-07 21:46 Baracko New Issue
2019-07-09 08:56 steev Assigned To => steev
2019-07-09 08:56 steev Status new => assigned
2019-07-09 08:56 steev Note Added: 0010771
2019-07-09 18:20 steev Status assigned => resolved
2019-07-09 18:20 steev Resolution open => fixed
2019-07-09 18:20 steev Fixed in Version => 2019.3
2019-07-09 18:20 steev Note Added: 0010777