View Issue Details

IDProjectCategoryView StatusLast Update
0005597Kali Linux[All Projects] General Bugpublic2019-08-17 11:05
ReporternixuserAssigned Torhertzog 
PrioritynormalSeveritymajorReproducibilityalways
Status resolvedResolutionfixed 
Product Version2019.2 
Target VersionFixed in Version 
Summary0005597: vlc seg faults on launch
DescriptionFresh install of Kali, and installed vlc. On launch vlc produces a segmentation fault.

kali$ vlc
VLC media player 3.0.7.1 Vetinari (revision 3.0.7.1-0-gf3940db4af)
[000055f6d98ab750] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Segmentation fault
kali$
Steps To Reproduce1. Install vlc from default repo.
2. Try to launch it.
Additional InformationFrom /var/log/messages:

Jul 25 12:37:07 kali kernel: [ 1020.733361] vlc[2618]: segfault at 1bec0 ip 000000000001bec0 sp 00007fc128b8f668 error 14 in vlc[55d660733000+1000]

Activities

apolokak

2019-07-31 06:08

reporter   ~0010809

You can run this in terminal for fix this, and run again if vlc update.
# sed -i s/geteuid/getppid/g /usr/bin/vlc

nixuser

2019-08-01 04:08

reporter   ~0010811

"sed -i s/geteuid/getppid/g /usr/bin/vlc" hasn't fixed it for me. Exact same issue.

crash

2019-08-07 13:25

reporter   ~0010817

Hi! You have two options here, but first:

Make sure you kali is totally up-to-date.
Remove the VLC: apt purge vlc
Update your Kali: apt update && apt full-upgrade && apt autoremove
Install VLC again.

Now:
1 Option: Create a regular user and run vlc or vlc-wrapper whit this user.

2 Option, run as root. By default vlc does not support run as root. But you can have a workaround

You can use any hexedit, I suggest you bless, it is in Kali repo already.
apt-get install bless

Open VLC binary using bless
bless /usr/bin/vlc
Search for the string "geteuid" and change by "getppid" ( without quotes)
Save it, and run.

In the current Kali version it is working fine:
Linux Anubis 4.19.0-kali5-amd64 0000001 SMP Debian 4.19.37-6kali1 (2019-07-22) x86_64 GNU/Linux

root@Anubis:/# vlc
VLC media player 3.0.7.1 Vetinari (revision 3.0.7.1-0-gf3940db4af)
[000055d3d954b750] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[000055d3d95463a0] main playlist: playlist is empty

See attachment

vlc-kali.png (267,001 bytes)

nixuser

2019-08-11 03:10

reporter   ~0010851

I am using Kali as a regular user, so from the above I am assuming I don't need to make the binary edit. Removed vlc with "sudo apt purge vlc" and updated the system, auto-removed and reinstalled vlc.

kali$ uname -a
Linux kali 4.19.0-kali5-amd64 0000001 SMP Debian 4.19.37-6kali1 (2019-07-22) x86_64 GNU/Linux
kali$ vlc
VLC media player 3.0.7.1 Vetinari (revision 3.0.7.1-0-gf3940db4af)
[0000562fdf092750] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
Segmentation fault
kali$

rhertzog

2019-08-15 13:18

administrator   ~0010872

I'm sorry but vlc is not a key package of Kali. And it looks like that your problem is not affecting everybody.

So we will not invest any resource in diagnosing this bug. If you want to make progress on this issue, you should at least provide a backtrace of the segfault and file this either to the upstream developers or to Debian (unless the problem is really specific to Kali, but from the information currently provided I don't see why it would be). Feel free to re-open, if you have a more detailed report (with backtrace) and if you have tested that the issue is specific to the Kali package.

nixuser

2019-08-16 06:06

reporter   ~0010891

I'm running Debian Stretch (latest updates) and Buster (latest updates) and vlc works fine on those platforms. But I understand vlc is not a focus for a dedicated purpose distro.

nixuser

2019-08-17 05:14

reporter   ~0010901

Well... as I live and breathe... Looks like whatever was causing vlc to crash and burn must have been causing issues with other packages, because the latest wave of updates has fixed vlc as well.

kali$ vlc
VLC media player 3.0.7.1 Vetinari (revision 3.0.7.1-0-gf3940db4af)
[00005613169a3750] main libvlc: Running vlc with the default interface. Use 'cvlc' to use vlc without interface.
[000056131699e3a0] main playlist: playlist is empty
QObject::~QObject: Timers cannot be stopped from another thread
kali$ uname -a
Linux kali 4.19.0-kali5-amd64 0000001 SMP Debian 4.19.37-6kali1 (2019-07-22) x86_64 GNU/Linux
kali$

Works for me now, please close the bug.

rhertzog

2019-08-17 11:05

administrator   ~0010903

Thanks, closing.

Issue History

Date Modified Username Field Change
2019-07-25 02:53 nixuser New Issue
2019-07-31 06:08 apolokak Note Added: 0010809
2019-08-01 04:08 nixuser Note Added: 0010811
2019-08-07 13:25 crash File Added: vlc-kali.png
2019-08-07 13:25 crash Note Added: 0010817
2019-08-11 03:10 nixuser Note Added: 0010851
2019-08-15 13:18 rhertzog Assigned To => rhertzog
2019-08-15 13:18 rhertzog Status new => closed
2019-08-15 13:18 rhertzog Resolution open => won't fix
2019-08-15 13:18 rhertzog Note Added: 0010872
2019-08-16 06:06 nixuser Status closed => feedback
2019-08-16 06:06 nixuser Resolution won't fix => reopened
2019-08-16 06:06 nixuser Note Added: 0010891
2019-08-17 05:14 nixuser Note Added: 0010901
2019-08-17 05:14 nixuser Status feedback => assigned
2019-08-17 11:05 rhertzog Status assigned => resolved
2019-08-17 11:05 rhertzog Resolution reopened => fixed
2019-08-17 11:05 rhertzog Note Added: 0010903