View Issue Details

IDProjectCategoryView StatusLast Update
0005615Kali Linux[All Projects] General Bugpublic2019-08-15 13:06
ReporterRadhakAssigned Torhertzog 
PriorityimmediateSeveritycrashReproducibilityalways
Status closedResolutionwon't fix 
Product Version2019.2 
Target VersionFixed in Version 
Summary0005615: Alfa AWUS036ACH with Kali
Description Intermittent disconnection of Alfa AWUS036ACH USB adapter from Kali 2019.2

I am following the OSWP course and for this I bought a Alpha AWUS036ACH USB adapter two days ago.

Plugged it into the USB 3.0 slot of my Lenovo PC running Kali Linux 2019.2 updated with the latest distribution.

I was made to understand that this card would be immediately recognized by Kali 2019.2 once plugged in. Unfortunately, I could not see the wireless adapter in Kali once plugged-in.

installed the drivers by using the following command: "apt-get install realtek-rtl88xxau-dkms".

The driver got installed and after re-boot I was able to see the wireless adapter in Kali and was able to do injection test and all other tests.

The issue is that after sometime, the adapter is disconnected automatically and can only be used again if I unplug it from the USB port and plug it back in.

I do have another Alfa card which is AWUS036NHA, which once plugged into the same USB port works flawlessly every time.

By doing this I know that my USB ports are fine but has got something to do with the driver or setting.

Would appreciate if someone could guide me through this install so that I could start using the AWUS036ACH adapter?

Activities

Mister_X

2019-08-05 13:58

reporter   ~0010814

The driver isn't developed by Kali, and using the forum is a better place for support. In any case, check 'dmesg' when the issue happens, messages could indicate what is happening.

rhertzog

2019-08-15 13:06

administrator   ~0010871

Thank you for your interest in Kali, but we are not able to deal with such hardware support problems. Please read https://kali.training/chapter-6/filing-a-good-bug-report/ first.

Please work with the upstream developers of the drivers: https://github.com/aircrack-ng/rtl8812au

Issue History

Date Modified Username Field Change
2019-08-05 05:44 Radhak New Issue
2019-08-05 13:58 Mister_X Note Added: 0010814
2019-08-15 13:06 rhertzog Assigned To => rhertzog
2019-08-15 13:06 rhertzog Status new => closed
2019-08-15 13:06 rhertzog Resolution open => won't fix
2019-08-15 13:06 rhertzog Note Added: 0010871